How to run IIS in 32 bit mode on 64 bit windows

I recently used the following KB from MS to try and run 32 bit IIS on my 64 bit windows OS.

http://support.microsoft.com/kb/894435

The issue is that the ops team gave us a 64 bit server and Business Objects runs on 32 bit only. After following the KB article above, we can't even get a basic .txt file to display through IE. I keep getting the "Service Unavailable" error. I have attached the application log error as a text file.

Has anybody had any success running 32 bit IIS on a 64 bit Windows 2003 platform? If so...what am I missing here.

Thanks!
ISAPI-error.txt
LVL 1
sqlagent007Asked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

ncheungCommented:
Try this?

Open a command prompt and navigate to the %systemdrive%\Inetpub\AdminScripts directory.

cscript.exe adsutil.vbs set W3SVC/AppPools/Enable32BitAppOnWin64 “true”


http://www.microsoft.com/technet/prodtechnol/WindowsServer2003/Library/IIS/405f5bb5-87a3-43d2-8138-54b75db73aa1.mspx?mfr=true
0
sqlagent007Author Commented:
I did that and rebooted...still not giving me "Service Unavailable". Same error as posted before in the event log. Also this on, however a separate team does the McAffee configuration.
McAffee-error.txt
0
ncheungCommented:
Did the change on the IIS bit level cause the McAfee ISAPIstub.dll error or was that pre-existing?
If it was caused by it, then I suggest reverting the bit level back to it's previous setting.

You should have an error message in your application event log complaining about a specific ISAPI filter.  The problem is that you have some ISAPI dll either set to run 32bit on a 64bit web application or vice versa.
http://support.microsoft.com/kb/895976


If you do not have applications requiring the specific filter you can comment it out from load.  The other method is to verify that you have the correct bit version of the ISAPI dll required.  Of course based on your error messages thus far it is not pointing to any specific ISAPI filter.

First verify the DLL you need to load is actually there.
You can then go into IIS metabase and 'comment' out the line where the filter is in question was referenced if you don't require it.  Good practice is to have a backup of your IIS metabase first and use an IIS metabase explorer as the file can be quite overwhelming.

An available browser can be found in the IIS resource kit.
http://www.microsoft.com/downloads/details.aspx?FamilyID=56fc92ee-a71a-4c73-b628-ade629c89499&displaylang=en
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows OS

From novice to tech pro — start learning today.