change the intranet URL of sharepoint site

Hi there,
We've migrated Sharepoint from another win2003 server origSP.domain.local to a new win2008 server newSP.domain.local using central admin backup and restore.. If works fine from the http://newSP but we need to change it's access to be http://origSP

I've followed this thread http://www.experts-exchange.com/Software/Server_Software/Web_Servers/Microsoft_IIS/Q_25340758.html using hosts file for now for DNS.. And it looks like we've run into same problem as the last author post there: when I goto http://origSP  it prompts for username/password (which doesnt work)..

I've tried replacing all applicationHost.config instances of:
<windowsAuthentication enabled="true">

to:
<windowsAuthentication enabled="true" useKernelMode="true" useAppPoolCredentials="true">


But we still cannot login to http://origSP on the local server with any of the accounts I've tried..
I haven't actively changed the authentication to Kerberos and I don't think it would've been using this before..
What do we need to do to get this runing?
edukateAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

larrbeCommented:
Hi,
there are several things you have to look for:
1. First thing check this article http://support.microsoft.com/kb/896861/en-us - this should solve your problem about being unable to login locally on the server.
2. If you want your SharePoint being reachable under a second URL check alternate access mappings, find some good info here: http://blogs.msdn.com/sharepoint/archive/2007/03/06/what-every-sharepoint-administrator-needs-to-know-about-alternate-access-mappings-part-1.aspx
3. Last thing to check is your IE security settings. By default Integrated Authentication is only enabled for the Intranet Zone so make sure you add the new URL there aswell unless you have your whole DNS zone already added.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
edukateAuthor Commented:
Thanks larrbe
What I did from the other post actually worked on any of the workstations - just not the server itself but thats not really an issue..

However our mysite URL is still http://newSP:12345/MySite
Is there a way I can change this to either http://origSP/MySite or maybe http://mysite.origSP  or something similar?
0
larrbeCommented:
HI,
just so I get this right, your only problem right now is that MySites are only available of a non standard port, right? Cause basically in your first post you were talking about authentication issues.
0
Check Out How Miercom Evaluates Wi-Fi Security!

It's not just about Wi-Fi connectivity anymore. A wireless security breach can cost your business large amounts of time, trouble, and expense. Plus, hear first-hand from Miercom on how WatchGuard's Wi-Fi security stacks up against the competition plus a LIVE demo!

edukateAuthor Commented:
yeah thats main problem - if making it run on port 80 is easiest way to allow mysites to be avail via http://mysite.origSP/*
my first post was pretty much right except for accessing via server - which is no showstopper :)
0
larrbeCommented:
Hi,
following this link should http://metahat.blogspot.com/2007/05/mysite-not-working-sharepoint-2007.html - basically create a new web application using a NEW hostheader name and then assign it inside SSP MySite settings. Make sure all alternate access mappings a setup properly. let me know if you require more info
0
edukateAuthor Commented:
thanks larrbe - I'll look into this soon
0
edukateAuthor Commented:
haven't had a chance to try this yet sorry - wil spend some time on this later this week
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft SharePoint

From novice to tech pro — start learning today.