How to Configure VLAN in a Layer 3 Cisco Switch 3750


I have configured VLANs in Cisco 2960 layer2 switches now i want to route them through a cisco layer 3 3750 switch please tell me the steps and commands.
IT-MatrixAsked:
Who is Participating?
 
GJHopkinsCommented:
Looks like VLANS 2 and 3 are not defined on L3 switch

from your config they are not listed in show vlan and they are not active on the trunk

Port        Vlans allowed and active in management domain
Fa1/0/1     1

so add

vlan 2
name vlan2

vlan 3
name vlan3

then do a show ip interface brief to check that the vlans interfce are active


Then try to  ping the VLAN interfaces on the switch  from the computers?

if routing is working you should be able to ping all vlans from both computers.

Can you then ping the computer from the switch ? If not is there any firewall running on the computer ?
0
 
Istvan KalmarHead of IT Security Division Commented:
Hi,

You need to add 'ip routing' the L3 switch, for example:

ip routing
int vlan 1
 ip address 192.168.1.1 255.255.255.0
 no shu
int vlan 2
 ip address 192.168.2.1 255.255.255.0
0
 
IT-MatrixAuthor Commented:
Dont we have to first create sub interfaces in this switch if yes what is the command for that - thanks
0
Cloud Class® Course: Python 3 Fundamentals

This course will teach participants about installing and configuring Python, syntax, importing, statements, types, strings, booleans, files, lists, tuples, comprehensions, functions, and classes.

 
GJHopkinsCommented:
and ensure that a trunk between the two switches carries all the VLANs that you want to get to the L3 switch, by default all are carried but you can restrict them if you want to

example

int Fa1/0/48
desc link to L2 switch
switchport mode trunk
switchport encapsulation dot1q

there are several variations on these commands but this basic config should get you started
0
 
GJHopkinsCommented:
no the L3 switch isn't like a router  it used SVI - switch virtual interface for interfaces in VLANS, these are created in ikalmar's config with the int vlan 1 command. Sub interfaces are used on routers to create trunk ports to switches and each vlan is defined by a sub-interface, here you just trunk between the two switches
0
 
IT-MatrixAuthor Commented:

 Which command will run first can someone write all the commands i need to do on 3750 step by step ? thanks.
0
 
IT-MatrixAuthor Commented:
Dont we need to create VTP server? in this switch
0
 
Istvan KalmarHead of IT Security Division Commented:
I sent you all commands...

If you want to configure centralizeed VLAN management you need to configure VTP server on L3 switch, and VTP clients all other swithes!
0
 
GJHopkinsCommented:
create the vlans

vlan 1
 name myvlan1

vlan 2 name
 name myvlan2

define the interfaces

p routing
int vlan 1
 ip address 192.168.1.1 255.255.255.0
 no shu
int vlan 2
 ip address 192.168.2.1 255.255.255.0

define the trunk to the L2 switch

int Fa1/0/48
desc link to L2 switch
switchport mode trunk
switchport encapsulation dot1q

on the L2 switch define the other end of the trunk

int Fa1/0/48
desc link to L3 switch
switchport mode trunk
switchport encapsulation dot1q
no shut


as ikalmar says you don't need vtp. You don't even need to define the vlans as creating the interface will create the vlan for you.

0
 
Istvan KalmarHead of IT Security Division Commented:
Please refer this page about howto configure VTP:

http://www.petri.co.il/csc_setup_a_vtp_on_cisco_switches.htm
0
 
IT-MatrixAuthor Commented:

int Fa1/0/48
desc link to L2 switch
switchport mode trunk
switchport encapsulation dot1q
The above command will be configured in L3 switch right? Please clearify

on the L2 switch define the other end of the trunk

int Fa1/0/48
desc link to L3 switch (L3 switch should i write the name of my L3 switch here or what?)
switchport mode trunk
switchport encapsulation dot1q
no shut

The  above command will be configured in L2 switch right? Please  clearify
0
 
GJHopkinsCommented:
the desc lines are descriptions you can leave them out or write what you like.

Yes you need to connect the two switches and configure the trunk between them,  the configuration is the same at both ends.

Sorry if the description lines caused confusion.
0
 
IT-MatrixAuthor Commented:

The following two commands did not work in 3750 switch

switchport mode trunk wh i run this it says : (än interface whose trunk encapsulation is auto can not be configured to trunk mode)

switchport encapsulation dot1q  - is it run in config mode it didnt work either
0
 
GJHopkinsCommented:
Sorry working from memory

 so under the interface you need to set the encapsulation first and the correct command is

int f1/0/48
switchport trunk encapsulation dot1q
switchport mode trunk
0
 
IT-MatrixAuthor Commented:
Switch#      
Switch#sh run            
Building configuration...                        

Current configuration : 3811 bytes                                  
!
version 12.2            
no service pad              
service timestamps debug datetime msec                                      
service timestamps log datetime msec                                    
no service password-encryption                              
!
hostname Switch              
!
boot-start-marker                
boot-end-marker              
!
enable password ccna                    
!
no aaa new-model                
system mtu routing 1500                      
ip subnet-zero              
!
!
!
crypto pki trustpoint HTTPS_SS_CERT_KEYPAIR                                          
 enrollment selfsigned                      
 serial-number              
 revocation-check none                      
 rsakeypair HTTPS_SS_CERT_KEYPAIR                                
!
!
crypto pki certificate chain HTTPS_SS_CERT_KEYPAIR                                                  
 certificate self-signed 01                          
  30820253 308201BC A0030201 02020101 300D0609 2A864886 F70D0101 04050030                                                                        
  3B311030 0E060355 04031307 53776974 63682E31 27300F06 03550405 13083145                                                                        
  35463843 30303014 06092A86 4886F70D 01090216 07537769 7463682E 301E170D                                                                        
  39333033 30313030 33333536 5A170D32 30303130 31303030 3030305A 303B3110                                                                        
  300E0603 55040313 07537769 7463682E 3127300F 06035504 05130831 45354638                                                                        
  43303030 1406092A 864886F7 0D010902 16075377 69746368 2E30819F 30                                                                
  2A864886 F70D0101 01050003 818D0030 81890281 8100E939 848F3204 8A39CC9B                                                                        
  91363563 DC7019BC AC5291D6 C577CF3D 4A4F57C3 FCC0A74D 2C915170 6BBF79DC                                                                        
  0AD942D0 1754449A 59E74D16 1EF5E185 76A3A1C0 31FDF6DE 550090B8 858E53D2                                                                        
  AAB9BA8E F1F538F6 87FAE34C 9B31918F 05F05BBC A3F2DAD3 2BDA10E7 2D8D513A                                                                        
  1C71E68A 7ACF261A D902ADBD 234A04F2 AAD31CDF 8EE10203 010001A3 67306530                                                                        
  0F060355 1D130101 FF040530 030101FF 30120603 551D1104 0B300982 07537769                                                                        
  7463682E 301F0603 551D2304 18301680 140AC2AC 0A65C279 89B4FE66 DA39F0                                                                      
  3F94BBCD D7301D06 03551D0E 04160414 0AC2AC0A 65C27989 B4FE66DA 39F0953F                                                                        
  94BBCDD7 300D0609 2A864886 F70D0101 04050003 81810019 7A04B749 1EA664C3                                                                        
  1209D9EB C3AE7AA9 AAFA986A 1D81F898 32A860B9 0A9AC4AD 2A26DD8D 2B99E077                                                                        
  2AA15903 6727B9E5 ACE2F849 156C329C 561C11CB 2CD62FD8 596CA862 6EEE5DBA                                                                        
  CC24B20B 11C370F3 3E4B4790 1CAE39B6 ADC305AD 674B9EC3 5D19FEAF 1497D3F2                                                                        
  EA9FDC47 B0B6BCEF DBE901DB 5EC5319A B72E39C0 F36D2E                                                    
  quit      
!
!
!
!
!
spanning-tree mode pvst                      
spanning-tree extend system-id                              
!
vlan internal allocati                    
!
!
!
interface FastEthernet0/1                        
 switchport mode trunk                      
!
interface FastEthernet0/2                        
 switchport access vlan 2                        
!
interface FastEthernet0/3                        
 switchport access vlan 2                        
!
interface FastEthernet0/4                        
 switchport access vlan 2                        
!
interface FastEthernet0/5                        
 switchport access vlan 2                        
!
interface FastEthernet0/6                        
 switchport access vlan 2                        
!
interface FastEthernet0/7                        
 switchport access vlan 2                        
!
interface FastEthernet0/8                        
 switchport access vlan 2                        
!
interface FastEthernet0/9                        
 switchport access vlan 2                        
!
interface FastEthernet0/10                          
 switchport access vlan 2                        
!
interface FastEthernet0/11                          
 switchport access vlan 2                        
!
interface FastEthernet0/12                          
 switchport access vlan 3                        
!
interface FastEthernet0/13                          
 switchport access vlan 3                        
!
interface FastEthernet0/14                          
 switchport access vlan 3                        
!
interface FastEthernet0/15                          
 switchport access vlan 3                        
!
interface FastEthernet0/16                          
 switchport access vlan 3                        
!
interface FastEthernet0/17                          
 switchport access vlan 3                        
!
interface FastEthernet0/18                          
 switchport access vlan 3                        
!
interface FastEthernet0/19                          
 switchport access vlan 3                        
!
interface FastEthernet0/20                          
 switchport access vlan 3                        
!
interface FastEthernet0/21                          
 switchport access vlan 3                        
!
interface FastEthernet0/22                          
 switchport access vlan 3                        
!
interface FastEthernet0/23                          
 switchport access vlan 3                        
!
interface FastEthernet0/24                          
 switchport access vlan 3                        
!
interface GigabitEthernet0/1                            
!
interface GigabitEthernet0/2                            
!
interface Vlan1              
 ip address 192.168.1.1 255.255.255.0                                    
 no ip route-cache                  
!
interface Vlan2              
 ip address 192.168.2.1 255.255.255.0                                    
 no ip route-cache                  
!
interface Vlan3              
 ip address 192.168.3.1                      
 no ip route-cache                  
!
ip http server              
ip http secure-server                    
!
control-plane            
!
!
line con 0          
 password cisco              
 login      
line vty 0 4            
 password cisco              
 login      
line vty 5 14            
 password cisco              
 login      
line vty 15          
 login      
!
end  

Switch#sh vlan              

VLAN Name                             Status    Ports                                                    
---- -------------------------------- --------- -------------------------------                                                                              
1    default                          active    Gi0/1, Gi0/2                                                            
2    ATM                              active    Fa0/2, Fa0/3, Fa0/4, Fa0/5                                                                          
                                                Fa0/6, Fa0/7, Fa0/8, Fa0/9                                                                          
                                                Fa0/10, Fa0/11                                                              
3    ICBS                             active    Fa0/12, Fa0/13, Fa0/14, Fa0/15                                                                              
                                                Fa0/16, Fa0/17, Fa0/18, Fa0/19                                                                              
                                                Fa0/20, Fa0/21, Fa0/22, Fa0/23                                                                              
                                                Fa0/24                                                      
1002 fddi-default                     act/unsup                                              
1003 token-ring-default                                                  
1004 fddinet-default                  act/unsup                                              
1005 trnet-default                    act/unsup                                              

VLAN Type  SAID       MTU   Parent RingNo BridgeNo Stp  BrdgMode Trans1 Trans2                                                                              
---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------                                                                              
1    enet  100001     1500  -      -      -        -    -        0      0                                                                        
2    enet  100002     1500  -      -      -        -    -        0      0                                                                        
3    enet  100003     1500  -      -      -        -    -        0      0                                                                        
1002 fddi  101002     1500  -      -                                        
1003 tr    101003     1500  -      -      -        -    -        0      0                                                                        

VLAN Type  SAID       MTU   Parent RingNo BridgeNo Stp  BrdgMode Trans1 Trans2                                                                              
---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------                                                                              
1004 fdnet 101004     1500  -      -      -        ieee -        0      0                                                                        
1005 trnet 101005     1500  -      -      -        ibm  -        0      0                                                                        

Remote SPAN VLANs                
------------------------------------------------------------------------------                                                                              


Primary Secondary Type              P                                  
------- -        

































Switch con0 is now available                            





Press RETURN to get started.                            





Switch>      
Switch>      
Switch>      
Switch>en        
Switch#sh run            
Building configuration...                        

Current configuration : 2422 bytes                                  
!
version 12.2            
no service pad              
service timestamps debug datetime msec                                      
service timestamps l                  
no service password-encryption                              
!
hostname Switch              
!
boot-start-marker                
boot-end-marker              
!
!
no aaa new-model                
switch 1 provision ws-c3750-48p                              
system mtu routing 1500                      
ip subnet-zero              
ip routing          
!
!
!
!
!
!
!
spanning-tree mode pvst                      
spanning-tree extend system-id                              
!
vlan internal allocation policy ascending                                        
!
!
!
!
interface FastEthernet1/0/1                          
!
interface FastEthernet1/0/2                          
!
interface FastEthernet1/0/3                          
!
interface FastEthernet1/0/4                          
!
interface FastEthernet1/0/5                          
!
interface FastEthernet1/0/6                          
!
interface FastEthernet1/0/7                          
!
interface Fast            
!
interface FastEthernet1/0/9                          
!
interface FastEthernet1/0/10                            
!
interface FastEthernet1/0/11                            
!
interface FastEthernet1/0/12                            
!
interface FastEthernet1/0/13                            
!
interface FastEthernet1/0/14                            
!
interface FastEthernet1/0/15                            
!
interface FastEthernet1/0/16                            
!
interface FastEthernet1/0/17                            
!
interface FastEthernet1/0/18                            
!
interface FastEthernet1/0/19                            
!
interface FastEthernet1/0/20                            
!
interface FastEthernet1/0/21                            
!
interface FastEthernet1/0/22                            
!
interface FastEthernet1/0/23                            
!
interface FastEthernet1/0/24                            
!
interface FastEthernet1/0/25                            
!
interface FastEthernet1/0/26                            
!
interface FastEthernet1/0/27                            
!
interface FastEthernet1/0/28                            
!
interface FastEthernet1/0/29                            
!
interface FastEthernet1/0/30                            
!
interface FastEthernet1/0/31                            
!
interface FastEthernet1/0/32                            
!
interface FastEthernet1/0/33                            
!
interface FastEthernet1/0/34                            
!
interface FastEthernet1/0/35                            
!
interface FastEthernet1/0/36                            
!
interface FastEthernet1/0/37                            
!
interface FastEthernet1/0/38                            
!
interface FastEthernet1/0/39                            
!
interface FastEthernet1/0/40                            
!
interface FastEthernet1/0/41                            
!
interface FastEthernet1/0/42                            
!
interface FastEthernet1/0/43                            
!
interface FastEthernet1/0/44                            
!
interface FastEthernet1/0/45                            
!
interface FastEthernet1/0/46                            
!
interface FastEthernet1/0/47                            
!
interface FastEthernet1/0/48                            
 switchport trunk encapsulation dot1q                                    
 switchport mode trunk                      
!
interface GigabitEthernet1/0/1                              
!
interface GigabitEthernet1/0/2                              
!
interface GigabitEthernet1/0/3                              
!
interface GigabitEthernet1/0/4                              
!
interface Vlan1              
 ip address 192.168.1.2 255.255.255.0                                    
!
interface Vlan2              
 ip address 192.168.2.2 255.255.255.0                                    
!
interface Vlan3              
 ip address 192.168.                  
!
!
router eigrp 10              
 network 192.168.1.0                    
 network 192.168.2.0                    
 network 192.168.3.0                    
!
ip classless            
ip http server              
!
!
!
control-plane            
!
!
line con 0          
line vty 5 15            
!
end  

Switch#sh vlan              

VLAN Name                             Status    Ports                                                    
---- -------------------------------- --------- -------------------------------                                                                              
1    default                          active    Fa1/0/2, Fa1/0/3, Fa1/0/4                                                                        
                                                Fa1/0/5, Fa1/0/6, Fa1/0/7                                                                        
                                                Fa1/0/8, F                                                        
                                                Fa1/0/11, Fa1/0/12, Fa1/0/13                                                                            
                                                Fa1/0/14, Fa1/0/15, Fa1/0/16                                                                            
                                                Fa1/0/17, Fa1/0/18, Fa1/0/19                                                                            
                                                Fa1/0/20, Fa1/0/21, Fa1/0/22                                                                            
                                                Fa1/0/23, Fa1/0/24, Fa1/0/25                                                                            
                                                Fa1/0/26, Fa1/0/27, Fa1/0/28                                                                            
                                                Fa1/0                                                    
                                                Fa1/0/32, Fa1/0/33, Fa1/0/34                                                                            
                                                Fa1/0/35, Fa1/0/36, Fa1/0/37                                                                            
                                                Fa1/0/38, Fa1/0/39, Fa1/0/40                                                                            
                                                Fa1/0/41, Fa1/0/42, Fa1/0/43                                                                            
                                                Fa1/0/44, Fa1/0/45, Fa1/0/46                                                                            
                                                Fa1/0/47, Fa1/0/48, Gi1/0/1                                                                          
                                                Gi1/0/                          
1002 fddi-default                     act/unsup
1003 token-ring-default               act/unsup
1004 fddinet-default                  act/unsup

VLAN Name                             Status    Ports
---- -------------------------------- --------- -------------------------------
1005 trnet-default                    act/unsup

VLAN Type  SAID       MTU   Parent RingNo BridgeNo Stp  BrdgMode Trans1 Trans2
---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------
1    enet  100001     1500  -      -      -        -    -        0      0
1002 fddi  101002     1500  -      -      -        -    -        0      0
1003 tr    101003     1500  -      -      -        -    -        0      0
1004 fdnet 101004     1500  -      -      -        ieee -        0      0
1005 trnet 101005     1500  -      -      -        ibm  -        0      0

Remote SPAN VLANs
------------------------------------------------------------------------------


Primary Secondary Type              Ports
------- --------- ----------------- ------------------------------------------
Switch#      
Switch#sh run            
Building configuration...                        

Current configuration : 3811 bytes                                  
!
version 12.2            
no service pad              
service timestamps debug datetime msec                                      
service timestamps log datetime msec                                    
no service password-encryption                              
!
hostname Switch              
!
boot-start-marker                
boot-end-marker              
!
enable password ccna                    
!
no aaa new-model                
system mtu routing 1500                      
ip subnet-zero              
!
!
!
crypto pki trustpoint HTTPS_SS_CERT_KEYPAIR                                          
 enrollment selfsigned                      
 serial-number              
 revocation-check none                      
 rsakeypair HTTPS_SS_CERT_KEYPAIR                                
!
!
crypto pki certificate chain HTTPS_SS_CERT_KEYPAIR                                                  
 certificate self-signed 01                          
  30820253 308201BC A0030201 02020101 300D0609 2A864886 F70D0101 04050030                                                                        
  3B311030 0E060355 04031307 53776974 63682E31 27300F06 03550405 13083145                                                                        
  35463843 30303014 06092A86 4886F70D 01090216 07537769 7463682E 301E170D                                                                        
  39333033 30313030 33333536 5A170D32 30303130 31303030 3030305A 303B3110                                                                        
  300E0603 55040313 07537769 7463682E 3127300F 06035504 05130831 45354638                                                                        
  43303030 1406092A 864886F7 0D010902 16075377 69746368 2E30819F 30                                                                
  2A864886 F70D0101 01050003 818D0030 81890281 8100E939 848F3204 8A39CC9B                                                                        
  91363563 DC7019BC AC5291D6 C577CF3D 4A4F57C3 FCC0A74D 2C915170 6BBF79DC                                                                        
  0AD942D0 1754449A 59E74D16 1EF5E185 76A3A1C0 31FDF6DE 550090B8 858E53D2                                                                        
  AAB9BA8E F1F538F6 87FAE34C 9B31918F 05F05BBC A3F2DAD3 2BDA10E7 2D8D513A                                                                        
  1C71E68A 7ACF261A D902ADBD 234A04F2 AAD31CDF 8EE10203 010001A3 67306530                                                                        
  0F060355 1D130101 FF040530 030101FF 30120603 551D1104 0B300982 07537769                                                                        
  7463682E 301F0603 551D2304 18301680 140AC2AC 0A65C279 89B4FE66 DA39F0                                                                      
  3F94BBCD D7301D06 03551D0E 04160414 0AC2AC0A 65C27989 B4FE66DA 39F0953F                                                                        
  94BBCDD7 300D0609 2A864886 F70D0101 04050003 81810019 7A04B749 1EA664C3                                                                        
  1209D9EB C3AE7AA9 AAFA986A 1D81F898 32A860B9 0A9AC4AD 2A26DD8D 2B99E077                                                                        
  2AA15903 6727B9E5 ACE2F849 156C329C 561C11CB 2CD62FD8 596CA862 6EEE5DBA                                                                        
  CC24B20B 11C370F3 3E4B4790 1CAE39B6 ADC305AD 674B9EC3 5D19FEAF 1497D3F2                                                                        
  EA9FDC47 B0B6BCEF DBE901DB 5EC5319A B72E39C0 F36D2E                                                    
  quit      
!
!
!
!
!
spanning-tree mode pvst                      
spanning-tree extend system-id                              
!
vlan internal allocati                    
!
!
!
interface FastEthernet0/1                        
 switchport mode trunk                      
!
interface FastEthernet0/2                        
 switchport access vlan 2                        
!
interface FastEthernet0/3                        
 switchport access vlan 2                        
!
interface FastEthernet0/4                        
 switchport access vlan 2                        
!
interface FastEthernet0/5                        
 switchport access vlan 2                        
!
interface FastEthernet0/6                        
 switchport access vlan 2                        
!
interface FastEthernet0/7                        
 switchport access vlan 2                        
!
interface FastEthernet0/8                        
 switchport access vlan 2                        
!
interface FastEthernet0/9                        
 switchport access vlan 2                        
!
interface FastEthernet0/10                          
 switchport access vlan 2                        
!
interface FastEthernet0/11                          
 switchport access vlan 2                        
!
interface FastEthernet0/12                          
 switchport access vlan 3                        
!
interface FastEthernet0/13                          
 switchport access vlan 3                        
!
interface FastEthernet0/14                          
 switchport access vlan 3                        
!
interface FastEthernet0/15                          
 switchport access vlan 3                        
!
interface FastEthernet0/16                          
 switchport access vlan 3                        
!
interface FastEthernet0/17                          
 switchport access vlan 3                        
!
interface FastEthernet0/18                          
 switchport access vlan 3                        
!
interface FastEthernet0/19                          
 switchport access vlan 3                        
!
interface FastEthernet0/20                          
 switchport access vlan 3                        
!
interface FastEthernet0/21                          
 switchport access vlan 3                        
!
interface FastEthernet0/22                          
 switchport access vlan 3                        
!
interface FastEthernet0/23                          
 switchport access vlan 3                        
!
interface FastEthernet0/24                          
 switchport access vlan 3                        
!
interface GigabitEthernet0/1                            
!
interface GigabitEthernet0/2                            
!
interface Vlan1              
 ip address 192.168.1.1 255.255.255.0                                    
 no ip route-cache                  
!
interface Vlan2              
 ip address 192.168.2.1 255.255.255.0                                    
 no ip route-cache                  
!
interface Vlan3              
 ip address 192.168.3.1                      
 no ip route-cache                  
!
ip http server              
ip http secure-server                    
!
control-plane            
!
!
line con 0          
 password cisco              
 login      
line vty 0 4            
 password cisco              
 login      
line vty 5 14            
 password cisco              
 login      
line vty 15          
 login      
!
end  

Switch#sh vlan              

VLAN Name                             Status    Ports                                                    
---- -------------------------------- --------- -------------------------------                                                                              
1    default                          active    Gi0/1, Gi0/2                                                            
2    ATM                              active    Fa0/2, Fa0/3, Fa0/4, Fa0/5                                                                          
                                                Fa0/6, Fa0/7, Fa0/8, Fa0/9                                                                          
                                                Fa0/10, Fa0/11                                                              
3    ICBS                             active    Fa0/12, Fa0/13, Fa0/14, Fa0/15                                                                              
                                                Fa0/16, Fa0/17, Fa0/18, Fa0/19                                                                              
                                                Fa0/20, Fa0/21, Fa0/22, Fa0/23                                                                              
                                                Fa0/24                                                      
1002 fddi-default                     act/unsup                                              
1003 token-ring-default                                                  
1004 fddinet-default                  act/unsup                                              
1005 trnet-default                    act/unsup                                              

VLAN Type  SAID       MTU   Parent RingNo BridgeNo Stp  BrdgMode Trans1 Trans2                                                                              
---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------                                                                              
1    enet  100001     1500  -      -      -        -    -        0      0                                                                        
2    enet  100002     1500  -      -      -        -    -        0      0                                                                        
3    enet  100003     1500  -      -      -        -    -        0      0                                                                        
1002 fddi  101002     1500  -      -                                        
1003 tr    101003     1500  -      -      -        -    -        0      0                                                                        

VLAN Type  SAID       MTU   Parent RingNo BridgeNo Stp  BrdgMode Trans1 Trans2                                                                              
---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------                                                                              
1004 fdnet 101004     1500  -      -      -        ieee -        0      0                                                                        
1005 trnet 101005     1500  -      -      -        ibm  -        0      0                                                                        

Remote SPAN VLANs                
------------------------------------------------------------------------------                                                                              


Primary Secondary Type              P                                  
------- -        

































Switch con0 is now available                            





Press RETURN to get started.                            





Switch>      
Switch>      
Switch>      
Switch>en        
Switch#sh run            
Building configuration...                        

Current configuration : 2422 bytes                                  
!
version 12.2            
no service pad              
service timestamps debug datetime msec                                      
service timestamps l                  
no service password-encryption                              
!
hostname Switch              
!
boot-start-marker                
boot-end-marker              
!
!
no aaa new-model                
switch 1 provision ws-c3750-48p                              
system mtu routing 1500                      
ip subnet-zero              
ip routing          
!
!
!
!
!
!
!
spanning-tree mode pvst                      
spanning-tree extend system-id                              
!
vlan internal allocation policy ascending                                        
!
!
!
!
interface FastEthernet1/0/1                          
!
interface FastEthernet1/0/2                          
!
interface FastEthernet1/0/3                          
!
interface FastEthernet1/0/4                          
!
interface FastEthernet1/0/5                          
!
interface FastEthernet1/0/6                          
!
interface FastEthernet1/0/7                          
!
interface Fast            
!
interface FastEthernet1/0/9                          
!
interface FastEthernet1/0/10                            
!
interface FastEthernet1/0/11                            
!
interface FastEthernet1/0/12                            
!
interface FastEthernet1/0/13                            
!
interface FastEthernet1/0/14                            
!
interface FastEthernet1/0/15                            
!
interface FastEthernet1/0/16                            
!
interface FastEthernet1/0/17                            
!
interface FastEthernet1/0/18                            
!
interface FastEthernet1/0/19                            
!
interface FastEthernet1/0/20                            
!
interface FastEthernet1/0/21                            
!
interface FastEthernet1/0/22                            
!
interface FastEthernet1/0/23                            
!
interface FastEthernet1/0/24                            
!
interface FastEthernet1/0/25                            
!
interface FastEthernet1/0/26                            
!
interface FastEthernet1/0/27                            
!
interface FastEthernet1/0/28                            
!
interface FastEthernet1/0/29                            
!
interface FastEthernet1/0/30                            
!
interface FastEthernet1/0/31                            
!
interface FastEthernet1/0/32                            
!
interface FastEthernet1/0/33                            
!
interface FastEthernet1/0/34                            
!
interface FastEthernet1/0/35                            
!
interface FastEthernet1/0/36                            
!
interface FastEthernet1/0/37                            
!
interface FastEthernet1/0/38                            
!
interface FastEthernet1/0/39                            
!
interface FastEthernet1/0/40                            
!
interface FastEthernet1/0/41                            
!
interface FastEthernet1/0/42                            
!
interface FastEthernet1/0/43                            
!
interface FastEthernet1/0/44                            
!
interface FastEthernet1/0/45                            
!
interface FastEthernet1/0/46                            
!
interface FastEthernet1/0/47                            
!
interface FastEthernet1/0/48                            
 switchport trunk encapsulation dot1q                                    
 switchport mode trunk                      
!
interface GigabitEthernet1/0/1                              
!
interface GigabitEthernet1/0/2                              
!
interface GigabitEthernet1/0/3                              
!
interface GigabitEthernet1/0/4                              
!
interface Vlan1              
 ip address 192.168.1.2 255.255.255.0                                    
!
interface Vlan2              
 ip address 192.168.2.2 255.255.255.0                                    
!
interface Vlan3              
 ip address 192.168.                  
!
!
router eigrp 10              
 network 192.168.1.0                    
 network 192.168.2.0                    
 network 192.168.3.0                    
!
ip classless            
ip http server              
!
!
!
control-plane            
!
!
line con 0          
line vty 5 15            
!
end  

Switch#sh vlan              

VLAN Name                             Status    Ports                                                    
---- -------------------------------- --------- -------------------------------                                                                              
1    default                          active    Fa1/0/2, Fa1/0/3, Fa1/0/4                                                                        
                                                Fa1/0/5, Fa1/0/6, Fa1/0/7                                                                        
                                                Fa1/0/8, F                                                        
                                                Fa1/0/11, Fa1/0/12, Fa1/0/13                                                                            
                                                Fa1/0/14, Fa1/0/15, Fa1/0/16                                                                            
                                                Fa1/0/17, Fa1/0/18, Fa1/0/19                                                                            
                                                Fa1/0/20, Fa1/0/21, Fa1/0/22                                                                            
                                                Fa1/0/23, Fa1/0/24, Fa1/0/25                                                                            
                                                Fa1/0/26, Fa1/0/27, Fa1/0/28                                                                            
                                                Fa1/0                                                    
                                                Fa1/0/32, Fa1/0/33, Fa1/0/34                                                                            
                                                Fa1/0/35, Fa1/0/36, Fa1/0/37                                                                            
                                                Fa1/0/38, Fa1/0/39, Fa1/0/40                                                                            
                                                Fa1/0/41, Fa1/0/42, Fa1/0/43                                                                            
                                                Fa1/0/44, Fa1/0/45, Fa1/0/46                                                                            
                                                Fa1/0/47, Fa1/0/48, Gi1/0/1                                                                          
                                                Gi1/0/                          
1002 fddi-default                     act/unsup
1003 token-ring-default               act/unsup
1004 fddinet-default                  act/unsup

VLAN Name                             Status    Ports
---- -------------------------------- --------- -------------------------------
1005 trnet-default                    act/unsup

VLAN Type  SAID       MTU   Parent RingNo BridgeNo Stp  BrdgMode Trans1 Trans2
---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------
1    enet  100001     1500  -      -      -        -    -        0      0
1002 fddi  101002     1500  -      -      -        -    -        0      0
1003 tr    101003     1500  -      -      -        -    -        0      0
1004 fdnet 101004     1500  -      -      -        ieee -        0      0
1005 trnet 101005     1500  -      -      -        ibm  -        0      0

Remote SPAN VLANs
------------------------------------------------------------------------------


Primary Secondary Type              Ports
------- --------- ----------------- ------------------------------------------


0
 
Istvan KalmarHead of IT Security Division Commented:
Hi,
is it 3 configs ?
0
 
IT-MatrixAuthor Commented:

Sorry for confusion

As I said please go through our config and let us know why it is not working the VLANs can not ping each other
config-l2-switch.txt
config-l3-switch.txt
0
 
IT-MatrixAuthor Commented:
PLease ignore the first file (Config-l2) because the second file contains both configuration of both switches the first config belongs to L2 and the second belongs to L3
0
 
Istvan KalmarHead of IT Security Division Commented:
hi,

the config is good!

But I advise to connect the L2 switches with trunk port, and use MGMT VLAN

interface FastEthernet1/0/48                            
switchport trunk encapsulation dot1q                                    
 switchport mode trunk        
0
 
IT-MatrixAuthor Commented:
I believe it is already connected to trunk port but still there is no route between Vlans please tell me what should i do more?
0
 
GJHopkinsCommented:
Ok can you do the following on both switches

show interface trunk

show cdp neighbors

where are you trying to ping from and to ?

0
 
IT-MatrixAuthor Commented:
Below is the result of L2 switch

Switch#show cdp neighbors
Capability Codes: R - Router, T - Trans Bridge, B - Source Route Bridge
                  S - Switch, H - Host, I - IGMP, r - Repeater, P - Phone

Device ID        Local Intrfce     Holdtme    Capability  Platform  Port ID
Switch           Fas 0/1           143          R S I     WS-C3750- Fas 1/0/1
Switch#

Switch#show interfaces trunk

Port        Mode             Encapsulation  Status        Native vlan
Fa0/1       on               802.1q         trunking      1

Port        Vlans allowed on trunk
Fa0/1       1-4094

Port        Vlans allowed and active in management domain
Fa0/1       1-3

Port        Vlans in spanning tree forwarding state and not pruned
Fa0/1       1-3
Switch#

Below is  the result of L3 switch

Switch#show cdp neighbors
Capability Codes: R - Router, T - Trans Bridge, B - Source Route Bridge
                  S - Switch, H - Host, I - IGMP, r - Repeater, P - Phone

Device ID        Local Intrfce     Holdtme    Capability  Platform  Port ID
Switch           Fas 1/0/1         131           S I      WS-C2960- Fas 0/1
Switch#

Switch#show interfaces trunk

Port        Mode             Encapsulation  Status        Native vlan
Fa1/0/1     auto             n-802.1q       trunking      1

Port        Vlans allowed on trunk
Fa1/0/1     1-4094

Port        Vlans allowed and active in management domain
Fa1/0/1     1

Port        Vlans in spanning tree forwarding state and not pruned
Fa1/0/1     1
Switch#

And we are pinging a computer in one VLan from another Vlan


0
 
xzatechCommented:
default gateway?
could you do : #sho run int? ( the interfaces in questions (vlans also)) & #sho adj and #sho cdp nei and #sho vlan
0
 
IT-MatrixAuthor Commented:

The solution was not complete we had to configure EIGRP protocol in layer 3 switch and then it worked
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.