Outlook "Send on Behalf of" is missing when sending as delegate

Outlook "send on Behalf of" is missing after sending mail from a delegated share mailbox.
this is what I have done so sar...
1) I gave send as permission in Exchange 2007 Management Console.
2) I logged on as the "shared Mailbox" to assign delegates permissions for myself. Inbox etc.
3) I also right click on Mailbox, properties, permissions and set myself with Editor access.
4) Now logged on to outlook with the shared mailbox already in my outlook folder list.
5) replied to a message from "Shared Mailbox" added my name to the FROM field and then sent the mail.
checked the received mail and it shows from "ME" with NO "Sent on behalf" shared mailbox.

I have searched around for days and can not find a simple or straight forward solution to this irriatable problem.
CAN SOME PLEASE HELP? Grrrrrrrrrr!
MessagingMoAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

IvaSoftCommented:
It works as should do.  Just grant yourself "send on behalf of" right instead of "Send As".
See http://www.cryer.co.uk/brian/msexchange/exch_howto_grant_send_on_behalf_of.htm

Regards,
Victor
0
MessagingMoAuthor Commented:
I did all those steps before and no luck.
0
IvaSoftCommented:
Did you remove "Send as" right?
0
10 Tips to Protect Your Business from Ransomware

Did you know that ransomware is the most widespread, destructive malware in the world today? It accounts for 39% of all security breaches, with ransomware gangsters projected to make $11.5B in profits from online extortion by 2019.

MessagingMoAuthor Commented:
I did not remove "Send as" right in Exchange 07 Management console.
Instead, I added myself to the "Send as" through the EX07MC, mailbox properties, mail flow settings, delivery Options. I did not add myself to manage the mailbox as this may prevent the Send as from displaying, I've been told.
0
IvaSoftCommented:
In EMC, select a mailbox, right-click and select Manage Send As properties. Do you see yourself there in the list?
0
MessagingMoAuthor Commented:
YES I see myself there.
0
IvaSoftCommented:
Remove yourself from there.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
MessagingMoAuthor Commented:
Done...it worked...
The problem is that I can not be in Send As and Send on behalf.
Thanks a lot for this.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Outlook

From novice to tech pro — start learning today.