Ntbackup Fails reports saying C is not a valid drive or i do not have access

Hi i've got this issue on one of my SBS2003 SP2 machines, this is the report i receive now this server has two backups one to a external usb drive and to a hp dat 72 drive both jobs are exactly the same, the external usb backup works fine but the tape drive recently has started failing and giving out this report:

Backup Status
Operation: Backup
Active backup destination: 4mm DDS
Media name: "Media created 13/04/2010 at 10:49"

Volume shadow copy creation: Attempt 1.
Backup (via shadow copy) of "C: "
Backup set #1 on media #1
Backup description: "Set created 13/04/2010 at 10:51"
Media name: "Media created 13/04/2010 at 10:49"

Backup Type: Normal

Backup started on 20/04/2010 at 01:05.

Error: The device reported an error on a request to write data to media.
Error reported: Hardware failure.
There may be a hardware or media problem.
Please check the system event log for relevant failures.
The operation was ended.
Backup completed on 20/04/2010 at 01:08.
Directories: 47
Files: 147
Bytes: 39,689,668
Time:  3 minutes and  25 seconds

Error: C: is not a valid drive, or you do not have access.


----------------------

The operation did not successfully complete.

----------------------

I've ran and checked, cleaning tapes (brand new) ran 5 times to give it a thougher  clean and used a new tape to backup but still the same results, also have ran hp dat 72 storageworks from hp to test the tapes and the drive itself and they have all past. Applied the latests firmware to the drive also and applied some hotfix's from microsoft but to no avail.
The event log gives the events 8001 8018 8019 but neither of these give any useful info just pointing to look at the backup logs.

All help is much appreciated and welcomed.
Thanks
JackShukerTechnicalAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Rodney BarnhardtServer AdministratorCommented:
What  type of account is being used to run the BE services? Could the rights have changed on that account?
0
JackShukerTechnicalAuthor Commented:
The account being used is administrator so it has full rights to run it
0
Rodney BarnhardtServer AdministratorCommented:
Does your server have any compressed folders? I did some research and found where some people had the same error with compressed folders on the C:.
You could have one folder causing the problem. I assisted on person who was using Backup Exec and it listed a specific file. When we looked at it, permissions were such on that folder that the account could not back it up. He took ownership and deleted the file.
This seems to have been a common problem prior to SP2, and Microsoft had a hotfix that was incorporated into SP2. I also found this started happening recently, so wonder if this just started if there was a patch that broke something in the system.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

JackShukerTechnicalAuthor Commented:
thank you for the information rbarnhardt but i just realised i added the zone backup exec when this was just a backup using ntbackup onto tape, (dont know how to take a zone of a question) the strange thing is last nights backup managed to backup about 26GB which was all of C and some of E but didnt complete successfully again it came up with The requested media failed to mount. The operation was aborted. even though it got 5.2GB of E its still failing and not completing successfully. FYI the event log seems to be useless just pointing me to look at the reports...
0
Rodney BarnhardtServer AdministratorCommented:
I noticed it wa NTBackup the second time I looked at it, and was just saying I assisted someone who was using BE and had one file on the C: drive causing the issue. I was concentrating on the "Error: C: is not a valid drive, or you do not have access." Now that it completed the C: drive and moved to the next drive, that is not likely. How does the drive connect to the server? Is it hard wired, such as SCSI, or USB?

0
JackShukerTechnicalAuthor Commented:
The tape drive (its a HP DAT 72) is usb and have gotten the latest drivers and firmware for it. the problem is that the backup was running a few weeks ago but the all of a sudden this started happening and there has been no changes at all to the system.
0
Rodney BarnhardtServer AdministratorCommented:
On my second comment, I asked about your server OS. I know for various reasons, servers are at different patch levels. Are you on SP2? I didn't see where you answered that question. There was a issues prior to that with USB drives.
http://support.microsoft.com/default.aspx?scid=kb;en-us;817765
 
0
JackShukerTechnicalAuthor Commented:
the OS is Windows server 2003 with SP2 on but now all of a sudden its decided to start backing up again and we havn't done anything to it. sometimes i wonder what is a greater mystery god or computers...
0
JackShukerTechnicalAuthor Commented:
I've requested that this question be closed as follows:

Accepted answer: 0 points for JackShuker's comment #a32695249

for the following reason:

No other solution woked - it just started working
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Storage Software

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.