Speed Issues with Netgear GSM7248


My customers are complaining about speed issues on our network.

We have three Netgear GSM7248 switches linked with a single cat 5 cable as shown below.
This question has two parts really:

1. How do I configure a LAG using the web interface on these to double the speed of the uplink to each swicth, and maybe our servers too?

2. After inspecting each individual port on the swicthes they are set to AUTO.  However a lot of the port speeds are set to 100mbs Half Duplex as opposed to the 1000mbs Full Duplex.  Should I change these manually to 1000mbs?

Many Thanks
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

I trust you have spanning tree on otherwise you will definitely start getting speed issues with this arrangement due to broadcast loops.  It doesnt hurt to set the port speeds so that there is no chance of any auto-negotiation conflicts.  To configure a LAG  you will need to choose one switch as the master with 2 LAGS and slave the others off it.  
which version of switches are they?
chrisd_2kAuthor Commented:
It is V1
I think Spanning tree is enabled but its difficult to tell using the web interface
How the Cloud Can Help You as an MSSP

Today, every Managed Security Service Provider (MSSP) needs a platform to deliver effective and efficient security-as-a-service to their customers. Scale, elasticity and profitability are a few of the many features that a Cloud platform offers. Register today to learn more!


What version of Firmware are you running? From the picture of your spanning tree settings it looks like its not the latest,

I can't quite remember how to set up LAG in previous versions of the firmware, in the latest it is fairly straight forward,

Under LAG Configuration, add a LAG as shown above.
• Set Link Trap, STP Mode and Static Mode to Enable or Disable as required.
• If Link Trap is set to Enable, then a trap will be sent if the LAG link state changes.
• STP Mode indicates whether or not spanning tree is enabled on the LAG or not.
• Static Mode indicates whether or not LACP is used, i.e. Static Mode set to Disable means
LACP is used.
• Press Add.

Under LAG Membership, add the ports that are to be included in the LAG (maximum of eight).
•      Expand the ports in the switch by clicking on Unit 1
•      Check ports you wish to add
•      Press Apply

For auto-negotiation, i would always try and configure manually if possible, as said above it will help with negotiation conflicts but also it helps by reducing the amount of traffic on the network.

If you wanted to create multiple links to the switch from the server, you would configure LAG on the switch in question, add the ports and then on the server, generally within the adapter properties there is an option for teaming, you would need to team the adapters together and select what you want, Load-Balancing, Failover, etc...

Its obviously quite difficult to give more detail as i don't know your servers etc.. But if you post more i might be able to help




Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
chrisd_2kAuthor Commented:
I'm running V  I have just downloaded V and will install that.

In my current version I cant even find anything that says LAG let alone configure it but that will probably change when I update the firmware?

I have Proliant servers but I'm pretty sure I can fset that up, just havent had much exposure to switch management which is the main problem.

Thanks for your help with this guys all advice is greatly appreciated
This guide might help you set up the LAGs. http://kb.netgear.com/ci/fattach/get/69/1260525114/redirect/1
STP should be enabled by default.
chrisd_2kAuthor Commented:
Here is an overview of my web interface if its of any use
chrisd_2kAuthor Commented:
Anglo, I found that guide myself but as you can see its very different from my web interface - Will that change with the upgraded firmware?  Or are they using other software?

Arrgh!  my switch has gone AWOL for web and telnet.  As I am not on site I cannot comment at the moment. sorry.  
chrisd_2kAuthor Commented:
Ive upgraded the firmware and it looks exactly the same.  I cant see any LAG config options.

Any ideas guys?
I thought my switch was the same but unfortunately its not.  Sometimes you get the advanced features not showing in the Web interace.  From the manual it refers to the command line instructions.
chrisd_2kAuthor Commented:
Working now thanks
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Networking Hardware-Other

From novice to tech pro — start learning today.