Need to type "sudo modprobe ndiswrapper" at every single reboot to have wireless working

I'm very new to Linux,

after having installed ubuntu i needed some tricks with ndiswrapper to make my wireless PCI adapter work.

The problem is that every time i reboot my machine, i need to enter  sudo modprobe ndiswrapper  into the console

If i forget to do that command, i can't see my wlan0 in the ifconfig -a screen.


I've tried to edit

/etc/rc.local

in the purpose of adding the  "sudo modprobe ndiswrapper"  string but i can't save it, maybe because is a read only file.

Neither sudo ndiswrapper -m made the tricks

I'm using Ubuntu 10.04 beta2

Thank you for your help
LVL 1
farioAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Maciej SsysadminCommented:
Add "ndiswrapper" (without "") to /etc/modules.
0
TobiasHolmCommented:
use: sudo nano /etc/rc.local

Then you can save the edited file (CTRL+X)
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
TobiasHolmCommented:
Or use: sudo nano /etc/etc/modules
if you want to edit the modules file instead.
0
TobiasHolmCommented:
typo... Should of course be: sudo nano /etc/modules
0
pointerstopCommented:
Really, don't use rc.local unless you've tried everything else.  rc.local is a fallback for things you can't do anywhere else.  It will quickly become unwieldy if you start putting things in there.  This belongs in /etc/modules (which is what "sudo ndiswrapper -m" is admittedly supposed to do, but I've never seen it work).

Also, please don't advise using "nano".  Use "editor", which may  be "nano", but may be whatever other editor the system admin has installed as the default.  Not all Linuxes will use nano by default.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Linux Distributions

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.