get cisco 877 to use firmware file in flash

Untitled_Titan
Untitled_Titan used Ask the Experts™
on
Hi,
I have copied a firmware file to flash: adsl_alc_20190_4.0.017.bin
see output:
Directory of flash:/

    2  -rwx    18275844   Apr 7 2010 15:07:29 +00:00  c870-advsecurityk9-mz.124-
20.T.bin
    3  -rwx        3179   Mar 1 2002 00:03:33 +00:00  sdmconfig-8xx.cfg
    4  -rwx      931840   Mar 1 2002 00:03:51 +00:00  es.tar
    5  -rwx     1505280   Mar 1 2002 00:04:14 +00:00  common.tar
    6  -rwx        1038   Mar 1 2002 00:04:26 +00:00  home.shtml
    7  -rwx      112640   Mar 1 2002 00:04:38 +00:00  home.tar
    8  -rwx     1002424   Apr 7 2010 15:16:48 +00:00  adsl_alc_20190_4.0.017.bin
    9  -rwx     1002424   Apr 7 2010 15:41:34 +00:00  adsl_alc_firmware.bin

But upon reload, the router continues to use the embedded file init_AMR-3.0.014_no_bist.bin rather than my preferred one: adsl_alc_20190_4.0.017.bin
- see output:

Huddersfield77#sh dsl int atm0
ATM0
Alcatel 20190 chipset information

Line has not yet been activated.

Modem Status:    Down (DMTDSL_DO_OPEN)
DSL Mode:        Unknown
Interrupts:      78357 (0 spurious)
PHY Access Err:  0
Activations:     0
LED Status:      OFF
LED On Time:     100
LED Off Time:    100
Init FW:         init_AMR-3.0.014_no_bist.bin
Operation FW:    AMR-3.0.014.bin
FW Source:       embedded

DSL: Training log buffer capability is not enabled
Huddersfield77#

I want the Cisco 877 to load the latest Firmware: adsl_alc_20190_4.0.017.bin instead of init_AMR-3.0.014_no_bist.bin as this helps with ADSL 2+ stability

Any advise on how I can make this stick would be greatly appreciated.
Thanks,
Jaime
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
Istvan KalmarHead of IT Security Division
Top Expert 2010

Commented:
Hi,

Where can you get adsl_alc_20190_4.0.017.bin file, it is not CISCO bin file!

Author

Commented:
its come from the Cisco site:
Download Software for Cisco 877 Integrated Services Router : adsl_alc_20190_4.0.017.bin
Asymmetric Digital Subscriber Line (ADSL) Firmware, Release Version - 4.0.17, File
Description - , File Size - 1002424, Min Dram - , Min Flash - , MD5 Checksum -
a0d1b4e9f1e5f5db8d926f828e350246, Release Publish Date - 08-JAN-10
| http://tools.cisco.com/support/downloads/go/Redirect.x?imageguid=E32FA7EE979C8564B272560646CC96...

...and it has worked on other 877 routers that we have put it on see output:

Directory of flash:/

    2  -rwx    18275844   Mar 1 2002 00:53:53 +00:00  c870-advsecurityk9-mz.124-20.T.bin
    3  -rwx        3179   Mar 1 2002 00:04:01 +00:00  sdmconfig-8xx.cfg
    4  -rwx      931840   Mar 1 2002 00:04:19 +00:00  es.tar
    5  -rwx     1505280   Mar 1 2002 00:04:43 +00:00  common.tar
    6  -rwx        1038   Mar 1 2002 00:04:54 +00:00  home.shtml
    7  -rwx      112640   Mar 1 2002 00:05:06 +00:00  home.tar
    8  -rwx     1002424  Jun 16 2009 23:27:31 +00:00  adsl_alc_20190.bin

sh dsl int atm0

--output supressed---

Init FW:         init_AMR_4.0.017.bin
Operation FW:    AMR-E-4.0.017.bin
FW Source:       external
FW Version:      4.0.17

Istvan KalmarHead of IT Security Division
Top Expert 2010

Commented:
oh, it is not IOS, it is Asymmetric Digital Subscriber Line (ADSL) Firmware to ADSL card I see....

adsl_alc_20190_4.0.017.bin
Release Date: 14/Dec/2009
ADSL firmware version 4.0.17 for UK annex M support only. Compatible with Huawei MA5300 DSLAM, EADB line card.
Size: 978.93 KB  (1002424 bytes)

you need to rename the old firware to adsl_alc_20190.old, and rename the new firware to adsl_alc_20190.bin and reload the router!

Ensure you’re charging the right price for your IT

Do you wonder if your IT business is truly profitable or if you should raise your prices? Learn how to calculate your overhead burden using our free interactive tool and use it to determine the right price for your IT services. Start calculating Now!

Not an area I've had a lot to do with but are you sure that the IOS and firmware combination is valid. If it is then it should be picked up automatically as you have found before.

see

http://www.cisco.com/en/US/prod/collateral/routers/ps221/prod_bulletin0900aecd801d5c4c.html

which may help
I don't think there is an old file the firmware is embedded in IOS, but if it finds an alternative in flash it should use that instead. However there may be some reasons as to why its not being recognised:

Filename?
Corrupted file - does the byte count look OK ?
Did you check the MD5 hash of the file downloaded from Cisco?

Author

Commented:
Hi,
I have checked the link supplied by GP Hoskings and it does appear that the IOS is compatiable with the new firmware I wish to use, and we do have other 877 routers running the upgraded firmware succefully with System image file is "flash:c870-advsecurityk9-mz.124-20.T.bin"

Re. Ikalmar's comment, unfortunatly I cannot rename the firmware file that is being used because it is embedded. It is not saved in the Flash memory for me to rename.

Author

Commented:
Thank GJHopkins I will check these things

It needs to be renamed to adsl_alc_20190.bin
so you can also store multiple versions on flash and copy them to the correct name.

eg

    2  -rwx    19018508  Jan 22 2010 18:24:37 +00:00  c870-advipservicesk9-mz.124-15.T10.bin
    3  -rwx      991820  Aug 23 2009 01:47:24 +01:00  adsl_alc_20190.bin.3.0.33
    4  -rwx         720  May 29 2009 18:45:01 +01:00  vlan.dat
    5  -rwx      996472  Aug 23 2009 01:49:59 +01:00  adsl_alc_20190.bin
    6  -rwx      996472  Aug 23 2009 01:49:19 +01:00  adsl_alc_20190.bin.4.0.15

Init FW:         init_AMR-4.0.015.bin
Operation FW:    AMR-4.0.015.bin
FW Source:       external
FW Version:      4.0.15

Author

Commented:
I cleared the flash and copied the file back up. The file name I used was: adsl_alc_20190.bin but I had used this same fiule name 5 times before!!
Upon reboot the firmware had been upgraded so I don't know what was different this time. Thanks for your help.
Its all irrelavant anyway because ADSL2 still doesn't stabalise on Cisco 877's even with the firmware upgarde.

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial