Network scanner Problem after windows Update

We have a Nashuatec  DSc424 networked photocopier with a scan function.

It was working perfectly as a network scanner untill i installed updates on our server now it says authentication with remote folder failed. All settings are exactly the same.

The server we use is a Windows SBS 2003
JRMCoAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

turnbulldCommented:
It seems like there are a few of possibilities (probably more I haven't thought of).  

First, the update may have either installed or reconfigured the firewall.  You may have to alter the server's firewall to allow the network device access.  This is potentially true even though the communication is primarily from server to scanner.  The scanner still talks back to the server to update the server on its progress and to return the scanned image.

Second, the update may have altered either user accounts or the rules by which user accounts are allowed to connect to the server.  Check the privileges on the remote folder and the users who are allowed to write to it.  You may have to adjust those privileges.  In Windows, privileges are not exactly straightforward; it may not be enough to just grant write privileges to a user.  You may also have to grant the user account the right to connect to the server as a service or other more general permission than mere file and folder privileges.

Third, you may have to reinstall the driver for the device on the server.   Sometimes an update will affect driver configuration or change the way drivers register with the server.  In these cases, reinstalling the driver after the update will typically clean up whatever the problem is.  This might be the best thing to try first as it will often handle the other two problems as well.
0
Shreedhar EtteCommented:
Which was  hotfix installed?
0
JRMCoAuthor Commented:
Hi, unfortunatly having tried all of the above none are succesfull

I am unsure what hotfix it was that caused the problem as there were a few installed at the same time. (over 100)
0
Challenges in Government Cyber Security

Has cyber security been a challenge in your government organization? Are you looking to improve your government's network security? Learn more about how to improve your government organization's security by viewing our on-demand webinar!

Shreedhar EtteCommented:
My god over 100 hotfixes at a time :(

Reconfigure the Scanner.
0
JRMCoAuthor Commented:
shreedhar the scanner has been reconfigured and is still saying
Authentication with the destination has failed.
Check settings.
0
Shreedhar EtteCommented:
Hi,

-  Check that the user name and password are correct.
- Check that the ID and password for the destination folder are correct.
- A password of 128 or more characters may not be recognized.

Hope this helps,
Shree
0
JRMCoAuthor Commented:
shreedhar all have been checked and they are all correct
0
JRMCoAuthor Commented:
Does anyone have any more ideas. Were at our wits end with this one everything is set up exactly the same it appears but it wont scan.
0
turnbulldCommented:
About all I can think of is to try and configure the scanner against a workstation or a different server.  If that works, at least you know for certain that the problem is in the original server and not the scanner itself.
0
JRMCoAuthor Commented:
Tried this and it works.But then i stillcant figure out whats changed on the SBS server?
0
JRMCoAuthor Commented:
Does any one have any ideas why a patch would stop the scanner communicating with the server and if so how to resolve?
0
jrtecCommented:
I dont if it is your case, but check it out.

have had issue on Server 2003, SBS 2003, Server 2008 and SBS 2008 when they are configured as domain controllers.
If this server is also a domain controler that is usually caused by the following setting:
Microsoft Network Server: Digitally Sign Communications (Always), The default setting for domain controllers is enabled, for others is not configured or disabled. This usually causes problems when acessing the share from devices are not cable of Digitally Sign Communications, like some multifunctionals/scanners or linux machines. This does not happen on all machines since some are capable of  Digitally Sign Communications. Usually older machines have this issue.
So, try to disable this setting on the server, on the Domain controller security policy and Default Domain Policy.

Administrative Tools
Domain controller security policy (in this case this is not the one, choose the one that aplies to your server)
Local Policies
Security options
Microsoft Network Server: Digitally signed communication (always) -> should be changed to DISABLE
Execute Gpupdate /force or reboot the server to apply the policy change

You will not be able to change this setting trough gpedit , local computer policy since it is overrided by the Domain security policy.

On server 2008 one way to get there is the following:
Administrative Tools
Server Manager
Features
Group Policy Manager
Forest: ...
Default Domain Policy
 Computer configuration
  Policies
   Windows Settings
    Security Settings
     Local Policies
      Security Options
        Microsoft Network Server: Digitally Sign Communications (Always)
            - Define This Policy
            - Disabled

Execute Gpupdate /force or reboot to apply policy

Trough gpedit you will be able to see the option but not change it, so I suggest that after the change you cannot scan to the folder check trough gpedit if it is disabled.
If it is not disabled, disable it at the top of the hierarchy. Something may be overriding the setting.

If it still does not work try the following, togheter with the previous setting
Domain member: Digitally encrypt or sign secure channel data (always) -> disabled

Dont forget to execute Gpupdate /force or reboot to apply policy each time you change something.

Also

are you scanning to the server using \\server_ip_address\shared_folder or \\server_name\shared_folder?
Just wondering about name resolution.
Is the domain field configured in the machine? if not you might have to specify the user for authentication like for example: user@domain.local

hope any of this helps.
0
JRMCoAuthor Commented:
Have tried this and no it still does not work.

The domain field is configured and i have tried both \\server_ip and \\server_name still no luck
0
jrtecCommented:
Can try to scan to a shared folder on a user computer, just to compare.

Back to the server:
Make shure that the user being used for authentication as permissions on the share and on the security tab.
Also on the if you have the firewall on, check if you have an exception for windows file sharing and the scope, or just for test just turn off the firewall.
0
JRMCoAuthor Commented:
I have now solved this. For future reference in the server connections netBios had been disabled.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Peripherals

From novice to tech pro — start learning today.