Microsoft Hyper-V Virtual Machine connect problem

Hello, Experts,

I have Hyper-V (v6.0.6001.18016) running on host OS Windows Server 2008 x64 SP1 with a guest Virtual Machine running Windows XP SP3.

Suddenly, using Hyper-V Virtual Manager's "Connect..." option, I can no longer reach my guest XP VM (even though it is definitely running).

Here's the error message popup I get (jpg also attached):
    Virtual Machine Connection:
        This user account cannot access the virtual machine's video.  If you this this is an error...

And on the console:
    Authorization failed
        Check to make sure you are authorized to view this virtual machine's video

I also tried to RDP to it, but got a blank / black screen.

TIA.
_RD
hyperv-connect-problem-for-EE.jpg
rdefuriaAsked:
Who is Participating?
 
rdefuriaAuthor Commented:
These comments do not fill the bill.  Will close this question.
0
 
Syed Mutahir AliTechnology ConsultantCommented:
http://blogs.msdn.com/virtual_pc_guy/archive/2008/01/17/allowing-non-administrators-to-control-hyper-v.aspx

Have a look at the above link which tells you how to modify permissions / authorizations for Hyper-v VMS

Were you able to access with the user you are logged in before ?

Any permission / settings changes ?
0
 
rdefuriaAuthor Commented:
Well, I am running as the Administrator.  I had seen that site but assumed it would not apply to me as I am running as Administrator on the host (and on the guest).

Prior to this error surfacing sometime in April, I had been running this way (since Oct. 2008, in fact).

No permissions / settings changes on the host or on the guest.

But I did apply security updates to the host.  I backed those out and still no good.
0
Network Scalability - Handle Complex Environments

Monitor your entire network from a single platform. Free 30 Day Trial Now!

 
TeethingCommented:
log in to the xp machine via rdp and add the server computer account to the local administrators group.

Is this on a domain or workgroup ?

If this is a domain, check to see if there were an GP changes that would remove log on rights.
0
 
rdefuriaAuthor Commented:
workgroup.

currently both Hyper-V manager connect and RDP to guest (XP) machine fail, as indicated above.
0
 
TeethingCommented:
Edit:  Just saw that rdp wasn't working.

You can use computer manager, connect to a another computer and change the group permissions there or you can try using cacls.exe .


0
 
rdefuriaAuthor Commented:
Hello,

Here's how I fixed this issue -- courtesy of:
      John Howard - Senior Program Manager in the Hyper-V team at Microsoft
      http://archive.msdn.microsoft.com/HVRemote/Release/ProjectReleases.aspx?ReleaseId=3084

From the pdf in the above link, I read the following:
1. Add a user rights to remotely access Hyper-V. On the server, from an elevated command prompt, run: cscript hvremote.wsf /add:domain\user (if machine is in a domain) or cscript hvremote.wsf /add:user (if machine is in a workgroup)

So I tried the following on my box:
            cscript hvremote.wsf /add:name_of_my_local_administrator_account

And now I can successfully connect to the guest Virtual Machine via Hyper-V Manager -> Connect... and via RDP!

FWIW...
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.