2008 server r2 domain controller unable to share printer

i have a 2008 windows server R2 that is a domain controller.
i am have installed 3 network printers but are unable to make this server a print server.
telling me

Printer settings could not be saved. Operation could not be completed (error 0x0000006d9)

we have another server exactly like this working fine i am stumped. firewall is off, file and printer sharing is turned on.
SJISITAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

SJISITAuthor Commented:
why would i turn the firewall on?
why would that stop the sharing of the printer?
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
IT Pros Agree: AI and Machine Learning Key

We’d all like to think our company’s data is well protected, but when you ask IT professionals they admit the data probably is not as safe as it could be.

Darius GhassemCommented:
Read the links they will explain that the firewall being off was causing the problem this fixed my issue when I had this same problem. Once you save the information you should be ok to turn it off again.
0
Nenad RajsicCommented:
try this: steps in 2008 might be different but I am sure you'll find your way around it

Click Start, click Settings, and then click Printers.
Right-click the problem printer, and then click Sharing.
Write down the share name of the printer.
Stop sharing this printer by clicking the Not Shared radio button, and then close the printer folder.
Open Control Panel, double-click Services, select the Spooler Service, click Stop, and then click Start.
After the Spooler Service restarts, open the printer folder and re-create the printer share using the share name found in step 3. Do this by clicking Start, clicking Settings, and then clicking Printers. Right-click the problem printer, and then click Sharing. Click the Shared radio button, and then share the printer with the same name as before.



0
SJISITAuthor Commented:
thanks that works another reason i hate microsoft its my choice to not have firewall on whatever it works thanks
0
Darius GhassemCommented:
Not a problem. I'm glad it is fixed.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows Server 2008

From novice to tech pro — start learning today.