Can't pair apple wireless keyboard (aluminum)

I'm trying to connect and pair a new wireless keyboard to mac mini with Snow Leopard 10.6.3 and it's determined correctly as 'Apple Wireless Keyboard', but then I'm prompted to enter few numbers and hit return. I do that but it doesn't seem to work and I get "The pairing attempt was unsuccessful. Click 'Continue' to try again." Keyboard is on and blinking during that process and my magic mouse works perfectly so bluetooth itself seems to be ok. Any suggestions?
iivanAsked:
Who is Participating?
 
Owen RubinConnect With a Mentor PrincipalCommented:
I was going to suggest new batteries. Also, be sure that Caps Lock if off as well when you hot the keys.
Have you tried paring it with another machine to see if the keyboard is good?

It also looks like you are not alone:
http://discussions.apple.com/thread.jspa?messageID=5985530

One post I saw said to hold the return key down and at the same time select the keyboard. Not sure why that would work, but some have said it helped.

Strangely, this just happened to be on an old 12" PowerBook and a white Bluetooth keyboard. I turned off BlueTooth on the Mac, then switched off the keyboard and then back on, and the turned BlueTooth back on. That seemed to make it work once!
0
 
Craig BowmanIT Services ManagerCommented:
Have you tried pulling the batteries on the keyboard and letting it power back up yet and restarting the mac as well?
0
 
iivanAuthor Commented:
Have just tried that -- it didn't help.
0
Cloud Class® Course: Python 3 Fundamentals

This course will teach participants about installing and configuring Python, syntax, importing, statements, types, strings, booleans, files, lists, tuples, comprehensions, functions, and classes.

 
ElinKeiCommented:
See if Mouse Keys is turned on. It can stop your keyboard keys from registering when you do the pairing.

To check your System Preference settings, or to enable/disable Mouse Keys:

    1. Open System Preferences and click on the Universal Access preference pane.
    2. Click the Mouse & Trackpad settings tab.
    3. Click the "Off" radio button next to Mouse Keys.
0
 
statproConnect With a Mentor Commented:
I had this problem and had to delete the com.apple.bluetooth file from the system:

-Delete the keyboard from the bluetooth items
-Navigate to ~/Library/Preferences/com.apple.Bluetooth or ~/Library/Preferences/com.apple.Bluetooth.plist and delete both
-Restart your machine immediately
-Try and readd the keyboard.

Worked for me instantly, good luck
0
 
Owen RubinPrincipalCommented:
I recommend a point split
0
 
jhyieslaCommented:
This question has been classified as abandoned and is being closed as part of the Cleanup Program. See my comment at the end of the question for more details.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.