• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 562
  • Last Modified:

Export and importing a wildcard certificate to IIS 7.0 causes Windows 2008 to hang on restart

We have a wildcard certificate from network solutions (*.ourdomain.com).  It has been exported from IIS 6.0 with the private key and imported into Windows 2008 IIS 7.0.  When the server is restarted, it will hang on "applying user settings" at the console and you can't even ping the machine.   We have tried it on multiple Windows 2008 servers with the same result.  Booting into safe mode and removing the certificate clears up the issue.  I have tried the suggestions in this article below but it didn't work.  Has anyone seen this behavior before?

http://www.experts-exchange.com/Networking/Protocols/Application_Protocols/SSL/Q_23632109.html?sfQueryTermInfo=1+7.0+certif+ii+import+wildcard
0
libertytax
Asked:
libertytax
1 Solution
 
Shreedhar EtteCommented:
Hi,

Does this is an 3rd party certificate? If yes, then you need to install the Intermediate Certificate Bundle on the Server first and then the Certificate.

Refer this:
http://serverfault.com/questions/54020/certificate-install-causes-iis7-to-hang-on-reboot

Hope this helps,
Shree
0
 
libertytaxAuthor Commented:
I installed the Network Solutions intermediate certificates and it worked.  Thanks!
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Cloud Class® Course: Microsoft Azure 2017

Azure has a changed a lot since it was originally introduce by adding new services and features. Do you know everything you need to about Azure? This course will teach you about the Azure App Service, monitoring and application insights, DevOps, and Team Services.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now