Joining WD ShareSpace to Domain

We purchased 2 WD ShareSpace 4TB NAS devices. They seemed like a great deal for the $$$. Had all the features we needed for cheap storage. Including AD integration.
After configuring one with the basic network configs and raid configs. Time came to join it to the domain to grant permissions for AD groups. Not so easy... The options for joining to a domain are as followed.
Domain Name:
Domain NETBIOS Name: (optional)
Domain Controller IP:
Administrator:
Administrator Password:

I have entered both domain an netbios. Just domain name. Just domainname.local and all other combos. I have tried many many times, and am 100% sure username and password are correct. I have tried domain\administrator as well. I found this post that states the 2 errors I am getting with the different combos. It says it cannot join an SBS 2008 domain. One posts says to add a 2003 DC to your domain and point to that, I have tried that as well since we already had another 2003 DC. Nothing seems to work... Here is the WD fourm and below are my two errors. Any help would be appreciated!

http://community.wdc.com/t5/WD-ShareSpace/ShareSpace-2TB-to-Join-SBS-2008-Domian/td-p/5268;jsessionid=31E149517EF3FC6658BFB143EA51323A 

[NET_ERROR: Join ADS failed]
[KINIT_ERROR: 'Preauthentication failed']

Thanks
pvbuckleAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Davis McCarnOwnerCommented:
Well, for starters, it isn't just WD's having this problem.  I found this on a Seagate furum: http://forums.seagate.com/t5/BlackArmor-NAS-Network-Storage/blackarmor-220-can-t-join-to-domain/m-p/43933
"I finally figured it out.  I had two issues.  The first is that the NAS server was trying to resolve DNS externally instead of internally, so it got our outside IP, which meant it couldn't reach my internal domain.  The second issue was a bonehead one on my part.  I was placing the name of the DNS server in the Domain NetBios Name field instead of the name of the domain.  If the domain name field is domainname.companyname.com, the Domain NetBios Name should be domainname.  I also entered the internal IP address of the local domain controller for the DNS server and viola."
0
pvbuckleAuthor Commented:
After talking to WD support, they confirmed - does NOT work with 2008 domains... No plans on new firmware either... So they are basically useless... DO NOT PURCHASE THE WD SHARE SPACE!!! unless you plan to stay on 2003 forever.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
kucelkjCommented:
I upgraded my firmware today and was successfully able to add my WDShareSpace to my domain. Firmware version 2.3.02.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
SBS

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.