Exchange 2010 Coexistence with Exchange 2007

Hi there,

I currently have an Exchange 2007 server in NJ. I set up an Exchange 2010 server is LA. What do I have to do for them to operate in coexistence and communicate with each other seamlessly? Thank you.
mizgroupAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

mizgroupAuthor Commented:
I have a VPN setup between the sites already.
0
AkhaterCommented:
if both are part of the same exchange organization & both are running all the exchane roles they should be already working.

Are you able to exchange emails between btoh? What problems are you running into?
0
mizgroupAuthor Commented:
Yes both are part of the same organization and both machines have all the roles. I created a mailbox on the 2010 server and tried to access it via OWA but was unable to. I get this error: Outlook Web Access is currently unavailable. If the problem continues, contact technical support for your organization and tell them the following: No Client Access servers of the appropriate version can be accessed from the Internet. Just so you know I didn't install the client access role right away as i thought I might not have needed it. I installed it after all the roles. Is that a potential problem?
0
Big Business Goals? Which KPIs Will Help You

The most successful MSPs rely on metrics – known as key performance indicators (KPIs) – for making informed decisions that help their businesses thrive, rather than just survive. This eBook provides an overview of the most important KPIs used by top MSPs.

AkhaterCommented:
plz when you try to go owa use https://2k10IP/owa a d try again does it work? if it does then your solution is easy?
0
mizgroupAuthor Commented:
Yes it is working actually.
0
AkhaterCommented:
well then u dont have a problem it is just that you should set your CAS 2k10 as your owa address instead of your 2k7.
0
mizgroupAuthor Commented:
do i have to do that? what if i wanted to keep my 2k7 server as my owa?
0
AkhaterCommented:
well exchane 2K7 cannot redirect to 2K10

2k10 can redirect & proxy to 2k7
0
mizgroupAuthor Commented:
Aha i see. what about my incoming mail. can i have mail going to either of the servers and they will route to each other as needed?
0
AkhaterCommented:
Yes if both have the cas role installed, as u told me, email routing wont be an issue
0
mizgroupAuthor Commented:
For some reason i can send mail externally but not internally
0
AkhaterCommented:
U cannot send from 2k10 to 2k7 nor vice versa?

What are the status of your queues ? Where are the email stuck?
0
mizgroupAuthor Commented:
sending from 2k7 to 2k10 internally works as well.
0
mizgroupAuthor Commented:
I sent from 2010 to an external email address no problem. i also received one no problem. I tried to send an email internally but it is stuck in the hub version 8 queue.
0
mizgroupAuthor Commented:
Do i have to change permissions in my receive connectors?
0
AkhaterCommented:
No you don't
when you go to the queue where they are stuck what is the last error ? can you share a screenshot ?
0
mizgroupAuthor Commented:
Well i actually had to change my receive connector on my exchange 2007 server to allow Exchange server authentication and to allow permissions for exchange servers under the users.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
AkhaterCommented:
then it was changed at some point it time :)

everything working fine now ?
0
mizgroupAuthor Commented:
Yep working great, thanks for all your help
0
mizgroupAuthor Commented:
Problem now, iphones and blackberrys arent working for mailboxes that have been moved to the new server? any suggestions?
0
AkhaterCommented:
are these phones using the 2007 cas or the 2010 one ?
0
mizgroupAuthor Commented:
They are using the 2007 CAS.
0
AkhaterCommented:
then go back to my first post you should hit primary the 2010 one
0
mizgroupAuthor Commented:
As for the iphone i set it up to the 2010 server and it worked. as for the blackberry i cant do that as its 4.1 and not compatible with exchange 2010
0
AkhaterCommented:
as you just said BB 4.1 is not compatible with exchange 2010

how else can I help you ?
0
mizgroupAuthor Commented:
You can use 2007 CAS roles as a proxy in between
0
AkhaterCommented:
I didn't get it  sorry is this a confirmation or a question ?
0
mizgroupAuthor Commented:
Hahaha that is a fact.
0
AkhaterCommented:
ok maybe I don't deal with BB
0
AkhaterCommented:
I answered all the OP questions
0
mizgroupAuthor Commented:
Ok but i posted the end solution. If i accept yours as a solution people will not come out with the right answer
0
AkhaterCommented:
Are you talking about the BB thing ? is this what all the thread was about ?
0
mizgroupAuthor Commented:
about the receive connector
0
AkhaterCommented:
Ok this is too big to re-read I though you were referring to the BB issue.

0
mizgroupAuthor Commented:
oh no not at all, the main point of this is the receive connectors, thanks for all your help again.
0
AkhaterCommented:
your welcome!
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.