Firefox has forgotten all my forms

Hi- Using FF 3.5.5 on XP SP3. Every few days it forgets all my form input, like user names, although once I type in the user name it remembers the password. Then maybe the next day, it will remember my user names again.

Also, I'm entering a lot of new products. When I needed to enter the product name again in a new field, FF used to prompt me after the first couple of letters with the product name I've been typing in. Now I have to type in the whole thing. Again, that will probably fix itself in the next day or two.
Melody ScottAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Marc ZCommented:
You might want to confirm your settings are not auto deleting.
Go to Tools->Options->Privacy->History and select Firefox will "Use Custom settings".  And set it appropriately.  Make sure Clear History when Firefox closes is not checked, and if it is, look at the Settings next to it.
Melody ScottAuthor Commented:
thanks, trying that and it's not working as yet. I tried logging into an account, then logging out and in again, and it didn't remember my user name. I'll kepp trying as the day goes on and see if it starts remembering. Thanks for helping.
mrichmonCommented:
I had an issue where if I entered my specific username into a login screen - it would not remember to autocomplete it - but woudl autocomplete every other username that started like mine - and would remember min on other computers.

It turned out I needed to re-create a new firefox profile and everything went back to working.  Sounds like that may be the solution for you as well...
Big Business Goals? Which KPIs Will Help You

The most successful MSPs rely on metrics – known as key performance indicators (KPIs) – for making informed decisions that help their businesses thrive, rather than just survive. This eBook provides an overview of the most important KPIs used by top MSPs.

Melody ScottAuthor Commented:
How do I do that, mrichmon?
Melody ScottAuthor Commented:
Well, all that did was annoy me! LOL. It removed all my bookmarks, etc. I can't do that, so I recreated my original default profile. Unless I was supposed to point my new profile to the old folder?
Marc ZCommented:
No, first we test with a new profile.  If things go smoothly, THEN we import from old profile.
mrichmonCommented:
You will still be able to import your bookmarks and cookies, but you need to see if it solves the issue first while the profile is clean...
Melody ScottAuthor Commented:
Hi- I'll do it as soon as I get some time, thanks!!
InfotechflyerCommented:
If a site uses autocomplete="off" then look at this article for a bookmarklet to remove that autocomplete attribute.
http://kb.mozillazine.org/User_name_and_password_not_remembered 
https://www.squarefree.com/bookmarklets/forms.html#remember_password (bookmarklet)
Melody ScottAuthor Commented:
Hi- Firefox is remembering all my info again, and I haven't done anything. Rebooting doesn't help, it just suddenly doesn't offer me a dropdown for any fields. Even if I'm (for instance) entering new products, usually when I start to type 'chicken wellington" into another box, usually it will offer me some options, but last week it was just empty. Now all is back as it should be.

I don't think creating anther profile is going to solve this one.Also, I don't think the autocomplete answer is the solution, since when it happens, it happens on all sites.
Marc ZCommented:
Well, glad to have tried to help you this once, anyways.
You might want to update as well, sometimes that fixes small bugs as well. Currently 3.6.3
Melody ScottAuthor Commented:
I guess I still want to leave this open, because the problem will crop up again. Thanks.
Melody ScottAuthor Commented:
Hi- two hours after that last post, Firefox has again stopped prompting me to fill in fields. It still is remembering my passwords. I'm starting to be tempted to dump FF and use chrome!
Marc ZCommented:
mel

Can you please give us the list of Firefox Add-ons you have installed?


Is it possible you are occasionally accidentally hitting
Ctrl + Shift +Del

This page gives you more info on the Form Autocomplete with a troubleshooting section.
http://support.mozilla.com/en-US/kb/Form+autocomplete?style_mode=inproduct

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Melody ScottAuthor Commented:
Hi, Add-ons are firebug, google toolbar for FF,  igoogle tab remover, java quickstarter, Microsft .net framework assistant 1.1, New Tab home page, and Norton IPS and Norton Toolbar.

Thanks for telling me what it's called! Form auto-complete. OK, will read that thanks!
Marc ZCommented:
Norton huh,  does either one of those have a Clear Private Data option?
And Google Toolbar might also have some privacy settings, I would think.
I don't think Firebug clears data, unless of course, you are testing pages.  It might.
I really think going through each of those Add-ons Settings or options might help pinpoint something.  Keying in on any Forms, Privacy, Auto-complete, Clear... options.
Melody ScottAuthor Commented:
I looked at options, thanks- the only one that gives me options is google toolbar, on the others the options buttons is grayed out. Do you think the next time it stops giving me the form autocomplete I should try disabling the add-ons one by one?
Marc ZCommented:
You could, but disabling any addon requires restarting firefox and that by itself might be fixing your issue. I'm curious, the Norton's items, are you using a Norton product for security? Antivirus, antimalware, privacy?  If yes, where are the settings for it?
By the way, Firefox Safe Mode disables and resets all preferences.
Melody ScottAuthor Commented:
The norton product is Norton 360, and yep it's my security. I can disable the two Norton addons, and see if that helps in the long run.

If not, should I start Firefox in safe mode when the problem occurs, and see if it still happens?
Marc ZCommented:
Yes, that would be good troubleshooting.
Melody ScottAuthor Commented:
Interesting.. it happened again, I disable firebug, and it started working immediately. I will close this ticket and award points if it is still working tomorrow. Too bad though, I like firebug. I guess I can enable it when I need to troubleshoot.
Melody ScottAuthor Commented:
Hi- It was Firebug. Haven't had the problem since I disable it. Thanks for your help.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Web Browsers

From novice to tech pro — start learning today.