How do we fix our problem with our Windows 2008 Domain Controller ?

We have a Windows 2008 DC and another Windows 2003 DC on our domain.  Earlier today the Windows 2008 server stopped allowing clients to browse to it, whether it be by using the \\servername\share or by trying to open up a Network drive.  When we tried to do this we kept getting a message saying:

\\servername is inaccessible.  You might not have permisson to use this resource.

Logon Failure: The Target Account name is incorrect

We checked on the Windows 2008 DC and there were very little errors to give us much of a clue apart from the 5774 NETLOGON System error below:

The dynamic registration of the DNS record '_ldap._tcp.Default-First-Site-Name._sites.DomainDnsZones.ourdomain.local. 600 IN SRV 0 100 389  servername.ourdomain.local.' failed on the following DNS server:  

DNS server IP address: ::
Returned Response Code (RCODE): 0
Returned Status Code: 0  

For computers and users to locate this domain controller, this record must be registered in DNS.  

USER ACTION  
Determine what might have caused this failure, resolve the problem, and initiate registration of the DNS records by the domain controller. To determine what might have caused this failure, run DCDiag.exe. To learn more about DCDiag.exe, see Help and Support Center. To initiate registration of the DNS records by this domain  controller, run 'nltest.exe /dsregdns' from the command prompt on the domain controller or restart Net Logon service.
  Or, you can manually add this record to DNS, but it is not recommended.  

ADDITIONAL DATA
Error Value: Bad DNS packet.

We tried running the commands listed there but it didn't work and we have deleted all old DNS records for an old DNS server which has now been removed but clients still cannot connect to their fileshares etc.

Can anyone offer any advice about how to fix this please ?

Many thanks in advance
PurityITAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Darius GhassemCommented:
Make sure the clients are pointing to internal DNS servers only. Run dcdiag /fix on the server.

Does this DC have the same name as another that has been removed?

0
PurityITAuthor Commented:
Hi Darius - The clients were indeed pointing to the internal DNS servers only. Thanks for your help though

Shreedhar - The post you provided gave me an indication of what was wrong.  It wasn't the solution in the post but something else that someone had suggested in the link below:

http://support.microsoft.com/?id=329721

After I reset the password with netdom I then went into DNS and deleletd all traces of our old DNS server which had recently been removed.  After this was done I then rebooted and the shares became available for the users

0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Active Directory

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.