Crystal Enterprise XI - R2 - Error

Hello, I have a report that runs on Oracle 11g in the back. The report was running daily without any errors until last week. Oracle was upgraded from 9i to 11g last week. So, we installed ORacle 11g client on the Crystal Enterprise (CE) server as well. The report is failing ever since the database was upgraded to 11g. Though, Oracle 11g client is installed on CE Server, and the ODBC is recreated to use the new driver, the report is failing with the error below:
"Error in File D:\Program Files\Business Objects\BusinessObjects Enterprise 11.5\Data\procSched\hhcrystal2.reportjobserver\~tmp1c9461b87e1c1dd3.rpt: Unable to connect: incorrect log on parameters. "
The report runs just fine on my local PC. Can someone please HELP me out on this issue? Thanks so much
rustypootAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

mlmccCommented:
Did you give permissions to the database and all views, tables, and stored procedures?

Did you update the report to use the new connection?
You may have to open the report and do a Verify Database

mlmcc
0
rustypootAuthor Commented:
Thx; I will test and let you know.
0
rustypootAuthor Commented:
I tried all of the things that you mentioned; but no luck. Still same error!
0
Python 3 Fundamentals

This course will teach participants about installing and configuring Python, syntax, importing, statements, types, strings, booleans, files, lists, tuples, comprehensions, functions, and classes.

mlmccCommented:
How are you running on your local PC?

mlmcc
0
rustypootAuthor Commented:
On my local PC, I have Oracle 11g client installed. So, I just point to the Data Source and run the rpt. No errors! But on CE Server, we can not get it to work;
0
mlmccCommented:
Are you running in the Crystal designer or through an application?

mlmcc
0
mlmccCommented:
Do you need to install the client on other user machines?

Do other users have permissions on the server to the client?

mlmcc
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
rustypootAuthor Commented:
ok I found out why this is an issue - we have XIR2 SP$ and Oracle 11g is not compatible with SP 4. So we need to upgrade to SP 5!
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Crystal Reports

From novice to tech pro — start learning today.