I am looking for help to add an additional T1 interface to my Cisco 1841.

Hello,

We have a Cisco 1841 router, currently configured with one T1 interface.  We are having bandwidth issues in our office, and have purchased a second T1 line, which has already been installed in the building, but has yet to be connected to and configured on our router.

I am looking for help modifying my configuration to bundle the two T1's into one 3mb interface...   my current configuration is below:

1841#sh run
Building configuration...

Current configuration : 1412 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname 1841
!
boot-start-marker
boot-end-marker
!
logging buffered 51200 warnings
!
no aaa new-model
!
resource policy
!
mmi polling-interval 60
no mmi auto-configure
no mmi pvc
mmi snmp-timeout 180
ip subnet-zero
ip cef
!
!
!
!
ip domain name xyz.com
!
username ***** privilege 15 secret 5 $1$1bZI$4RPuYCyb1l83rTltCGsZE/
username ***** privilege 15 secret 5 $1$dSra$YpbzYJS7CmT9y5a6m9vYz1
!
!
!
interface FastEthernet0/0
 description -----> LAN-side connection to NSA 240
 ip address 63.246.78.81 255.255.255.240
 duplex auto
 speed auto
!
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial0/0/0
 description -----> T1 connection to Norlight
 no ip address
 encapsulation frame-relay
 service-module t1 timeslots 1-24
 frame-relay lmi-type ansi
!
interface Serial0/0/0.1 point-to-point
 description -----> default gateway
 ip address 66.84.152.10 255.255.255.252
 frame-relay interface-dlci 500 IETF
!
ip classless
ip route 0.0.0.0 0.0.0.0 Serial0/0/0.1
!
ip http server
ip http access-class 23
ip http authentication local
ip http timeout-policy idle 60 life 86400 requests 10000
!
!
control-plane
!
!
line con 0
 login local
line aux 0
line vty 0 4
 privilege level 15
 password ********
 login
 transport input telnet
!
end


I spoke to Cisco, who verified that the router is capable of bundling the circuits, even though from the router specifications it is not technically recommended.  They sent me these commands to show a sample configuration, but I am not exactly sure how to implement them:

Here is a configuration example for a 1841 with two WIC-1DSU-T1-V2:


Router# configure terminal
Router(config)# interface Multilink1
 ip address 72.165.114.18 255.255.255.252
 no shutdown
 no cdp enable
 ppp multilink
 multilink-group 1


Router# configure terminal
Router(config)# interface Serial0/1/0
Router(config-if)# no ip address
Router(config-if)# encapsulation ppp
Router(config-if)# no shutdown
Router(config-if)# service-module t1 framing esf
Router(config-if)# service-module t1 linecode b8zs
Router(config-if)# service-module t1 timeslots 1-24
Router(config-if)# no fair-queue
Router(config-if)# ppp multilink
Router(config-if)# multilink-group 1
Router(config-if)# end
Router# write


Router# configure terminal
Router(config)# interface Serial0/2/0
Router(config-if)# no ip address
Router(config-if)# encapsulation ppp
Router(config-if)# no shutdown
Router(config-if)# service-module t1 framing esf
Router(config-if)# service-module t1 linecode b8zs
Router(config-if)# service-module t1 timeslots 1-24
Router(config-if)# no fair-queue
Router(config-if)# ppp multilink
Router(config-if)# multilink-group 1
Router(config-if)# end
Router# write



Can someone help me with that the finished configuration should look like?  Perhaps a more important question is 'Should I be attempting this?'.  I wrote the initial configuration a couple of years ago, but I am a Cisco 'noob' and haven't attempted this type of configuration before.

Thanks!

Scott
LVL 1
meelnahAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

sidetrackedCommented:
you are spot on, config below is part of an old (working) config we used some years ago for bundeling 8 E1 interfaces to reach 16 mbit. same principal

!
interface Serial2/1
 description --- s2-1
 bandwidth 2048
 no ip address
 no ip redirects
 encapsulation ppp
 serial restart_delay 0
 no fair-queue
 ppp multilink
 multilink-group 1
!
interface Serial2/2
 description --- s2-2
 bandwidth 2048
 no ip address
 no ip redirects
 encapsulation ppp
 serial restart_delay 0
 no fair-queue
 ppp multilink
 multilink-group 1
!
0
meelnahAuthor Commented:
Ok...

So I would just create a second serial interface named Serial0/0/1, configure it the same way as the first EXCEPT adding the ppp multilink and multilink-group 1 lines to set up the 'bundling' or load balancing?  I also would need to add the ppp multilink and mulitlink-group 1 lines to the serial0/0/0 address then...

My IP address on the WAN side of the router is defined on the fractional interface (I think that is the correct term... please correct me if I am wrong) serial0/0/0.1.  Can this stay 'as-is', or does it need to be modified as well?

thanks for the help!
0
chad_rCommented:
I noticed that your first T1 is Frame Relay, and assuming your second is as well you would be configuring a multilink frame-relay bundle (MFR), not MPPP.  Also, based on your config this appears to be your ISP connection.  Is that correct?  Did you order your second T1 from the same provider?  You will need to work with them to see if they support this on their end as well.  If so, they can probably walk you through their standard config.  In reality though it's not overly complicated, and is very similar to what you have posted above.  

The following example shows the configuration of bundle "MFR1". Serial interfaces 5/0/2:0 and 6/0/0:0 are configured as bundle links.

You will need to create a logical MFR  interface, and move the configuration options such as IP, etc from the current serial subinterface.  

This is a very basic example, but you should work with your provider to see what they support.

interface MFR1
 no ip address
 frame-relay multilink bid router1
!
interface MFR1.1 point-to-point
 ip address 66.84.152.10 255.255.255.252
 frame-relay interface-dlci 500 IETF

interface Serial0/0/0
 encapsulation frame-relay MFR1
 frame-relay multilink lid first-link
 frame-relay multilink hello 9
 frame-relay multilink retry 3

interface Serialx/x/x
 encapsulation frame-relay MFR1
 frame-relay multilink ack 4

some helpful troubleshooting commands:

show frame-relay multilink
show frame-relay multilink mfr1 (or physical interface) detail
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

meelnahAuthor Commented:
Hi Chad,

yes, my first T1 is a frame-relay, and the second came from the same ISP.  This is our company's connection to our ISP.  I am looking through your recommendations and puzzling things out now...

is sidetracked's method incorrect, or is this a case where we have two workable solutions?

Scott
0
chad_rCommented:
it's close, but for frame relay, you need to use frame relay multilink, not ppp multilink, and you do need to create the mfr interface and migrate your logical config.
0
sidetrackedCommented:
i missed that we were talking about frame relay here, not very common in sweden.

sorry for my misstake
0
meelnahAuthor Commented:
no worries, sidetracked!  I still thank you for your input!
0
meelnahAuthor Commented:
I have been working with my ISP, and although they won't take responsibility and view the config to 'ok' it, I think I am close... care to take a look and see if it's workable?

1841#sh run
Building configuration...

Current configuration : 1412 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname 1841
!
boot-start-marker
boot-end-marker
!
logging buffered 51200 warnings
!
no aaa new-model
!
resource policy
!
mmi polling-interval 60
no mmi auto-configure
no mmi pvc
mmi snmp-timeout 180
ip subnet-zero
ip cef
!
!
!
!
ip domain name
!
username ***** privilege 15 secret 5 $1$1bZI$4RPuYCyb1l83rTltCGsZE/
username ***** privilege 15 secret 5 $1$dSra$YpbzYJS7CmT9y5a6m9vYz1
!
!
!
network-clock-participate wic 0                                                
network-clock-participate wic 1                                                
network-clock-select 1 T1 x/x/x                                                
network-clock-select 2 T1 x/x/x                                                
!

interface FastEthernet0/0
 description -----> LAN-side connection to NSA 240
 ip address 63.xxx.xxx.xxx 255.255.255.240
 duplex auto
 speed auto
!
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
Interface MFR0
Description ---->Multi-Link Frame Bundle
Bandwidth 3072
No ip address
Encapsulation frame-relay IETF
Frame-relay lmi-type ansi
!
Interface MFR0.500 point-to-point
Description ----->connection to Norlight
Bandwidth 3072
Ip address 66.xxx.xxx.xxx 255.255.255.252
Frame-relay interface-dlci 500
!
interface Serial0/0/0
 description -----> T1 connection to Norlight
 no ip address
service-module t1 timeslots 1-24
encapsulation frame-relay MFR0
 no arp frame-relay
 no shutdown
 
!
Interface Serial0/0/1
 Description ----->T1 connection to Norlight
 No ip address
 Encapsulation frame-relay MFR0
service-module t1 timeslots 1-24
 No arp frame-relay
 No shutdown
!
ip classless
ip route 0.0.0.0 0.0.0.0 Serial0/0/0.1
!
ip http server
ip http access-class 23
ip http authentication local
ip http timeout-policy idle 60 life 86400 requests 10000
!
!
control-plane
!
!
line con 0
 login local
line aux 0
line vty 0 4
 privilege level 15
 password ********
 login
 transport input telnet
!
end

1841#

0
chad_rCommented:
Looks pretty good from here.  Historically my past company would edit the defaults and set:
 frame-relay multilink hello 4 (down from the default of 10)
 frame-relay multilink ack 2 (down from the default of 4)
 frame-relay multilink retry 3 (increased from 2 retries)

I am not suggesting changing them now, but these worked well for our situation, and you may want to consider it down the road.  I wouldn't touch them though until you have an established circuit.  Then you can worry about fine tuning.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
meelnahAuthor Commented:
The upgrade / cutover went perfectly.  Thank you so much for your help!
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Routers

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.