Body Content Type rejections

Hi all,

We're migrating from Exchange 2003 to Zimbra, and as such are running the two systems in parallel.  Since both of our emails are authoritative for the same domain (e.g. ""), we use a complex method to get them to talk to eachother.  Here's the layout:

              | Internet |
             | Gateway |
               |             |
_________        ________
| Exchange |        | Zimbra |
---------------       ------------

The gateway is just a Postfix system that does some address mangling and routes outside emails.  When the gateway receives an email for "" it routes it to Zimbra, and when it receives an email for "" it routes it to Exchange.  No problems here at all.

The Gateway is set as the smart host relay for both Zimbra and Exchange so outbound emails also go through the Gateway.  So that they can talk to eachother, we have two fake domains - "" and "".  When someone in Zimbra sends an email to someone in Exchange, they actually send to "".  The Gateway mangles the "" to "" and delivers to Exchange.  The same thing happens the other way, except the users in Exchange send to "" and the Gateway mangles and delivers to Zimbra.

Again, there is no problem with this method.

Here's where the problem lies though...  In Exchange, we "forward" from the users mailbox using the Exchange forward feature on the Active Directory record.  The only way this works in Exchange is to create a contact first with the destination address (i.e. ""), then you forward to that contact.  This works perfectly fine - for the vast majority of emails.

However, there are a small number of emails that bounce with "Body Content Type not supported".  This only occurs from Exchange to Zimbra.  We traced the problem to potentially an 8BITMIME issue, so we watched the raw network traffic.  It looks like Exchange connects, issues an EHLO, and then just disconnects!  It doesn't even try to send the email.  The server does advertise "250 8BITMIME" so it should be at least trying to send it.  It seems like it's a bug with the Exchange Contacts (many people seem to be reporting this).

Does anyone have any ideas on how to force Exchange to deliver the mail?


Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

31337Author Commented:
Looks like we may have found the solution.

In the Connector under the routing group it was set to "send HELO instead of EHLO".  However, there seems to be a bug because it was actually sending EHLO (confirmed when we looked at the network traffic) - and then ignoring the advertised settings, and then behaving as though it didn't get the 8BITMIME advertisement!

We changed it to use EHLO, and restarted the Exchange Routing service.  Our test message went through this time.  We had tried this before, but didn't realize that the Exchange Routing service had to be restarted - and Exchange, helpfully, doesn't warn you.

We'll see how it goes over the next few days.



Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Email Protocols

From novice to tech pro — start learning today.