File access problems, long path/filename

I'm dealing with a file access issue that has me stopped dead in my tracks.  Recently a couple of users indicated that they were unable to open files in a particular folder.  The strange thing is that they don't get an access denied error--when they double click the file, nothing happens.  Nothing at all.  I tried it as domain admin and had the same exact result.

Thinking it might be a bizarre permissions issue, I verified the folder is inheriting permissions from the parent folder (where they do have proper access rights), and forced apply to child objects just for good measure.  This didn't help.  I tried dragging and dropping the file to the admin desktop--no luck, nothing happened.  Right-clicking one of these problem files brings up a context menu with Open, Print, Open With, and Send To.  No option for Security, Properties, etc.  I've tried changing the target app using Open With, and THEN I get an "Access denied" error when opening the files.

My users have long and complicated paths with files nested many levels deep and I'm thinking perhaps the total path+file name is too long for NTFS.  I've tried creating new documents in the problem folder and I can only type a few characters, so that seems consistent with a path that's too long.  Realizing this, I've tried to rename the parent folders to shorter names, but I still can't open the target files.

Anyone have any idea how I can force these documents to be accessible?
flux303Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Wonko_the_SaneCommented:
An easy trick to get files with paths that are too long: Map a share somewhere in the middle of your path. E.g if your path is is
D:\this\is\a\reaaalllllllllllllly\looooong\path\
map to

net use x: \\server\d$\this\is\a\reaaalllllllllllllly\looooong\

Now you can attempt to access x:\path - if the path length is the problem this should help

0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
flux303Author Commented:
Thanks Wonko, great solution.  It worked for me.  I am waiting until tomorrow to hear if end users are having luck accessing these files and will award points if this fix works for them.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
OS Security

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.