OWA stopped working after net stop HTTP

Hi,
I've recently been working with Symantec to resolve an issue where my Symantec Endpoint Manager appears as "Offline" with the clients after I had to uninstall and reinstall the SEPM.  Anyway, today they instructed me to do the following:
Go to RUN and cmd
2.  Add loopback address.
httpcfg set iplisten -i 127.0.0.1
3. View all the IP addresses that the HTTP API is listening on to confirm 127.0.0.1 is listed.
httpcfg query iplisten
On Vista, Server 2008, Windows 7 the command for adding the loopback address is:
netsh http add iplisten ipaddress=127.0.0.1
4. Run the command >> say YES
net stop http
 I don't think that point 4 is really necessary.
 If you do it make sure to start all the stopped services again.
5. Reset IIS
iisreset
6. Brose Reporting from IIS >> should work ok.

After I ran these commands, my Outook Web Access (OWA) has stopped working and cliens out in the fileld as well as computers in-house are getting "Internet Explorer Cannot Display the Page" errors and all of my OMA devices (Blackberries) have been unable to connect to the server.  I have since rebooted the server twice, removed the loopback that Symantec had me do with the httpcfg delete iplisten -i 127.0.0.1 command and restarted the IIS services to no avail.  I desperately need to get the email working again on the Web Access as well as their blackberries ASAP!!  Can someone please help!
Windows 2003 Server Standard with Exchange 2003.  All latest SPs.
All of the services are started in services.msc and I can browse the /exchange website and access the administrator's email via "Browse" on the website in the IIS administration console.
Thank you!
LVL 5
jhill777Asked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

MegaNuk3Commented:
Change the Default Web site back to listening on all unassigned IP addresses via IIS, then do IISRESET
0
jhill777Author Commented:
Thanks for the input but unless you're referring to something else that was never changed.  
Description: (Default Website)
IP Address: (All Unassigned)
TCP Port: 80
SSL Port: 443
0
MegaNuk3Commented:
where did you run httpcfg? On the Exchange server?
0
Big Business Goals? Which KPIs Will Help You

The most successful MSPs rely on metrics – known as key performance indicators (KPIs) – for making informed decisions that help their businesses thrive, rather than just survive. This eBook provides an overview of the most important KPIs used by top MSPs.

jhill777Author Commented:
Yes.  I just ran the httpcfg query ssl command and it returned the attached.  That can't be right....right?

ssl.jpg
0
MegaNuk3Commented:
what does "httpcfg query iplisten" give you now?
0
jhill777Author Commented:
Httpqueryserviceconfiguration completed with 1168.
0
MegaNuk3Commented:
can you go into IE and hit the exserver/exchange directory does that work from the server, but not from a client workstation?
0
jhill777Author Commented:
No, I can't get to it from the server itself.
0
jhill777Author Commented:
Just doing w2003server1/exchange, right?
0
jhill777Author Commented:
W2003server1 is the name of my server, btw.
0
MegaNuk3Commented:
in IE try
http://w2003server1/exchange

and try
https://w2003server1/exchange

see if either of them bring up OWA
0
jhill777Author Commented:
Yeah, that's what I thought.  No dice.
0
MegaNuk3Commented:
you have rebooted this server right?
Make sure the HTTP Exchange Virtual Server is started under ESM (under the exchange server\Protocols)
0
jhill777Author Commented:
Yeah I've rebooted and yes, the Virtual Server is started.
0
MegaNuk3Commented:
Time for me to go to bed as it is 11PM here in the UK.... sorry

Have a look at resetting your IIS Exchange folders:
http://www.msexchange.org/tutorials/Resetting-OWA-Folder-IIS-security-permissions-Exchange-2003.html

OR
http://support.microsoft.com/?id=883380

Make sure you have your certificate somewhere handy so you can re-import it onto the web site once you verify that OWA over HTTP works OK
0
jhill777Author Commented:
It just came back up.  Here is everything that I did.  After Symantec's instructions shut down the OWA, I reversed everything I did.  Rebooted.  While looking for answers as to why the OWA still wasn't working, I noticed that the private store database was producing events saying:  The current physical size of this database (the .edb file and the .stm file) is 19 GB. This database has exceeded the size limit of 18 GB. However, the logical free space in this database has not yet been evaluated. Therefore, it is possible that this database contains enough free space to bring its logical size below the maximum size limit.  I thought I changed this a while ago to a higher GB limit but I changed it again to 75GB in the registry Rebooted.   After reboot, I noticed warnings in the event viewer saying my Exchange server's memory wasn't optimized while searching for errors for why OWA didn't come up.  I swear I added a switch a long time ago but whatever, I added the /3GB switch and the /USERVA=3030 switch to the boot.ini file.  After posting here on Experts Exchange, I decided to install the 13 microsoft updates I had available and try a reboot one last time before resetting the Exchange Folders per your instructions above.  The updates were:  2 updates per KB970892, Kb980182, KB981349, KB976323, KB980232, KB979683,KB979309, KB977816, KB978338, and KB978601.  After installation and reboot, OWA started working properly again.  Not sure if an update overwrote something or if the 3rd reboot was responsible or if rebooting after changing the boot.ini was the trick but whatever, it's working.  I did, however, just see yet another warning saying the stupid server memory wasn't optimized for Exchange but I'll deal with that tomorrow.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
MegaNuk3Commented:
So you didn't have to go through an IIS virtual directory reset?

Have a look at running the Exchange Best Practice Analyser on that server:
http://www.microsoft.com/downloads/details.aspx?displaylang=en&FamilyID=dbab201f-4bee-4943-ac22-e2ddbd258df3

ExBPA should highlight anything else that you should change.
0
MegaNuk3Commented:
Hmmm I have looked at all of the hotfixes you have mentioned and none of them relate to Exchange, IIS or OWA, so am wondering how they fixed your problem...

Oh well, at least it is all working now. Don't forget to run ExBPA on there and see if it picks anything else up.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.