26 Apr 10 10 - DHCP client is not registering the IP in the DNS server automatically.

Hi Experts,

One laptop is getting IP from DHCP server. IPconfig shows the new IP, but Ping to the <hostname> of the laptop name resolves to the OLD IP address. DNS zone also hosts the records mapped to the old IP.

DHCP server belongs to a different trusted domain (abc.com) and client PC belongs to a different trusted domain (zyx.com). In the scope of the DHCP server; both DNS servers' IP is added; means DNS server of both the domain. DHCP Scope is configured to "Always dynamically update DNS A and PTR record".

I tried with ipconfig /flushdns and then /release /renew, But still in the DNS the host record maps to the old IP.

Please advise what could be the possible reasons?

Best Regards,
Anupam
anupam1983Asked:
Who is Participating?
 
Netman66Connect With a Mentor Commented:
Delete the bad entries in DNS for this machine - both in the Forward Lookup Zone and Reverse Lookup Zone (if you have one).

Reboot the PC or run ipconfig /release then ipconfig /renew and it should be in DNS properly.

If you check the Event logs on that laptop, my guess is you'll see some DNSAPI errors relating to being unable to update DNS records.  This is just for you to visualize.

You should be good now.
0
 
Brian PierceConnect With a Mentor PhotographerCommented:
try ipconfig /RegisterDNS
0
 
mredfelixCommented:
0
Protect Your Employees from Wi-Fi Threats

As Wi-Fi growth and popularity continues to climb, not everyone understands the risks that come with connecting to public Wi-Fi or even offering Wi-Fi to employees, visitors and guests. Download the resource kit to make sure your safe wherever business takes you!

 
anupam1983Author Commented:
Thanks for the reply! but is it needed everytime when it gets the new IP from DHCP?

I've noticed the the TCP/IP option "Register this connection's address in DNS" option is not selected.

 
0
 
anupam1983Author Commented:
Hi mredfelix,

Host file on the client machine?
0
 
Brian PierceConnect With a Mentor PhotographerCommented:
>> I've noticed the the TCP/IP option "Register this connection's address in DNS" option is not selected. <<
Then select it !!!
0
 
anupam1983Author Commented:
Okay! The user has gone for a training session, when he comes back I'll take the control of his machine and will do it.

Between, do you suspect any other reasons resulting this problem?

Many thanks,
Anupam
0
 
Brian PiercePhotographerCommented:
Probably not :-)
0
 
anupam1983Author Commented:
Executed ipconfig /registerdns, and also checked that box "Register this connection's address in DNS". Waited for more than an hour; still no joy!

Could you please advise what else I should check? Reboot of the laptop was done several time. It's just the DNS host record is getting updated when there is an IP change in the client (through DHCP).
0
 
bhanukir7Connect With a Mentor Commented:
hi anupam,

try to enable scavenge of stale records on the DNS server. I am presuming that this is a windows DNS server.

please follow this article.

http://www.windowsreference.com/windows-server-2008/scavenging-automatic-purge-outdated-dns-resource-records-added-dynamically/

regards
bhanu
0
 
anupam1983Author Commented:
Wow! Thanks for all your help! I'm sorry I took 2 days to post the solution back!

Resolution is: Deleting records from DNS and then replicating with other DCs. And asked the guy to execute /release, /renew and /registerDNS and that worked! Bingoooooo! NetMan is absolutely right!

Bhanu, Aging and Scavanging is already enabled and value is 7, but I believe DHCP server has a configuration of deleting the stale records automatically and for that it requests to the DNS server. Correct me if I'm wrong.

I'll allot points to the experts as you've found some time to suggest me. Thank you all.

Best Regards,
Anupam
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.