Changing group permissions

Good afternoon expert,
Have created a site. Created group for site. When adding users to group I add the user names at 'Add Users' (GIF attached). But at Give Permissions the group name has '[No Access]' in the text box after the radio button marked Add users to a SharePoint group. And the radio button marked 'Give users permission directly' is greyed out. So I go back To Sit Settings and choose the group and click Settings and choose Group Settings but there is no place to give the group access. There is the Group Name, Group Owner, Group Settings has radio buttons on viewing and editing the membership and some radio buttons on Membership Requests but no way to change the VIsitor, Designer, Contributor, or Owner status.
What am I missing?

Thanks.

Allen in Dallas
LVL 1
Allen PittsBusiness analystAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Allen PittsBusiness analystAuthor Commented:
forgot image
Add-users-100420.gif
0
quihongCommented:
Its a three step process (I tell this to all my users, "everything comes in 3")

1) Create the Group
2) Add users to the Group
3) Assign permission to the Group

You need to assign permission to the Group (3).

Go to Site Settings->Advance Permissions (this screen shows you what groups and users have access to your site, at the site level). Click on New. In the User/Group Box type in the name of your SP group. Select Give users permission directly and select the appropriate permission.

0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
quihongCommented:
Oh, are you a site collection admin?
0
ronney_leslieCommented:
1. Clik on "Site Actions" on the right corner of that page.
2. Select "Site Settings" menu option from the dropdown
3. On the resultant page look for the heading "Users and Permissions"

OPTION 1
4. Click the link "Site collection administrators" (if it is available)
5. See if your user account is listed there.

OPTION 2
4. Click the link "People and groups" (if it is available)
5. On the left Nav look for the heading "Groups" and click it
6. Locate the "<Your Site Name> Owners" link and click on it
7. See if your user account is listed there.

BTW If you cannotr access any of the above that means you are not an administrator and you cannot give permissions to others.

Ronney
0
Allen PittsBusiness analystAuthor Commented:
Had to add the group to the that has permissions to the parent site to allow the permissions to be inherited. Apparently one could add permissions to the group specifically.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft SharePoint

From novice to tech pro — start learning today.