Blackberry Enterprise Server Express 5.0.1 on SBS 2008 64bit with Exchange 2007

I have installed BESE 5.0.1 on a SBS2008 64bit, all preinstallation met. Created BESAdmin account and did all the permissions step by step in each blackberry user. SQL 2005 tables working perfectly. Ran test and everything is OK.

The big frustrating issues is that can't log in with Active Directory Authentication. I can log in with blackberry admin user but not AD. Can't find any users in the AD.

I have reinstalled 3 times so that the password (hash) is correct and same thing.

I would appreciate the help.

tks.
amedexittAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

kenwagersCommented:
You may need to add AD groups to the SQL instance.  By default, the only AD users with rights to the database will be the BUILTIN\Administrators.

If you are not a local admin on the box, you may not have any access until it is assigned.

Add the correct AD group to the Security Logins area of Microsoft Server Management Studio (using the server level Security, not the database level Security Logins option).  For example, if you added DOMAIN\Domain users, and then granted that new login access and rights to the databases, all domain users should be able to connect with their credentials.

I would not recommend you assign all domain users rights, though.  It should be a specific group.
0
amedexittAuthor Commented:
I create new group with the AD administrator login and its not working. I have also tried adding the domain users and still not working.
0
kenwagersCommented:
What's the error?  After adding the users, did you grant rights to the individual databases?  

You need to both add the domain user to the sever, and then grant permissions to a specific database and it's objects.

You might try granting db_reader to the user or role for the desired database and see if that allows access to the system. When you are attempting to connect to the server, you are logged in as the domain user you granted rights to?
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
BlackBerry

From novice to tech pro — start learning today.