Outbound Exchange to Postfix email

How do I tell my Exchange 2003 Server to send all outbound mail to my postfix server(s)?
misterITAsked:
Who is Participating?
 
bevhostConnect With a Mentor Commented:
Yes, although it is possible to also specify a smart host in the SMTP Connector as well
go into Exchange System Manager->Connectors->SMTP Connector.

Make sure that the setting is on "Deliver through DNS."

connector.png
0
 
bevhostCommented:
Go into System Manager

Open Servers, YOURSERVER, Protocols, SMTP, Default SMTP Virtual Server Properties,
Click Delivery TAB, Advanced Button
Change Smart Host to the IP addrss of your postifx server

smarthost.png
0
 
ncheungCommented:
You can create or modify your a SMTP connector on your exchange routing group to direct all content to a smart host (which is your postfix server).

You address space should be "*" as you want all your traffic using that connector and assure that the cost is the lowest within your routing group.  Then you can specify this connector for your organization or just the routing group.

Try this tutorial on how to setup a SMTP connector in Exchange 2003.
http://www.msexchange.org/tutorials/Configuring-SMTP-Connector.html
0
Making Bulk Changes to Active Directory

Watch this video to see how easy it is to make mass changes to Active Directory from an external text file without using complicated scripts.

 
misterITAuthor Commented:
bevhost

I did see that. My Exchange server is already set up like that and forwarding to our postfix server. I'm wanting  Exchange to send all outbound mail to another one temporarily. Is that all I have to do is change the smart host in advanced delivery? Why are my options to start, stop the virtual smtp server grayed out? Additionally I get an error "the virtual server instance is not running when clicking on current session.

Thanks.
0
 
bevhostCommented:
Do you have more than one connection under protocols->SMTP ?
0
 
misterITAuthor Commented:
bevhost

Using Exchange manager on my PC leaves these options grayed out even though I'm an admin..weird. However when I view exchange manager on the Exchange server itself..they are not grayed out. So once I edit the SMTP smart host address to point to another postfix server...is it safe to say all I need to do is restart the SMTP virtual and not reboot the box itself?
0
 
bevhostCommented:
just restart the smtp virtual, not the whole server.
0
 
bevhostCommented:
Just being a member of 'Administrator' group probably isn't enough for that.
I alwsys RDP to the server for such things.
0
 
misterITAuthor Commented:
So what if I wanted to take the postifx server out of the email flow entirely and just send out to the internet..leave the smtp virtual server blank?

thanks again for you time.
0
 
misterITAuthor Commented:
Thanks again for your info and help.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.