Need to "Record What You Hear" in Win7 from Jet Audio & Sound Card

New install Win7. Latest driver from SB for Audigy 2 ZS installed and works well. Jet Audio Record mode won't do "What You Hear" mode.

Is there anyone out there who is able to record "What You Hear" in Win 7?

Same in prog Audacity.

Recordings are made but just nothing but silence.
Onboard sound is disabled. Playback and recording is set to SB card as default. Recording level is more than adequate.

Just banging my head on a wall.
CaptainPickardAsked:
Who is Participating?
 
CaptainPickardAuthor Commented:
As I noted in all my research on the Creative Labs Forum:

The functionality of the "Record What You Hear" seems to be a "matter of time" issue. That is, if I simply wait some 15 minutes or so it self enables without any assistance or tweaking any settings. It just won't work on bootup for whatever reason. Audacity records with all default settings during install. Jet Audio records. All is well I just have to wait it out. I think a lot of the problem was my wanting for it to work right away, and then after tweaking it death it would start to work, I would credit something, reboot and repeat. I ended up crediting proper function to so many different attributes that I discovered the common denomenator between them all was the fact that nothing worked until a certain amount of time had passed, and that it finally working after a tweak was pure coincidence.
0
 
hutnorCommented:
Try this.

Just go to control panel - sound - recording - right click under the list of available devices - choose "show disabled devices" - enable "stereo mix" - go to properties - adjust the levels (the default is 0 for some reason)
1
 
nobusCommented:
-in the audio and sound applet>audio tab check if the correct input  is selected
0
Upgrade your Question Security!

Your question, your audience. Choose who sees your identity—and your question—with question security.

 
CaptainPickardAuthor Commented:
Hutnor:I've read this on a forum but this "stereo mix" feature doesn't exist to be enabled

nobous: Both Jet Audio and Recording Tab in Windows sound are set to "What You Hear"
0
 
nobusCommented:
that is not what i posted...
0
 
CaptainPickardAuthor Commented:
Are you not referring to the Jet Audio prog as the "the audio and sound applet"?
0
 
nobusCommented:
no the one from Control panel i meant - sorry for being not clear
0
 
CaptainPickardAuthor Commented:
Those interested can follow on this forum
http://forums.creative.com/t5/Windows-7/Cannot-record-quot-what-you-hear-quot-with-latest-x64-drivers/m-p/554579

basically boiled down to random selectiveness in deciding when & wants to work or not. Swapping identical working sound cards no help
0
 
MereteCommented:
Hi CaptainPickard I'm running Windows 7 Professional 32 bit, and use Audacity to record from the stereomix..
I can tell you it was tricky trying to get this stereomix to function with my Realteck PCI audio card
 this is how I achieved it, hopefully it can assist you even though we use different tools
there is several steps I had to do to achieve this, and believe it or not I still need to change it back in order to hear what I recorded in Audacity,
ok step 1
R/click the Audio volume on the taskbar > open recording devices>highlight one and the r/click it go to properties and tick both options show disabled devices>show disconnected devices,
you should now see the stereomix. make it default for recording.
Step 2
Now highlight  the stereomix >properties> you see 5 tabs.. General. Listen.. Levels. enhancements..Advanced
In the enhancements>disable all sound effects
untick DC offset if ticked.
Click on the Speakers tab and select Speakers not the Realtek digital output.
apply and ok
in the Levels>put it just below the center I use 35 balance ok apply
done..

In audacity I have set it to show the  Audio Toolbar above for easy switching
 I had to check the "  output "  preferences and make sure it was using  Windows DirectSound :Speakers (realtek HD Audio)
and  "Input" :Windows DirectSound:Stereo Mix (realtek HD audio)
And that works,
 in order to playback in Audacity what I just recorded i have to switch the "Output "DirectSound :Speakers (realtek HD Audio) to Windows DirectSound  RealTek Digital Output (realTek HD Audio

Audacity.jpg
0
 
MereteCommented:
0
 
CaptainPickardAuthor Commented:
mods ...will revisit this info next week...
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.