SAN Zoning RA4100

I have an RA4100 array hooked up to a Brocade 3200 switch that I am trying to learn how to configure zoning.  If I directly hook up my Proliant ML350 server using the HP supported Storageworks PCI-X HBA to the RA4100 via an SC fibre cable, I am able to see the RA4100 when using the SmartStart CD. I was able to successfully create a LUN and access it in Windows.  

However, if I try to connect both the ML350 HBA and the RA4100 to the Brocade switch, when I run the SmartStart CD, it does not see the RA4100 in the ML350 (perhaps it doesn't load the HBA driver because it doesn't see the RA4100 since it is hooked up to a switch?).  In the Brocade, I can see the ports green light change from the right to the left, and the PortStats screen goes from completely blank to showing frames transmitted, so I know there is a physical connection for both the ML350 and the RA4100 according to the switch.

Since I tried setting up zoning, but couldn't see the RA4100 in SmartStart, I tried clearing out the config, as I read if you do this, it is wide open and everything can see everything.  The RA4100 still won't appear in SmartStart.

Any suggestions on what to try to get the RA4100 to be recognized by the switch and/or SmartStart?
B1izzardAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Gerald ConnollyCommented:
NB the RA4100 is an FCAL device, so set the switch up accordingly!  i.e. force the switch port connected to the RA4100 to be FL.
Check your switch licenses to make sure it supports loop devices. (Can't remember when this feature went away!)
Make sure HBA is in Fabric mode not FCAL as well.
Once you get all this done, check that the switch can see the RA4100 (via the nameserver etc)
Check this web-site for more info
   http://www.dectrader.com/docs/set2/emr_na-lpg85078-1.pdf
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
B1izzardAuthor Commented:
Thanks a million!   After going through the manuals, I did find reference to setting in loop mode.  The commands were:

portcfglport 0,1
portcfglport 1,1
portcfgshow

That did the trick.  I can see the RA4100 from the HBA on the Proliant.  Thanks again!
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Storage

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.