Problems with USB stick via RDP to Windows 2008 R2

We upgraded our servers to Windows 2008 R2, and we have problems reading USB sticks through RDP v5.2.

When the user logon the terminal server via RDP, we see the USB device but when you click it its not possible to open it. It just says "File exists"

It seems like Windows 2008 R2 does something with the way it read the index the USB device or something, as it works perfect thru RDP 6.0

Thanks for any help or tips!
LVL 1
Mr WooberAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

B HCommented:
...why not update people to RDP 6.0 (or even 7.0)?

in 7.0 on win7 or vista, all the video processing can be done on the local machine, which is a huge advantage - no more choppy graphics.

if you can't, lets look at the stick.  is there something special about it?  maybe an auto-run or something that the rdp can't understand?

give it a drive letter on the server and see if you can access it:
net use j: \\tsclient\e   (or whatever letter it is on the client machine)
start > run > j:\
0
Mr WooberAuthor Commented:
Well, the problem is that we use Itona thinclients and the USB stick is connected in this. But I also tried this with a laptop, and gets the same issue using the same RDP version.

If I use RDP 6 or 7 its works with no hassle, formating the USB stick would not be an option. So if there is some registry setting or something I could try on the terminal server, and see if that work?

Thanks for your help!
0
B HCommented:
it's not a registry setting kind of thing... it's the server not understanding what the usb stick is, rdp5 isn't giving it enough info.

lets look at the stick.  is there something special about it?  maybe an auto-run or something that the rdp can't understand?

give it a drive letter on the server and see if you can access it - do this on rdp as the user:
net use j: \\tsclient\e   (or whatever letter it is on the client machine)
start > run > j:\
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Mr WooberAuthor Commented:
This solution works in DOS, but when I click on the USB device in Windows Explorer it says "Not accessible". Is there a way to turn off some settings in Windows 2008 so it reads the USB storage correctly?
0
Mr WooberAuthor Commented:
This solution works in DOS, but when I click on the USB device in Windows Explorer it says "Not accessible". Is there a way to turn off some settings in Windows 2008 so it reads the USB storage correctly?
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft Server OS

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.