Third party certificate for terminal services

Everytime I connect to a terminal services server at a customer I get a "The identity of the remote computer cannot be verified..."
I want this certificate to be my thirdparty thawte certificate.
However, when I try to choose it under rdpcertificate the list comes up empty.
I have tried importing it under certificate mmc to computer account under personal AND remote desktop.
Its a windows 2008 R2.
cert-error.jpg
rdpcert.jpg
LVL 2
mathiesen-dataAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Jordie77Commented:
Do you have a correct certificate? Is it generated for that specific server and / or goal?
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
cyberkiwiCommented:
The error message is saying the server you are connecting to does not have a thawte/verisign trusted certificate. Are you trying to connect using your local certificate?
0
cyberkiwiCommented:
From the .domain.local, it also shows that you are connecting using a LAN name instead of FQDN.  If you have a thwate certificate, it would only be served up if it matches the FQDN of the RDP connection.
0
IT Pros Agree: AI and Machine Learning Key

We’d all like to think our company’s data is well protected, but when you ask IT professionals they admit the data probably is not as safe as it could be.

mathiesen-dataAuthor Commented:
How would I check which goal it is generated for, and what should it say? I did it on another 2008 servers IIS to generate the CSR.
I choose MSIIS for the type of certificate, so this could be the problem.
0
mathiesen-dataAuthor Commented:
I disagree Cyberkiwi. Is says that I connect with another name than the one that the server has a certificate for.
0
mathiesen-dataAuthor Commented:
If I connect using the ip adress I would get an error saying that it doesnt match.
0
mathiesen-dataAuthor Commented:
Finally solved it.
When choosing to import the certificate, the default setting is to import files ending on .cer and not the .pfx which appearently contains the private key.
The way I noticed was that it was missing the key icon marked with the blue circle.
certstore.JPG
0
mathiesen-dataAuthor Commented:
Ultimately the certificate wasnt the correct kind
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft Server OS

From novice to tech pro — start learning today.