Third party certificate for terminal services

Everytime I connect to a terminal services server at a customer I get a "The identity of the remote computer cannot be verified..."
I want this certificate to be my thirdparty thawte certificate.
However, when I try to choose it under rdpcertificate the list comes up empty.
I have tried importing it under certificate mmc to computer account under personal AND remote desktop.
Its a windows 2008 R2.
cert-error.jpg
rdpcert.jpg
LVL 2
mathiesen-dataAsked:
Who is Participating?
 
Jordie77Commented:
Do you have a correct certificate? Is it generated for that specific server and / or goal?
0
 
cyberkiwiCommented:
The error message is saying the server you are connecting to does not have a thawte/verisign trusted certificate. Are you trying to connect using your local certificate?
0
 
cyberkiwiCommented:
From the .domain.local, it also shows that you are connecting using a LAN name instead of FQDN.  If you have a thwate certificate, it would only be served up if it matches the FQDN of the RDP connection.
0
Simplify Active Directory Administration

Administration of Active Directory does not have to be hard.  Too often what should be a simple task is made more difficult than it needs to be.The solution?  Hyena from SystemTools Software.  With ease-of-use as well as powerful importing and bulk updating capabilities.

 
mathiesen-dataAuthor Commented:
How would I check which goal it is generated for, and what should it say? I did it on another 2008 servers IIS to generate the CSR.
I choose MSIIS for the type of certificate, so this could be the problem.
0
 
mathiesen-dataAuthor Commented:
I disagree Cyberkiwi. Is says that I connect with another name than the one that the server has a certificate for.
0
 
mathiesen-dataAuthor Commented:
If I connect using the ip adress I would get an error saying that it doesnt match.
0
 
mathiesen-dataAuthor Commented:
Finally solved it.
When choosing to import the certificate, the default setting is to import files ending on .cer and not the .pfx which appearently contains the private key.
The way I noticed was that it was missing the key icon marked with the blue circle.
certstore.JPG
0
 
mathiesen-dataAuthor Commented:
Ultimately the certificate wasnt the correct kind
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.