SBS 2003 Server / w3wp.exe 100% when using mobile synchro

Hi,

I'm going to be crazy with a problem who appear 7 days ago, without any reason, on a serveur who works fine since 1,5 years.

I explain :
We have 6 mobiles, like iPhone who's using push notification, sync calendar and contact.
When i made a request/push of an iPhone (or other phone) the process w3wp.exe is growing up to 80/100%. The sync works fine but slow. The service w3wp.exe still using 80/100% of cpu for 1 minutes and then going to 0%.
I identified that the problem is in IIS, the Application Pool called ExchangeApplicationPool. When I stop this Pool, the w3wp.exe process is going down to 0%.
I was on the Microsoft website and see this article : http://support.microsoft.com/kb/941439/en-us?fr=1
I've isntalled this KB, but now when we receive a new mail, push doesn't work anymore. I must make a manually sync to have my mail on my phone. I will try to go back with this update today.

So, i really need your help on this case. Thanks a lot!
julienhubschAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

DMTechGrooupCommented:
http://blog.whitesites.com/w3wp-exe-using-too-much-memory-and-resources__633900106668026886_blog.htm

Seen where a couple people stated it was the ASP.net.. you might try reinstalling or verifying you have all the latest updates to dotnet.
MegaNuk3Commented:
were they large mails you were synching like that MS article you posted said?

Have a look at putting this hotfix on there instead:
http://support.microsoft.com/kb/970103 (ActiveSync & 100% CPU)

where the update is from 2009 and not 2007 like you posted. (different files though)
julienhubschAuthor Commented:
Hi All,
@DMTechGroup : I've made some update on my SBS 2003, and reboot in few hour to see if it's work or not.
@MegaNuk3:Thanks for your link, I've seen this article too, but it's about the store.exe processus, not w3wp.exe, that's why i'm not using this hotfix... what do you think about that?
Simplify Active Directory Administration

Administration of Active Directory does not have to be hard.  Too often what should be a simple task is made more difficult than it needs to be.The solution?  Hyena from SystemTools Software.  With ease-of-use as well as powerful importing and bulk updating capabilities.

MegaNuk3Commented:
your choice... the message is pulled from the store and sent to the device so a little recent hotfix there might help...

Have you run the Exchange Best Practice Analyser SBS 2003 Version:
http://www.microsoft.com/downloads/details.aspx?familyid=3874527A-DE19-49BB-800F-352F3B6F2922&displaylang=en

to see if ExBPA highlights anything?
julienhubschAuthor Commented:
I will see if i will make this update or not...

About ExBPA, the only thing I can see is this :
-----------------------------------------

Task Offloading is enable
Task Offloading is enabled and should be disabled on Windows Small Business Server 2003. Change the value of the DisableTaskOffload registry key to 1. For detailed instructions,  see the Knowledge Base article "You experience intermittent communication failure between computers that are running Windows XP or Windows Server 2003" at http://go.microsoft.com/fwlink/?LinkId=95149. If the DisableTaskOffload registry key does not exist, then manually create this registry key and set its value to 1.
MegaNuk3Commented:
I'd do what ExBPA says...

Maybe do this:
1.) remove hotfix 941439
2.) perform the ExBPA change

Are you still having issues? If so apply hotfix 970103
julienhubschAuthor Commented:
Ok it's done. I will restart the server in the next hour and tell you if it's better or not

Thanks!
MegaNuk3Commented:
Ok, I look forward to the update.

What timezone are you in? the question says "Pacific Daylight Time (GMT-07:00)" so you must be on a night shift or something.

I am in the UK (GMT) or now BST (British Summer Time)
julienhubschAuthor Commented:
I'm in france, GMT+1... I think we are on the same timezone
MegaNuk3Commented:
update your timezone in your profile because a lot of experts sometimes only look for problems in the same time zone as themselves, so they don't spend all night working on problems (USA and Aus/NZ). alanhardisty and demazter are both in GMT and they are both great Exchange Experts.

I look at almost all issues, but prefer ones that are on the same time zone as me or nearby so I won't get lots of e-mails when I should be in bed... ;-)
julienhubschAuthor Commented:
it's updated, thanks for the tips :o
I cannot restart my server today, i will do it tomorrow at the first time
thanks
MegaNuk3Commented:
OK, fingers crossed...
julienhubschAuthor Commented:
I've made all updates that MS wants to install with windows update withtout any good change... Same problem.... :/ Maybe I must try your update about store.exe....!?
julienhubschAuthor Commented:
I've identified that an specific account cannot sync calendar (it's the only one who has problem of sync)... I tried on different iPhone without any result.. Perhaps must I try to delete this account and recreate one to see if it's better?
I will test it tomorrow and let you know the result too
Thanks again ;)
MegaNuk3Commented:
Update the store.exe

try export the Calendar with exmerge and see if it reports any errors in the exmerge.log file for the calendar entries. that will help you work out which one is corrupt.
julienhubschAuthor Commented:
Hi MegaNuk3. Hope you've passed a nice week end.

I'm back with some news :
I've installed the KB 970103 (ActiveSync & 100% CPU), reboot the server... and... no change :/
I've deleted the account I suspect, but no change too...

About your exmerge, can you tell me exactly what I must do and how it work?
Thanks
MegaNuk3Commented:
Use exmerge.exe in merge mode to export the users mailbox to PST. It will report on any corrupt items. If you want, you can tell exmerge to just export the user's Calendar folder. when the exmerge finishes look in the exmerge.log for any items it says are corrupt, it should say "error" in front of them. It normally errors and tells you the message/appointment subject so you can find it easily in the user's mailbox and decide if you want to delete it or recreate it.
julienhubschAuthor Commented:
Hello

I've tried to do a Exmerge on the Administrator mailbox to see how it work. I've only 3 or 4 mail in this box

It failed, but don't know why...

You can see the report :

****************************************************************
Microsoft Exchange Mailbox Merge Program, v6.5.7529.0
Start Logging:April 26, 2010   16:10:26
****************************************************************
[16:10:26] Logging Level: None
[16:10:26] Reading settings from file 'D:\Exmerge\EXMERGE.INI'.
[16:10:26] Reading list of subjects for messages to be selected from file ''
[16:10:26] Reading list of attachment names for messages to be selected from file ''
[16:10:26] List of folders to be ignored has been read. 0 folders in the list.
[16:10:26] Current machine locale ID is 0x40c
[16:10:26] Operating System Version 5.2 (Build 3790)
[16:11:27] Accessing Domain Controller 'B2F-SRV'
[16:11:27] 'B2F-SRV' is running Exchange Server 2000 or later
[16:11:27] Mailbox '/o=B2F/ou=first administrative group/cn=Configuration/cn=Servers/cn=B2F-SRV/cn=Microsoft System Attendant' will be ignored as its DN contains strings in the ignore list
[16:11:27] Mailbox '/o=B2F/ou=first administrative group/cn=Configuration/cn=Connections/cn=SMTP (B2F-SRV)/cn={12A53696-325E-433C-B4A5-AD7816D6C9B3}' will be ignored as its DN contains strings in the ignore list
[16:11:27] Mailbox '/o=B2F/ou=first administrative group/cn=Recipients/cn=SystemMailbox{12A53696-325E-433C-B4A5-AD7816D6C9B3}' will be ignored as its DN contains strings in the ignore list
[16:11:27] Found 8 mailbox(es) homed on database 'PREMIER GROUPE DE STOCKAGE/BANQUE DE BOîTES AUX LETTRES (B2F-SRV)'.
[16:11:27] Ignored 3 mailbox(es) homed on database 'PREMIER GROUPE DE STOCKAGE/BANQUE DE BOîTES AUX LETTRES (B2F-SRV)'.
[16:11:27] Found 8 mailbox(es) homed on the specified databases.
[16:11:27] Ignored 3 mailbox(es) homed on the specified databases.
[16:13:15] Using attribute 'PR_MESSAGE_DELIVERY_TIME' for date operations.
[16:13:15] Merging data into target store. The program will copy only those messages that do not exist in the target store.
[16:13:15] Associated folder data will NOT be copied to the target store.
[16:13:15] Using 'French' (0x40c) as the default locale (Code page 1252)
[16:13:15] All mailboxes will be processed, regardless of locale
[16:13:15] Using default locale for all mailboxes
[16:13:15] Initializing worker thread (Thread0)
[16:13:15] Copying data from mailbox 'Administrateur' ('ADMINISTRATEUR') on Server 'B2F-SRV' to file 'D:\EXMERGE\PST\ADMINISTRATEUR.PST'.
[16:13:16] Store 'MSPST MS' was not opened.
[16:13:16] Errors encountered. Copy process aborted for mailbox 'Administrateur' ('ADMINISTRATEUR').
[16:13:16] Number of items copied from the source store for all mailboxes processed: 0
[16:13:16] Total number of folders processed in the source store: 0
[16:13:16] 0 mailboxes successfully processed. 1 mailboxes were not successfully processed. 0 non-fatal errors encountered.
[16:13:16] Process completion time: 00:00:00




Any Idea ?
Thanks!
MegaNuk3Commented:
hmmm try on a normal mailbox. Exmerge will not change any data in the mailbox unless "Archive" mode is used.

maybe the account your are using does not have rights to open the mailbox. You can test it by creating an Outlook profile that prompts for credentials and then using the exmerge account to log into the mailbox (to prove the exmerge account has mailbox access)
MegaNuk3Commented:
Might be because the mailboxes are in French:
"Store 'MSPST MS' was not opened Store 'MSEMS' was not opened
The Store 'MSPST MS' was not opened or Store 'MSEMS' was not opened errors might be seen in the ExMerge log file (ExMerge.log) after merging data from the recovery storage group has failed. These errors typically indicate a language localization mismatch problem. The errors can usually be resolved by entering the correct localized names for the MAPI services on which ExMerge depends.

For detailed instructions, see How to Discover and Configure the Correct Names for MAPI Services.
http://technet.microsoft.com/en-us/library/aa997045(EXCHG.65).aspx"
julienhubschAuthor Commented:
Hi again,

I've followed you'r link, and now it works with Administrator account...

When i try to do the same with an user account, it didn't work and in log file i can see this :


****************************************************************
Microsoft Exchange Mailbox Merge Program, v6.5.7529.0
Start Logging:April 27, 2010   11:56:26
****************************************************************
[11:56:26] Logging Level: Maximum
[11:56:26] Reading settings from file 'D:\Exmerge\EXMERGE.INI'.
[11:56:26] Data directory name read from .INI file: 'D:\EXMERGE\PST'.
[11:56:26] Merge action read from .INI file: 0
[11:56:26] DomainControllerForSourceServer read from INI file: 'b2f-srv'
[11:56:26] SrcServerLDAP-Port read from INI file: '389'
[11:56:26] Source server name read from .INI file: 'B2F-SRV'.
[11:56:26] Entered Routine:  (CADRoutines::IdentifyFamilyOfExchangeRunningOnServer)
[11:56:26] Entered Routine:  (CADRoutines::GetNamingContextData)
[11:56:26] BaseDN: 'LDAP://B2F-SRV:389/rootDSE'
[11:56:26] Ending Routine:  (CADRoutines::GetNamingContextData)
[11:56:26] Default Naming Context: 'DC=B2F,DC=local'
[11:56:26] Entered Routine:  (CADRoutines::GetNamingContextData)
[11:56:26] BaseDN: 'LDAP://b2f-srv:389/rootDSE'
[11:56:26] Ending Routine:  (CADRoutines::GetNamingContextData)
[11:56:26] Default Naming Context: 'DC=B2F,DC=local'
[11:56:26] Accessing Domain Controller 'B2F-SRV'
[11:56:26] Entered Routine:  (CADRoutines::GetExchangeServerNameInfo)
[11:56:26] BaseDN: 'LDAP://B2F-SRV:389/CN=Microsoft Exchange,CN=Services,CN=Configuration,DC=B2F,DC=local'
[11:56:26] Got IDirectorySearch interface
[11:56:26] Set search preferences
[11:56:26] Filter used: '(&(objectCategory=msexchExchangeServer)(cn=B2F-SRV))'
[11:56:26] Successfully executed directory search
[11:56:26] Ending Routine:  (CADRoutines::GetExchangeServerNameInfo)
[11:56:26] 'B2F-SRV' is running Exchange Server 2000 or later
[11:56:26] Ending Routine:  (CADRoutines::IdentifyFamilyOfExchangeRunningOnServer)
[11:56:26] Source server read from settings file is 'B2F-SRV'.
[11:56:26] DomainControllerForDestServer read from INI file: ''
[11:56:26] SrcServerLDAP-Port read from INI file: ''
[11:56:26] Invalid LDAP Port number entered in INI file (''). Ignoring this setting.
[11:56:26] Destination server name read from .INI file: ''.
[11:56:26] Message selection start date read from .INI file: ''.
[11:56:26] Reading list of subjects for messages to be selected from file ''
[11:56:26] Subject string match criteria read from INI file: 0
[11:56:26] Reading list of attachment names for messages to be selected from file ''
[11:56:26] Attachment name string match criteria read from INI file: 0
[11:56:26] Folder process setting read from .INI file: 2
[11:56:26] Apply to sub folders setting, read from .INI file: 0
[11:56:26] List of folders to be ignored has been read. 0 folders in the list.
[11:56:26] DelimiterUsedInMailboxFile setting read from .INI file: 0
[11:56:26] File containing list of mailboxes, read from .INI file: 'D:\Exmerge\MAILBOXES.TXT'.
[11:56:26] The file containing the list of mailboxes to be processed, 'D:\Exmerge\MAILBOXES.TXT' is missing or inaccessable. The filename was obtained from the FileContainingListOfMailboxes .INI file setting.
[11:56:26] Remove intermediate PST files setting read from .INI file: 1
[11:56:26] Date attribute read from .INI file: 0
[11:56:26] Data import method read from .INI file: 1
[11:56:26] ReplaceDataOnlyIfSourceItemIsMoreRecent setting read from .INI file: 1
[11:56:26] Copy user data setting read from .INI file: 1
[11:56:26] Copy associated folder data setting read from .INI file: 0
[11:56:26] Copy folder permissions setting read from .INI file: 0
[11:56:26] Copy dumpster items setting read from .INI file: 0
[11:56:26] UseThisPSTFileForAllMailboxes setting read from .INI file: ''
[11:56:26] MapFolderNameToLocalisedName setting read from .INI file: 0
[11:56:26] RenameFoldersBasedOnFolderMappings setting read from INI file: 0
[11:56:26] RenameSpecialFolders setting read from INI file: 1
[11:56:26] Default Locale read from INI file: 1036
[11:56:26] UseLastLogonLocaleID setting read from INI file: 0
[11:56:26] Current machine locale ID is 0x40c
[11:56:26] Command line received:
[11:56:26] Processor architecture: Intel
[11:56:26] Operating System Version 5.2 (Build 3790)
[11:56:27] Exchange Server service name got from EXMERGE.INI file is 'Banque de messages Microsoft Exchange' (LocalisedExchangeServerServiceName entry in section [EXMERGE]).
[11:56:29] Entered Routine:  (CADRoutines::IdentifyFamilyOfExchangeRunningOnServer)
[11:56:29] Entered Routine:  (CADRoutines::GetNamingContextData)
[11:56:29] BaseDN: 'LDAP://B2F-SRV:389/rootDSE'
[11:56:30] Ending Routine:  (CADRoutines::GetNamingContextData)
[11:56:30] Default Naming Context: 'DC=B2F,DC=local'
[11:56:30] Entered Routine:  (CADRoutines::GetNamingContextData)
[11:56:30] BaseDN: 'LDAP://b2f-srv:389/rootDSE'
[11:56:30] Ending Routine:  (CADRoutines::GetNamingContextData)
[11:56:30] Default Naming Context: 'DC=B2F,DC=local'
[11:56:30] Accessing Domain Controller 'B2F-SRV'
[11:56:30] Entered Routine:  (CADRoutines::GetExchangeServerNameInfo)
[11:56:30] BaseDN: 'LDAP://B2F-SRV:389/CN=Microsoft Exchange,CN=Services,CN=Configuration,DC=B2F,DC=local'
[11:56:30] Got IDirectorySearch interface
[11:56:30] Set search preferences
[11:56:30] Filter used: '(&(objectCategory=msexchExchangeServer)(cn=B2F-SRV))'
[11:56:30] Successfully executed directory search
[11:56:30] Ending Routine:  (CADRoutines::GetExchangeServerNameInfo)
[11:56:30] 'B2F-SRV' is running Exchange Server 2000 or later
[11:56:30] Ending Routine:  (CADRoutines::IdentifyFamilyOfExchangeRunningOnServer)
[11:56:30] Entered Routine:  (CADRoutines::GetExchangeServerStorageGroupInfo)
[11:56:30] BaseDN: 'LDAP://b2f-srv:389/CN=InformationStore,CN=B2F-SRV,CN=Servers,CN=premier groupe d'administration,CN=Administrative Groups,CN=B2F,CN=Microsoft Exchange,CN=Services,CN=Configuration,DC=B2F,DC=local'
[11:56:30] Got IDirectorySearch interface
[11:56:30] Set search preferences
[11:56:30] Filter used: '(objectClass=msexchPrivateMDB)'
[11:56:30] Successfully executed directory search
[11:56:30] Ending Routine:  (CADRoutines::GetExchangeServerStorageGroupInfo)
[11:56:30] Entered Routine:  (CADRoutines::GetMailboxesHomedOnExchangeServerDatabases)
[11:56:30] Mailbox '/o=B2F/ou=first administrative group/cn=Configuration/cn=Servers/cn=B2F-SRV/cn=Microsoft System Attendant' will be ignored as its DN contains strings in the ignore list
[11:56:30] Mailbox '/o=B2F/ou=first administrative group/cn=Configuration/cn=Connections/cn=SMTP (B2F-SRV)/cn={12A53696-325E-433C-B4A5-AD7816D6C9B3}' will be ignored as its DN contains strings in the ignore list
[11:56:30] Mailbox '/o=B2F/ou=first administrative group/cn=Recipients/cn=SystemMailbox{12A53696-325E-433C-B4A5-AD7816D6C9B3}' will be ignored as its DN contains strings in the ignore list
[11:56:30] Found 7 mailbox(es) homed on database 'PREMIER GROUPE DE STOCKAGE/BANQUE DE BOîTES AUX LETTRES (B2F-SRV)'.
[11:56:30] Ignored 3 mailbox(es) homed on database 'PREMIER GROUPE DE STOCKAGE/BANQUE DE BOîTES AUX LETTRES (B2F-SRV)'.
[11:56:30] Found 7 mailbox(es) homed on the specified databases.
[11:56:30] Ignored 3 mailbox(es) homed on the specified databases.
[11:56:30] Ending Routine:  (CADRoutines::GetMailboxesHomedOnExchangeServerDatabases)
[11:56:30] Entered Routine:  (CMapiSession::CreateSystemAttendantProfile)
[11:56:30] Entered Routine:  (CAdminProfileRoutines::CreateSystemAttendantProfile)
[11:56:30] Entered Routine:  (CAdminProfileRoutines::CreateSystemAttendantProfile)
[11:56:30] Entered Routine:  (CAdminProfileRoutines::HackMapiSvcInfForSA)
[11:56:30] Ending Routine:  (CAdminProfileRoutines::HackMapiSvcInfForSA)
[11:56:30] Ending Routine:  (CAdminProfileRoutines::CreateSystemAttendantProfile)
[11:56:30] Ending Routine:  (CAdminProfileRoutines::CreateSystemAttendantProfile)
[11:56:30] Ending Routine:  (CMapiSession::CreateSystemAttendantProfile)
[11:56:30] Entered Routine:  (CMapiSession::Logon)
[11:56:30] Entered Routine:  (CMapiSession::MapiInit)
[11:56:30] Successfully initialized MAPI.
[11:56:30] Ending Routine:  (CMapiSession::MapiInit)
[11:56:30] MAPI Logon successful.
[11:56:30] Ending Routine:  (CMapiSession::Logon)
[11:56:30] Entered Routine:  (CMapiSession::GetMailboxesOnServer)
[11:56:30] Getting list of mailboxes on the server.
[11:56:30] Found default store.
[11:56:30] Opened Exchange Server Store.
[11:56:30] Entered Routine:  (CMapiSession::GetMailboxesOnServerFromPrivateIS)
[11:56:30] GetMailboxesOnServerFromPrivateIS: QueryInterface succeeded
[11:56:30] GetMailboxesOnServerFromPrivateIS: GetMailboxTable succeeded
[11:56:30] Number of mailbox records read: 12. (CMapiSession::GetMailboxesOnServerFromPrivateIS)
[11:56:30] Ending Routine:  (CMapiSession::GetMailboxesOnServerFromPrivateIS)
[11:56:30] Finished getting list of mailboxes.
[11:56:30] Ending Routine:  (CMapiSession::GetMailboxesOnServer)
[11:56:30] Session logoff successful.
[11:56:30] Entered Routine:  (CMapiSession::DeleteOurProfile)
[11:56:30] Ending Routine:  (CMapiSession::DeleteOurProfile)
[11:56:30] Time to get mailbox data: 0 seconds
[11:56:35] Using attribute 'PR_MESSAGE_DELIVERY_TIME' for date operations.
[11:56:35] Merging data into target store. The program will copy only those messages that do not exist in the target store.
[11:56:35] Associated folder data will NOT be copied to the target store.
[11:56:35] Using 'French' (0x40c) as the default locale (Code page 1252)
[11:56:35] All mailboxes will be processed, regardless of locale
[11:56:35] Using default locale for all mailboxes
[11:56:35] Program will use 1 worker threads
[11:56:35] Initializing worker thread (Thread0)
[11:56:35] ((Thread0)) Before CopyMailboxData -PRESTATAIRES
[11:56:35] Entered Routine: EDKRoutines::CopyMailBoxData)
[11:56:35] Using locale 'French' (0x40c) and code page 1252 to connect to mailbox
[11:56:35] Copying data from mailbox 'prestataires' ('PRESTATAIRES') on Server 'B2F-SRV' to file 'D:\EXMERGE\PST\PRESTATAIRES.PST'.
[11:56:35] DN of object is '/O=B2F/OU=FIRST ADMINISTRATIVE GROUP/CN=RECIPIENTS/CN=PRESTATAIRES'.
[11:56:35] Entered Routine:  (CMapiSession::MapiInit)
[11:56:35] Successfully initialized MAPI.
[11:56:35] Ending Routine:  (CMapiSession::MapiInit)
[11:56:35] Entered Routine:  (CMapiSession::CreateEMSPSTProfile)
[11:56:35] Ending Routine:  (CMapiSession::CreateEMSPSTProfile)
[11:56:35] Successfully created profile.
[11:56:35] Entered Routine:  (CMapiSession::Logon)
[11:56:35] Entered Routine:  (CMapiSession::MapiInit)
[11:56:35] Successfully initialized MAPI.
[11:56:35] Ending Routine:  (CMapiSession::MapiInit)
[11:56:35] MAPI Logon successful.
[11:56:35] Ending Routine:  (CMapiSession::Logon)
[11:56:35] Entered Routine:  (CMapiSession::GetSession)
[11:56:35] Ending Routine:  (CMapiSession::GetSession)
[11:56:35] Entered Routine: EDKRoutines::OpenStores)
[11:56:35] OpenStores: Start
[11:56:35] GetMsgStoresTable successful.
[11:56:35] Checking service 'Banque de messages Microsoft Exchange'
[11:56:35] Found service 'MSEMS' in current profile.
[11:56:35] Error opening message store (MSEMS). Verify that the Microsoft Exchange Information Store service is running and that you have the correct permissions to log on. (0x8004011d)
[11:56:35] Ending Routine: EDKRoutines::OpenStores)
[11:56:35] Errors encountered. Copy process aborted for mailbox 'prestataires' ('PRESTATAIRES').
[11:56:35] Entered Routine:  (CMapiSession::DeleteOurProfile)
[11:56:35] Ending Routine:  (CMapiSession::DeleteOurProfile)
[11:56:35] Session logoff successful.
[11:56:35] Ending Routine: EDKRoutines::CopyMailBoxData)
[11:56:35] ((Thread0)) CopyMailboxData Failed -PRESTATAIRES
[11:56:35] ((Thread0)) Incremented progress bar
[11:56:35] Number of items copied from the source store for all mailboxes processed: 0
[11:56:35] Total number of folders processed in the source store: 0
[11:56:35] 0 mailboxes successfully processed. 1 mailboxes were not successfully processed. 0 non-fatal errors encountered.
[11:56:35] Process completion time: 00:00:00
[11:56:35] MAPI uninitialized.
[11:56:39] MAPI uninitialized.
MegaNuk3Commented:
Since you have 0x8004011d this is normally a permissions error. See if the exmerge account you are using can open that mailbox. I doubt it will be able to. So you either need to give the exmerge account "receive as" on the user's mailbox or you need to give the exmerge account "receive as" permissions on the whole Exchange mailbox store.
julienhubschAuthor Commented:
Problem SOLVED !!!!!!!!!!!!!!!!!!!!!! Yeahhhhhhhhhhhh

So, I Explain :

I suspected an user account / mailbox because since I make a sync with a iphone the problem appear...

I created a new account/mail on my AD and move all data on this new account, and delete the old account... without any change...
Today, to clean up my exchange, I decide to delete the mailbox in exchange...... and the problem disappear... Can you explain me how a single account could grow up the w3wp.exe processus even if this user is not logged or not synchronise with iPhone? and why all others accounts were impacted ?
Thanks for you patient MegaNuk3

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
MegaNuk3Commented:
Was the mailbox not opened through IIS? OWA or ActiveSync?

A corrupt message/attachment can kill IIS and that would affect all the users connected by it.

So just to confirm, you deleted the AD account and the mailbox and recreated it and this fixed the problem? Did you exmerge the data out and then exmerge it back in?

Have a look in the IIS logs and see if you can see anything for that user/mailbox:
IIS logs should be under C:\Windows\system32\logfiles\W3SVC1 if you can't see your usernames then you might need to make the server log it by going into IIS Manager, Default Web Site-->Properties-->"Web Site" tab-->Properties button under "Enable Logging"-->Advanced tab-->then select all the options

ActiveSync adds some custom fields that can be read to see what is actually happening during the synch:
http://msexchangeteam.com/archive/2005/03/28/403047.aspx
julienhubschAuthor Commented:
So just to confirm, you deleted the AD account and the mailbox and recreated it and this fixed the problem? Did you exmerge the data out and then exmerge it back in?
=> Yes !!

I've seen the log but there's nothing about this account :/
MegaNuk3Commented:
So you looked in the exmerge.log for errors when exporting the data?
AND
The IIS logs don't show this user/mailbox synching before w3wp.exe died?
julienhubschAuthor Commented:
Erf... Problem appear again, 2 weeks later... dunno why... I've deleted 3 mailbox but this time it's not working :/
MegaNuk3Commented:
open another question. no-one will help for 0 points   ;-)
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.