magic mouse options do not show in sys prefrences

Hi People i have never come across this problem before so im a bit stuck for ideas even when apple tech's said they could not help. the situation i have a mac that is running osx 10.6.3 i have one at home and i have 53 of them at work that i deal with. I have recently tried to connect a magic mouse on a friends mac with all the latest updates running 10.6.3 now the mouse connects with no issue but the problem is when you select the mouse in system preferences there is no options to configure the mouse ie no box to tick two finger swipe or secondary click, scroll or screen zoom just the normal options. if anyone has any ideas please let me know.
theshowstoprAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

jhyieslaCommented:
Does your friend still have the old mouse attached?  If so, try removing it and see if that makes a difference. Apple had a software update for the Magic mouse, but I can't imagine that it hasn't been rolled into 10.6.3.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
theshowstoprAuthor Commented:
Mate thanks for the quick reply. No mouse attached even tried to install mouse 1.0 software but was not required as its already installed. Rang apple said they had a few people with the same issue but no solution. Wandering if anyone else has experienced this and had a work around.
Im not a apple expert but his is the weirdest thing I've seen.
0
jhyieslaCommented:
You might even try reinstalling the old mouse, after deactivating the Magic Mouse, and then go back through the steps to reconnect the Magic Mouse.  I added mine when I was on 10.6.1 and used the mouse 1.0 software.  If I remember, I initailly didn't see the screen for the swipe configure as you are seeing. Attributed it to my not having removed the old mouse.  At some point, got the screen to display the mouse attributes properly... seemed to remember perhaps disconnecting and then reconnecting it.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Wireless Networking

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.