Zimbra upgrade V5->V6, centos 5.4 final problems

Hi,
I've tried to upgrade zimbra vrom V5 to V6 with this package:
zcs-6.0.6_GA_2324.RHEL5.20100406144520.tgz
First I've updated centos from 5.0 to the actual 5.4. : yum install all went fine zibmra continued working.
then I've installed zimbra: ./install.sh --platform-override
Now I've get errors:
1. Tue Apr 20 21:14:34 2010 *** Running as zimbra user: /opt/zimbra/bin/zmprov -m -l -- mcf zimbraReverseProxyMailEnabled TRUE
Exception in thread "Thread-2" java.lang.OutOfMemoryError: Java heap space
      at com.sun.jndi.ldap.Connection.run(Connection.java:858)
      at java.lang.Thread.run(Thread.java:619)

2: Tue Apr 20 21:35:22 2010 Running /opt/zimbra/bin/zmprov -m -l gas mailbox
Tue Apr 20 21:35:27 2010 Checking for default IM conference room...
Tue Apr 20 21:35:27 2010 *** Running as zimbra user: /opt/zimbra/bin/zmprov -m -l -- gxc conference.infometis.ch
Exception in thread "main" java.lang.NullPointerException
      at com.zimbra.cs.account.ProvUtil.dumpXMPPComponent(ProvUtil.java:2150)
      at com.zimbra.cs.account.ProvUtil.doGetXMPPComponent(ProvUtil.java:3595)
3. Tue Apr 20 21:53:36 2010 Removing com_zimbra_search
Tue Apr 20 21:53:36 2010 *** Running as zimbra user: /opt/zimbra/bin/zmzimletctl undeploy com_zimbra_search
[] INFO: I/O exception (java.net.ConnectException) caught when processing request: Connection refused
[] INFO: Retrying request
com.zimbra.common.zclient.ZClientException: invoke Connection refused, server: localhost
ExceptionId:main:1271793221299:95ab105c5612ef6b
Code:zclient.IO_ERROR
      at com.zimbra.common.zclient.ZClientException.IO_ERROR(ZClientException.java:45)
      at com.zimbra.cs.account.soap.SoapProvisioning.invoke(SoapProvisioning.java:323)
      at com.zimbra.cs.account.soap.SoapProvisioning.soapAdminAuthenticate(SoapProvisioning.java:272)
      at com.zimbra.cs.zimlet.ZimletUtil$ZimletSoapUtil.initZimletSoapUtil(ZimletUtil.java:1377)
      at com.zimbra.cs.zimlet.ZimletUtil$ZimletSoapUtil.<init>(ZimletUtil.java:1351)
      at com.zimbra.cs.zimlet.ZimletUtil.dispatch(ZimletUtil.java:1798)
      at com.zimbra.cs.zimlet.ZimletUtil.main(ZimletUtil.java:1888)
Caused by: java.net.ConnectException: Connection refused
4.       Starting imapproxy...Failed.
Starting nginx...2010/04/20 21:51:21 [emerg] 7770#0: SSL_CTX_use_certificate_chain_file("/opt/zimbra/conf/nginx.crt") failed (SSL: error:02001002:system library:fopen:No such file or directory error:20074002:BIO routines:FILE_CTRL:system lib error:140DC002:SSL routines:SSL_CTX_use_certificate_chain_file:sys)
failed.

For a full solution I will provide the full 500 points. Any help is very appreciated. If you need the full zmsetup log file please send me a email to mruff@infometis.ch
Thank you
Martin
LVL 1
wbkAsked:
Who is Participating?
 
wbkAuthor Commented:
Solved the problem myself:
1. had to increase the amount of memory
2. had to generate the certificates manually
0
 
berniepCommented:
at a guess there might be either java or library dependancies.  have you checked the java & lib versions required for this new version of your app?
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.