Integrated Websense V7.1 Reports Showing only IP addresses

Dear Sir,

I have ISA Server 2006 installed and integrated with Websense V7.1 for web filter.
When I'm logging into Websense Manager and generating a report, I am only seeing IP addresses for the URLs instead of domain names (www.google.com  for example).  Is there any way to get the reports show the URL hostnames instead of IPs?
Websense and ISA Server are installed on the same server (Win 2003 R2).

Thanks...
LVL 1
ISC-IT-AdminAsked:
Who is Participating?
 
ISC-IT-AdminConnect With a Mentor Author Commented:
I’ve noticed that Websense is filtering for clients who have their proxy settings defined under Internet Explorer’s settings.
So I configured the clients with proper proxy settings.

Websense starts filtering and resolving users URLs.
0
 
Duncan RoeSoftware DeveloperCommented:
Are the IP addresses resolvable on the system that produces the reports? I.e. does "dig -x <ip>" display a host name in the answer section?
This is known as a "reverse lookup". The reporting software may simply not be doing it.
You could perhaps write a post-processing script to run on the report files which would substitute host names where these are available (reverse lookup doesn't work for all IP addresses).
18:28:54$ dig -x 10.255.255.2

; <<>> DiG 9.2.2-P3 <<>> -x 10.255.255.2
;; global options:  printcmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 32038
;; flags: qr aa rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 1, ADDITIONAL: 1

;; QUESTION SECTION:
;2.255.255.10.in-addr.arpa.     IN      PTR

;; ANSWER SECTION:
2.255.255.10.in-addr.arpa. 302400 IN    PTR     darkstar.local.net.

;; AUTHORITY SECTION:
255.255.10.in-addr.arpa. 86400  IN      NS      DULLSTAR.MSHOME.net.

;; ADDITIONAL SECTION:
DULLSTAR.MSHOME.net.    86400   IN      A       192.168.0.120

;; Query time: 6 msec
;; SERVER: 10.255.255.3#53(10.255.255.3)
;; WHEN: Tue Apr 27 19:20:20 2010
;; MSG SIZE  rcvd: 121

19:20:20$ 

Open in new window

0
 
ISC-IT-AdminAuthor Commented:
Hello Duncan,

When I typed dig -x IP.
I received the following error:

C:\Users\Administrator>dig -x 69.63.181.11
'dig' is not recognized as an internal or external command,
operable program or batch file.

Any Help
0
Protect Your Employees from Wi-Fi Threats

As Wi-Fi growth and popularity continues to climb, not everyone understands the risks that come with connecting to public Wi-Fi or even offering Wi-Fi to employees, visitors and guests. Download the resource kit to make sure your safe wherever business takes you!

 
Duncan RoeSoftware DeveloperCommented:
My example was from the Linux command line. Maybe you don't have dig in windows.
My windows system has nslookup - similar to dig -x. Suggest you try that - Linux output below.
Windows also seems to have hostname which might do the job (I'm only looking at the contents of the WINDOWS folder of my old Windows disk)
21:32:44$ nslookup 10.255.255.2
Note:  nslookup is deprecated and may be removed from future releases.
Consider using the `dig' or `host' programs instead.  Run nslookup with
the `-sil[ent]' option to prevent this message from appearing.
Server:         10.255.255.3
Address:        10.255.255.3#53

2.255.255.10.in-addr.arpa       name = darkstar.local.net.

21:33:24$ 

Open in new window

0
 
Duncan RoeSoftware DeveloperCommented:
Instead of deleting, can you post the soluition that Customer Service helped you to find, as it might be usefule to others? Am objecting to let you do that.
0
 
Duncan RoeSoftware DeveloperCommented:
You can the accept your solution
0
 
Duncan RoeSoftware DeveloperCommented:
Excellent!
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.