activesync with exchange 2010 and Forefront TMG - testwebsite fails on sending options with ISA error

hi all, ive run the active sync connectivity website and it churns out this error at the end

i followed this article to create the rule in TMG 2010
http://www.testlabs.se/blog/?p=199

OWA works fine

any ideas?
thanks
Testing Exchange ActiveSync
 	Exchange ActiveSync test Failed
 	
	Test Steps
 	
	Attempting to resolve the host name mail.mydomain.org in DNS.
 	Host successfully resolved
 	
	Additional Details
 	IP(s) returned: xxx.xxx.xxx.xxx
	Testing TCP Port 443 on host mail.mydomain.org to ensure it is listening and open.
 	The port was opened successfully.
	Testing SSL Certificate for validity.
 	The certificate passed all validation requirements.
 	
	Test Steps
 	
	Validating certificate name
 	Successfully validated the certificate name
 	
	Additional Details
 	Found hostname mail.mydomain.org in Certificate Subject Common name
	Validating certificate trust for Windows Mobile Devices
 	Certificate is trusted and all certificates are present in chain
 	
	Additional Details
 	Certificate is trusted for Windows Mobile 5 and Later platforms. Root = CN=Entrust.net Secure Server Certification Authority, OU=(c) 1999 Entrust.net Limited, OU=www.entrust.net/CPS incorp. by ref. (limits liab.), O=Entrust.net, C=US
	Testing certificate date to ensure validity
 	Date Validation passed. The certificate is not expired.
 	
	Additional Details
 	Certificate is valid: NotBefore = 4/14/2010 12:00:00 AM, NotAfter = 4/17/2012 11:59:59 PM"
	Testing Http Authentication Methods for URL https://mail.mydomain.org/Microsoft-Server-Activesync/
 	Http Authentication Methods are correct
 	
	Additional Details
 	Found all expected authentication methods and no disallowed methods. Methods Found: Basic
	Attempting an ActiveSync session with server
 	Errors were encountered while testing the ActiveSync session
 	
	Test Steps
 	
	Attempting to send OPTIONS command to server
 	Testing the OPTIONS command failed. See Additional Details for more info
 	
	Additional Details
 	A Web Exception occurred because an HTTP 401 - Unauthorized response was received from ISA

Open in new window

LVL 1
awilderbeastAsked:
Who is Participating?
 
awilderbeastAuthor Commented:
it works ive done it

the iis7 error is just a bug in the test website i fyou setup your device it works
0
 
Shreedhar EtteCommented:
Hi,

Check this:
http://technet.microsoft.com/en-us/library/cc441478.aspx

Hope this helps,
Shree
0
Creating Active Directory Users from a Text File

If your organization has a need to mass-create AD user accounts, watch this video to see how its done without the need for scripting or other unnecessary complexities.

 
awilderbeastAuthor Commented:
hi i ran throgh that article, its exactly the same as the one i used fron that testlabs website

aslo my firewall has two nics internal & external so no problems there

what does it mean unauthorised response from isa? is isa blocking it?

what do i need to monitor to see the result from isa?
0
 
awilderbeastAuthor Commented:
ok im not using secureID so all should be fine there

i changed authentication on the TMG rule from authenticated users to all users, now i get

A Web Exception occurred because an HTTP 401 - Unauthorized response was received from IIS7

this would be iis7 on the exchagne yes? as iis isnt installed on the TMG

under iis7 > Microsoft-Server-ActiveSync authentication is set to basic only, is that right?
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.