MPLS network design and configuration

I have six sites I have decided to link together with voice and data using MPLS I need a step-by-step instruction on how to do this?
sydnal2010Asked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

chad_rCommented:
When you say you are going to connect them via MPLS, I'm assuming you are going to use a provider for this MPLS service, and just want to know how to interface with them.  Is that the case, or are you actually procuring the circuits and routers, and want to actually configure MPLS?  My guess is it's the first, so that's what I will base my answer on.  If it is the latter, let me know and I can probably help there as well.

If you are receiving a service from a provider, such as Sprint, OBS, AT&T, etc, then the answer will depend on what you are willing to pay for.  Most providers will be happy to actually install a managed CE(customer edge) router at each site, and manage that router for you.  Depending on the provider and your network, you can peer with that router via most network protocols from another site router, or many providers will actually allow you to use that router as your gateway for client networks as well, meaning you wouldn't have to manage routing at all.  It's really up to you, your requirements, and your budget.  I would suggest sitting down with a few different providers and talking through the options, since they will do most anything, but the more they do, the more it costs.
0
sydnal2010Author Commented:
I'm actually going to procure the circuits and the routers. Also, Is there a particular circuit I should order from the provider.
0
chad_rCommented:
Hi, so just so I am sure I understand, you will be procuring routers and circuits yourself, but are you also working with an MPLS provider, or are you actually doing it all?  Meaning, you are procuring and managing all routers in the path from site to site?  
0
Discover the Answer to Productive IT

Discover app within WatchGuard's Wi-Fi Cloud helps you optimize W-Fi user experience with the most complete set of visibility, troubleshooting, and network health features. Quickly pinpointing network problems will lead to more happy users and most importantly, productive IT.

sydnal2010Author Commented:
Yes, I will be working with an MPLS service provider AT&T to be exact. Other than that, I will be managing all of the routers at both sites.
0
Texas_BillyCommented:
If you're workign with ATT, your MPLS network will consist of the following:

(1) All CE - PE communication will be using BGP for label distribution - you need to make sure your CE routers support BGP.
(2) You can redistribute OSPF into BGP if you run OSPF for route advertisement currently.  If you don't, you're better off just advertising networks into BGP.
(3) You need to define where your internet connection is going to be.  If you have an existing internet connection that all sites will share, it is from this site that you will advertise your default route into BGP so the default route is aware of it.  If you're getting internet at one or more of these sites through ATTs bundled MPLS / Internet connection, you're fine.
(4) Serial Interface encapsulation with ATT will be frame-relay IETF  

From ATT, for each site, in order to configure your CE routers, you will need:
(1) Router IP address
(2) BGP neighbor address and AS
(3) Remote AS - this will be the same on all routers

I'm assuming you'll have an internet connection at one site that all sites will share, that's the most common implementation.  In this scenario:

The hub CE router (the one that is physically onsite with your internet connection), will advertise into BGP it's local network and advertise your default route like this:

router bgp 65010  **att has to give you this AS number**
no auto-summary
redistribute static
network 1.1.1.0 mask 255.255.255.0  **this is your private subnet behind this CE router**
neighbor 10.10.10.10 remote-as 65000 **ATT gives you the remote-as and neighbor IP**
neighbor 10.10.10.10 default-originate  **this advertises your default route to the cloud**

Outside of BGP, your default route is going to go to your internet connection, probably on another router:  ip route 0.0.0.0 0.0.0.0 1.1.1.225

On the other CE routers, the ones that need to route to the hub router to get internet access, you'll configure this way:

router bgp 65011  **Att gives you these numbers too, they'll be unique at each site**
no auto-summary
network 2.2.2.0 mask 255.255.255.0
neighbor  11.11.11.11 remote-as 65000  **remote AS will be the same on all routers**
redistribute static

For these routers, your default route will point the LAN interface of the router that advertises your default route.

**Note:  You will only advertise your default route from one router**

With ATT, your ip forward protocol will be nd

When you bring these sites online, you'll be on the phone with an ATT engineer on the service provider side - you should insist on this, anyway.  

First have them verify that LMI has come up (remember your serial encap is frame relay ietf), then have them verify that BGP is up and they can see your prefixes, then have them verify they can see your default route.  Once that's done, you're golden.  --TX
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Texas_BillyCommented:
As far as a particular circuit you should order, that's a matter of how much bandwidth you need each site to have out to the cloud.  If a T1 is enough bandwidth today, then a T1 mpls connection will be fine.  --TX
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Network Architecture

From novice to tech pro — start learning today.