• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 914
  • Last Modified:

Reoccuring Issue: EventID 8dzz System.Web.HttpException File does not Exist thrown when opening Site Settings page

Previous quesiton (that I thought we had resovled) http://www.experts-exchange.com/OS/Microsoft_Operating_Systems/Server/MS-SharePoint/Q_25125210.html

Server 2003
2 servers in farm
WSS 3.0 SP2

We have a reoccuring issue when attempting to open the Site Settings page (or even the View All Site Content link) on any site within the farm (including the Administration site). When clicking the Site Settings link, the user gets the standard "Unknown Error - Troubleshoot issue with Windows SharePoint Services" message. Running the configuraiton wizard on the servers appears to fix the issue for a couple of weeks, but then it starts happening again.

Using diagnostic logging, I receive the following:


0x01E8 Windows SharePoint Services    General                        8dzz High     Exception Type: System.Web.HttpException  Exception Message: The file '/_layouts/_controltemplates/TopNavBar.ascx' does not exist.

This same error is thrown, no matter from which site I try to access the Site Settings. I have verified that the specifid file does indeed exist on both servers in the farm at

\Program Files\Common Files\Microsoft Shared\web server extensions\12\TEMPLATE\CONTROLTEMPLATES

It's certainly annoying that this pops up every few weeks, and one of our users calls to say "hey, it's broken again". Any thoughts on why this keep happening? Thanks in advance...
0
pillbug22
Asked:
pillbug22
  • 2
  • 2
1 Solution
 
larrbeCommented:
Hi,
did you check permissions on the folder \Program Files\Common Files\Microsoft Shared\web server extensions\12\TEMPLATE\CONTROLTEMPLATES - check if at the time this error is thrown there are faulted logon events inside the security event log. Perhaps the worker process account can't access the files.
0
 
pillbug22Author Commented:
I checked the site this morning and got the same error.

I re-ran the SP config wizard and restarted both servers in the farm. Checking again, still error. I guess the patch/fix didn't work this time.

I just checked the Security event log on both servers, and I have no failure message from this morning - everything is success audit.
0
 
larrbeCommented:
looks like you changed some master pages - check this link: http://www.graphicalwonder.com/?p=532 looks like your farm is "broken"
0
 
pillbug22Author Commented:
I think that may be it. Looks like opening the applicaiton.master (not even editing it) in SPD auto-removes the "~/" from the header URL references, thus breaking the links.

Opened up the page in VStudio, put the "~/" back in place, and all is working well.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Cloud Class® Course: Microsoft Office 2010

This course will introduce you to the interfaces and features of Microsoft Office 2010 Word, Excel, PowerPoint, Outlook, and Access. You will learn about the features that are shared between all products in the Office suite, as well as the new features that are product specific.

  • 2
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now