Configuring Red Hat Enterprise Linux AS release 4 to run Oracle 11g sqlldr

I have Oracle 11g installed on linux. I want to use sqlldr on the linux box.

However right now Linux does not recognize sqlldr utility, i will have to configure linux box to accomodate the Oracle installation.

How do i do that?

Here is where ORACLE_HOME and other parameters:
ORACLE_HOME=/local/apps/oracle/product/11G/
SQLLDR=$ORACLE_HOME/bin/sqlldr
gram77Asked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

woolmilkporcCommented:
Hi,
did you add $ORACLE_HOME/bin to your PATH?
Issue "echo $PATH" to check.
If it's not there, issue
export PATH=$PATH:$ORACLE_HOME/bin
and add this statement to your .profile.
wmp
0
gram77Author Commented:
Even ORACLE_HOME is not recognized.

echo $ORACLE_HOME shows nothing..

Do i need to do something here too?
0
woolmilkporcCommented:
Which user are you logged in as?
During Oracle installation you should have been instructed to create a particular userid to become the database adminstrator userid.
The home dir of this user should contain all you need, including something like "oraenv" or "dbenv" or even .profile, .kshrc or .cshrc ...
Please check!
If no luck, add manually to your .profile
export ORACLE_HOME=/local/apps/oracle/product/11G
export $ORACLE_SID=[your_sid]
export ORA_NLS=/local/apps/oracle/product/11G/nls/data
export PATH=$PATH:$ORACLE_HOME/bin  
and see how far you will get with this. Replace [your_sid] with your Oracle SID.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Big Business Goals? Which KPIs Will Help You

The most successful MSPs rely on metrics – known as key performance indicators (KPIs) – for making informed decisions that help their businesses thrive, rather than just survive. This eBook provides an overview of the most important KPIs used by top MSPs.

gram77Author Commented:
woolmilkporc:
It worked. Now I am able to use sqlldr.

Do i have to issue these exports always, or will this setting persist between sessions?

I need to make this setting permanent, what can i do?

0
woolmilkporcCommented:
As I told you - add the lines I mentioned above to the .profile initialization file in the home directory of the user you're logged in as when running e.g. sqlldr.

Don't forget to log out and log in again, to have your changes take effect.

wmp
0
gram77Author Commented:
I do not have my home directory set up. i.e /home/gram77.
0
woolmilkporcCommented:
What do you mean with "not ... set up"? Which is gram77's home as configured in /etc/passwd?
If the directory doesn't exist, create it (as root) and give its ownership to gram77 (chown...)
If there is no .profile, either create a new file named .profile containing just the above lines, or copy the skeleton from /etc/skel and add these lines to it. Don't forget to set ownership (gram77) and execute permission.
wmp
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Oracle Database

From novice to tech pro — start learning today.