New website on IIS does not work

Hello
We just had a new website designed and created for us. I was given the web files today.
After removing the old files, from the folder that contained the old website (under wwroot),
I placed the new website including the index.html home page file.
I am unable to browse our website now. Even when right clicking the website in IIS and clicking on browse , I get the unable to display page.  When using I.E I get this error " You might not have permission to view this directory or page using the credentials you supplied. HTTP Error 403 - Forbidden

When using firefox, I get This Virtual Directory does not allow contents to be listed.

I tried restarting IIS , but it did not help. I have only changed the files and have made no modification in IIS .
Thank you,
 
LVL 1
netcompAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

OMC2000Commented:


In Windows Explorer right click on your virtual directory folder, select Security Tab and
enable permissions for IUSR_computer_name user.
If you installed ASP.NET application enable permissions for ASPNET user also.

Also make sure that permissions were enabled for child folders and files

When you copy files from another computer you may lose permissions.
0
netcompAuthor Commented:
Ok, I figured some fo the issue, but there is one more thing to fix.
After enabling index.html instead of index.htm as the home page header, the issue was resolved, but I am unable to open any php links whin the webpage. The Contact US page in in php and we are unable to open it when we click on the link. How  do I enable PHP in IIS. I think that's the problem.
0
tanujchandnaCommented:
Hi,

HTTP Error 403 - Forbidden error normally comes up when you don't have index / default page under your website's wwwroot directory. As you are saying that you have index.html page in wwwroot directory that means default page is not set for your website that's why you are getting this error. Do the following steps

* Open IIS
* Right Click on website -> Properties
* Click on Documents Tab
* Click on add
* type index.html
* Click on Move up button and set this extension to the top of the list
* Click ok -> ok

and problem gets resolved for you.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft IIS Web Server

From novice to tech pro — start learning today.