I can't attach Database on asp.net application after moving files to other local machine Operating system error 5:(Access is denied)

I'm trying to set up another local testing machine for my ASP.net web site.
I can display the page that doesn't have data connections.
However, I get following error message when I try to access database.

Unable to open the physical file "C:\Inetpub\wwwroot\htdocs\App_Data\ASPNETDB.MDF". Operating system error 5: "5(Access is denied.)".
An attempt to attach an auto-named database for file C:\Inetpub\wwwroot\htdocs\App_Data\ASPNETDB.MDF failed. A database with the same name exists, or specified file cannot be opened, or it is located on UNC share.

Connection String is as below

Data Source=.\SQLEXPRESS;AttachDbFilename=C:\Inetpub\wwwroot\htdocs\App_Data\ASPNETDB.MDF;Integrated Security=True;User Instance=True

I checked all the security setting that I think of, but I can't get it work.
I installed Visual Web Developer just to see if it establishes connections SQL server.
In Visual Web Developer 2010 Express edition, I can open the database and if I press "test Connection" button in "modify connection" pop up window, I get message say "Test connection succeeded"

What am I missing??
Thank you for your help
jtuttle99Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Tray896Commented:
This site has a lot of suggestions for this error that you may want to check out:

http://www.aspspider.com/resources/Resource170.aspx
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
jtuttle99Author Commented:
4. You may want to disable the "User Instance=true" and try.
This did the job!
Also, I had some problem with "Script" folder and I had to deleted it in IIS.

Thank you very much
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
.NET Programming

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.