• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 382
  • Last Modified:

ClickOnce Error

Hi.
I was publishing my application since more than 1 year.
Now suddenly, I started getting this error:
"Cannot publish because a project failed to build."
I have searched for this error & found a lot about it but not like my case!!
my problem is that I am getting this error by itself without any other errors with it ( like the problems I found on the internet!!).
I tried to open the project on another computer & publish the application, it worked fine!!
I tried to delete the certificate & re import it again on my computer, but I am still getting the same problem!!
Any ideas?
0
TaibaDXB
Asked:
TaibaDXB
  • 13
  • 10
1 Solution
 
13598Commented:
What other error(s) do you get?
0
 
13598Commented:
The certificate you are talking about is not expired, correct? Is it the same certificate you are using in the machine that works?  How exactly are you assigning it to your project?
Are you using VS2005? Which version of .net framework?
0
 
13598Commented:
Did you try cleaning the solution (Build/Clean Solution) and rebuilding it again?
0
Cloud Class® Course: C++ 11 Fundamentals

This course will introduce you to C++ 11 and teach you about syntax fundamentals.

 
TaibaDXBAuthor Commented:
Thank you for your reply.
I am not getting any other errors!!
I am just getting the mentioned error.
I am using Visual Studio 2010 with .NET framework 4
The certificate is not expired& it is the same one that is on the other machine.
0
 
TaibaDXBAuthor Commented:
I tried also to Clean/Rebuild the solution again, but I am still getting the same error.
0
 
13598Commented:
Under the project properties/security, do you have it set as full trust application?
Under project properties/Signing, please deselect the Sign the ClickOnce manifests, save and rebuild it and try to publish it. See if you get any errors.
After that close the app, open it up again, and select the project properties/Signing, Sign the ClickOnce manifests.
0
 
TaibaDXBAuthor Commented:
It is set to full trust application.
I deselected the option to sign the clickonce, save and rebuilt & tried to publish, but got again the same error.
I closed VS & reopened it again & re-signed the application & tried to publish, but again the same error!!
0
 
13598Commented:
The machine the project can be published from has the same version of VS and .net framework, correct?
Could you post a printscreen of your properties/signing tab?
In build/configuration manager, is it setup to debug or release on the failing machine?
0
 
TaibaDXBAuthor Commented:
Both versions on both computers.
and it is setup to debug.
I have attached the printscreen
TaibaDXB.png
0
 
13598Commented:
Can you try it setup to release mode?

Can you publish other projects ok?
0
 
TaibaDXBAuthor Commented:
I have attached the error that I am getting
TaibaDXB2.png
0
 
13598Commented:
Could you please attach the properties/Signing/More Details button info as well?
0
 
13598Commented:
OK. I love print screens!!!!   Can you please post the 7 Warnings you are getting?
0
 
13598Commented:
Is there a reason why don't you use what you have under installation folder URL under the publishing location instead?
0
 
TaibaDXBAuthor Commented:
Now this is strange!!
I have created one test project & tried to publish it & I got the same error!!!
0
 
13598Commented:
Then we can assume it is not the project. Does the failing machine have this patch installed? KB919472  Add/Remove Programs click on show updates and look for it.
0
 
TaibaDXBAuthor Commented:
This patch is not installed.
I have searched for this KB, but it seems that this patch is for VS2005!!
Do I need to install this patch if I am using VS 2010 ?
0
 
13598Commented:
Does the working machine have it?
0
 
13598Commented:
Could you try something quickly for me?
Try publishing the project by selecting Build/Publish  instead of the properties/publish tab.
0
 
TaibaDXBAuthor Commented:
No
0
 
TaibaDXBAuthor Commented:
It magically works through Build/Publish :)
After that I tried from the publish tab, but it doesn't work!!!!
Can you explain that ?
0
 
TaibaDXBAuthor Commented:
It seems that the problem is from the CodeRush Add-In
I disabled it & everything worked fine.
Thank you very much for your great help.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Cloud Class® Course: Microsoft Office 2010

This course will introduce you to the interfaces and features of Microsoft Office 2010 Word, Excel, PowerPoint, Outlook, and Access. You will learn about the features that are shared between all products in the Office suite, as well as the new features that are product specific.

  • 13
  • 10
Tackle projects and never again get stuck behind a technical roadblock.
Join Now