Exchange 2003 on SBS 2003 problem - inbound email failing (NDR), internal and outbound works fine

I have a problem with SBS 2003 Exchange 2003 SP2 server, which is after removing and reinstalling IIS not willing to receive any external email. Internal sending and receiving looks fine, and also external outbound looks fine, but incoming is failing and NDR is send to the sender - error 500. I spent all day today trying to fix it, and now I need some help please! Thanks, Maurice
meilecAsked:
Who is Participating?
 
shauncroucherConnect With a Mentor Commented:
Well worth running CEICW as pointed out by MegaNuk3,

http://support.microsoft.com/kb/825763

Configure E-mail and Internet Connection Wizard Options
Below are the beginning steps for the Configure E-mail and Internet Connection Wizard for the nine most common configurations. See the Configure E-mail and Internet Connection Wizard Options table earlier in this article for the configuration that best matches your configuration. All the steps start on the Connection Type page. To reach this page, click Next on the Configure E-mail and Internet Connection Wizard Welcome page. To start the Configure E-mail and Internet Connection Wizard, click Start, click Server Management, and do one of the following:
In the left pane, expand To Do List. In the details pane, click Connect to Internet.
In the left pane, expand Internet and E-mail. In the details pane, click Connect to Internet.

Have you checked in Exchange --> Recipient policies to make sure your domain is listed in there?

http://www.computerperformance.co.uk/exchange2003/exchange2003_recipient_policy.htm

Shaun

0
 
shauncroucherCommented:
You shouldn't remove IIS without removing Exchange as well - it causes all kinds of issues.

Can you telne to SMTP port 25 and send test message internally?

Shaun
0
 
meilecAuthor Commented:
Hello Shaun, yes, I know, but I couldn't remove Exchange and IIS was broken, so I removed IIS (no errors there), reinstalled it, and that has broken it. I have run repair/reinstallation on the Exchange after putting IIS back, reapplied service pack, but it is still broken... I can internally telnet to port 25 and I am greeted by the Exchange, but don't know how to manually send test email. What's interesting is that internal email via OWA and Exchange work fine, also I can email out to external addresses, but incoming traffic is failing - sender gets #< #5.0.0> #SMTP#. Is there a hope? Maurice
0
Making Bulk Changes to Active Directory

Watch this video to see how easy it is to make mass changes to Active Directory from an external text file without using complicated scripts.

 
shauncroucherCommented:
To be quite honest, you may be on a hiding to nowhere here, as IIS is so critical to SBS, that any kind of removal and reinstall will be pretty dire. You might consider a restore from previous backup of known working system or a fresh install and recovery of databases?

If not, then test the error condition (exact error message) when sending mail using telnet. The reason OWA and outbound works is beause it is using MAPI to interface and get messages in the queue, and is then sending mail out, not accepting mail.

Check in Exchange that the recipient policy has your domain in and is ticked.

test using telnet as follows:

telnet yourserver 25
mail from:<externalemail@externaldomain.com>
rcpt to:<amailbox@yourdomain.com>
data
Test email
.

(remember the dot)

Where do you get an issue?

Shaun
0
 
MegaNuk3Connect With a Mentor Commented:
Telnet into port 25:
http://support.microsoft.com/kb/153119/en-us

telnet exservername 25
EHLO externaldomain.com
MAIL FROM: validuser@externaldomain.com
RCPT TO: internaluser@mydomain.com notify=success,failure
DATA
Subject: This is a test message
test time: 20:18
.
QUIT
0
 
MegaNuk3Commented:
@shauncroucher - sorry mate, I should of refreshed the question before posting...
0
 
meilecAuthor Commented:
Hello Shaun, I really appreciate your prompt answers, as customer is desperate to have the system up and running by the morning... I have tried as suggested, here are the results:

after mail from:<externalemail@externaldomain.com>
got 503 5.5.2 Send hello first
then, I have typed helo, and then retried mail from:<externalemail@externaldomain.com>, and got 250 2.1.0 Sender OK.

then i typed rcpt to:<amailbox@yourdomain.com> (with few vaild addresses), and always got 501 5.5.4 Invalid Address.

I'm really keen to avoid restore from the backup, but I'm happy to install exchange and iis again, if you feel that would help...

Many thanks, Maurice
0
 
MegaNuk3Commented:
So to confirm for me and shaun... you typed a few valid internal addresses and they all gave you 5.5.4 "invalid Address" ?
0
 
MegaNuk3Commented:
Since you are using SBS have you tried simply re-running the Configure Email and Internet Connection Wizard (CEICW)?
0
 
meilecAuthor Commented:
yes, if I type them in the format of <amailbox@mydomain.com>. but, interestingly, if I use only <amailbox> without the domain, then I get 250 2.1.5. Just to mention again that internal email from one account to another using Outlook works fine... Thanks, Maurice
0
 
MegaNuk3Commented:
Can you send an external e-mail to say your gmail or hotmail account? What happens when you reply to that e-mail?
0
 
MegaNuk3Commented:
Are you running any AV software or anti-spam on that SBS box?
0
 
MegaNuk3Commented:
Please tell me you aren't typing in the '<' and the '>'

try my post #31393966
0
 
meilecAuthor Commented:
yes, i can send email out to gmail (and it arrives), but when i reply i get

Delivery has failed to these recipients or groups:
mailbox@mydomain.com
A problem occurred during the delivery of this message to this e-mail address. Try sending this message again. If the problem continues, please contact your helpdesk.

 #< #5.0.0> #SMTP#

I'm running AVG Network edition, but I have disabled it as part of troubleshooting and no difference. How do I run CEICW?

Many thanks, Maurice
0
 
meilecAuthor Commented:
thanks guys! another reinstall of the exchange, reapplication of exchange and windows sp2, and the internet connectivity wizard did the trick. thanks, maurice
0
 
MegaNuk3Commented:
Thanks for the points and the update. Glad you got it all working again.
0
 
shauncroucherCommented:
Glad I could help,

Shaun
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.