Can't run Apache Tomcat as Service on Win Web Server 2008 R2

I've just installed Windows Web Server 2008 R2, and can't get Apache Tomcat to run as a Service.  

Whenever I try to start the Tomcat service I get an error that says:
"Windows could not start the Apache Tomcat 6 on LEVELSSERVER. For more information review the System Event Log.  If this is a non-Microsoft service, contact service vendor and refer to service-specific error code 0."

In the error log, I get the following two entries:
The Apache Tomcat 6 service entered the stopped state.
The Apache Tomcat 6 service terminated with service-specific error The operation completed successfully..

I found a few posts that said msvcr71.dll is missing from C:\Program Files (x86)\Java\jre6\bin or System32, or SysWow64.  I tried putting it in all of those directories and still get the error.  Please help...

Post that I tried:
http://forums.sun.com/thread.jspa?threadID=5121172&start=45&tstart=0
JT_SIROAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

CEHJCommented:
Make sure IIS isn't already running, or indeed any other kind of web server
0
JT_SIROAuthor Commented:
I do have IIS running, and will need that to.

They can run concurrently can't they?
0
CEHJCommented:
Not on the same port - make sure they're not trying to
0
Simplify Active Directory Administration

Administration of Active Directory does not have to be hard.  Too often what should be a simple task is made more difficult than it needs to be.The solution?  Hyena from SystemTools Software.  With ease-of-use as well as powerful importing and bulk updating capabilities.

CEHJCommented:
I haven't tried to run it as a Windows service, but it certainly ought to have its log file still - check it
0
objectsCommented:
> They can run concurrently can't they?

of course they can

> Not on the same port - make sure they're not trying to

the error would be different if they were
0
JT_SIROAuthor Commented:
Figured it out - I needed to install the 64 bit JRE.  Thanks -
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Java App Servers

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.