Exchange 2007 does not send emails to the internet

I installed a new Exchange 2007 server into my Exchange 2003 environment with the hub transport and client access roles. I want this 07 machine to be responsible for sending all outgoing email from my organization.

Right after installation of the 07 server, email connectivity is still working, however the email is all going out my old 03 server. In the EMC -> Organization Configuration -> Hub Transport I gave the existing SMTP Connector a cost of 2, and then created a new SMTP connector, to connect to the Internet, with a cost of 1, using DNS (MX) to for outgoing.

Now, any email I send out gets stuck in the outgoing queue on my new 07 server with the error:

451 4.4.0 Primary target IP address responded with: "421 4.2.1 Unable to connect." Attempted to failover to alternate host, but that did not succeed. Either there are no alternate hosts, or delivery failed to all alternate hosts.

As soon as I remove the new SMTP connector the emails all get sent immediately through the old  one back through my 03 server.

Any advice is appreciated.
LVL 1
alan2938Asked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Bruno PACIIT ConsultantCommented:
Hi,

Obviously, your new Exchange 2007 hub transport server is unable to dialog with external SMTP servers and is unable to deliver outgoing e-mails...

To check connectivity, open a CMD prompt on your Exchange 2007 hub transport server and type the following command:
TELNET mx1.hotmail.com 25

(where mx1.hotmail.com is SMTP server for Hotmail on Internet, you can use any other SMTP server if you want).

As a result if connectivity is good you should see a whole black window with a SMTP banner at the top line like this:
"220 COL0-MC4-F6.Col0.hotmail.com Sending unsolicited commercial or bulk e-mail...."

If the telnet command get stucked showing the message "Connecting to..." then that means your server cannot send SMTP traffic to external SMTP servers.
Just verify that DNS resolution is ok using the command:
PING mx1.hotmail.com

If DNS resolution works well the PING command you say something like "Pinging on mx&.hotmail.com [65.55.37.120]..."

If no IP address appears in the PING result then your server has a bad DNS configuration.

Have a good day.



0
alan2938Author Commented:
Hm... interesting. Turns out that somehow there was no default gateway configured and could not ping externally. So now I fixed that and can ping mx1.hotmail.com with replies, but I still cannot telnet into port 25. It just says "connecting...". I have even turned off the Windows Firewall.
0
alan2938Author Commented:
Ok, so I switched the server from having a static IP to use DHCP and I can telnet into mx1.hotmail.com 25 without any problem. So why would having a static IP prevent connections?
0
Creating Active Directory Users from a Text File

If your organization has a need to mass-create AD user accounts, watch this video to see how its done without the need for scripting or other unnecessary complexities.

Bruno PACIIT ConsultantCommented:
Hi,

The real question is "Which equipment gives you the IP address ?"...

Is there a sort of firewall between your Exchange Server and Internet ? Sort of routeur ?
What is possible is that this routeur/firewall only allow TCP traffic going to Internet from computers it has given an IP address...

Look at the IP configuration obtained from DHCP... Are all the parameters the same than those you gave statically ? Same gateway ? Same DNS ?

There might be lot of explanations about why it only works when using DHCP but it surely concerns what is around your server. I mean, to explain the symptoms we need to know the configuration of all things that are involved on the IP dialog between your server and Internet...
What is certain is that there's no issue on your Exchange server about static or dynamic IP address. The problem is then around your server.

Anyway, you should go on and find the reason of that problem because it is really not good practice to have DHCP configuration on Exchange server...

Have a nice day
0
alan2938Author Commented:
I switched the Exchange server back to static IP using the exact settings that were given through DHCP... and upon reboot, the default gateway is blank. I add it in, the machine reboots again, and it doesn't make a difference. So for whatever reason, unless my server is configured for DHCP, it has no idea what my default gateway is.
0
Bruno PACIIT ConsultantCommented:
Hi again,

Use the command ROUTE PRINT to display IP routes and look for another default gateway route (something starting like 0.0.0.0)

There might be a conflict with the IP configuration of an obsolete netcard that had existed in your server previously and had not been totally removed from registry.

Use also IPCONFIG /ALL to display the whole IP config.

If it is not "top secret" can you show us the result ?
0
alan2938Author Commented:
Sure. See images blow...
ipconfigall.png
routeprint.png
0
Bruno PACIIT ConsultantCommented:
Hmmm... There's really something strange in your ROUTE PRINT result because the default gateway route should also appear at the top of the IPv4 Route Table, not only as a persistent Route...
I just checked on my servers and computers here (Windows 2008 and Windows 7) and I can see the default route at the top...

Can you do the followinf to check for obsolete NICs :

1) Open a CMD command prompt
2) Type SET DEVMGR_SHOW_NONPRESENT_DEVICES=1
3) then type DEVMGMT.MSC
4) In the "device manager" window that appears choose "Show hidden devices" in the "display" menu.

Are there any obsolete netCards that appear under "Netcard" container ? Obsolete cards usually appears grayed...

If there are make a right click on each and choose "uninstall".

Also, can you check disabling IPv6 on your IntelPro netcard (just uncheck the IPv6 protocol on the card configuration.

The fact default gateway disappear as soon as you type it is not normal and I bet that is your problem.



It's late here. I'll check tomorrow for more informations from you .

Have a nice night
0
alan2938Author Commented:
Hm... so I did what you suggested, found one adapter that I did not need, removed it, rebooted, and still no luck. Although now my gateway is showing up in the IPv4 routing table. I also disabled IPv6, although I did not reboot afterwards. See below.
routeprint2.png
0
Bruno PACIIT ConsultantCommented:
'Morning,

Have you change the server IP address during operations ? Because on first screenshots the IP address was 192.168.211.189 and now it is 192.168.211.15 !?

0
alan2938Author Commented:
Yeah, the 211.189 IP was the DHCP assigned IP that I mimicked the first time I switched to static again. 211.15 is what it SHOULD be.
0
alan2938Author Commented:
There are bunch of LAN adapters defined in the registry, FYI...
regedit.png
0
Bruno PACIIT ConsultantCommented:
Hi,

I found this article about default gateway disappearing : http://www.techsupportforum.com/networking-forum/networking-support/476026-default-gateway-keeps-disappearing.html

Can you test the solution in this article and let us know ?
Warning : you'll have to reconfigure al IP parameters but that's not a big deal

0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
alan2938Author Commented:
Did not work. I am going to just install a fresh copy of Server 08 with a new install of Exchange 07.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Software

From novice to tech pro — start learning today.