• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1761
  • Last Modified:

Windows iSCSI driver refuses to automount after reboot.

When I reboot my Windows Server 2003 R2 server it will not auto-mount its iSCSI volume. The strangest thing of all is that under the Windows iSCSI applet it shows as "connected". In order to get the iSCSI volume truly recognized in the OS and mounted with a drive letter, I have to go into the EqualLogic SAN manager, mark the volume offline and then back online, I then go to the Windows iSCSI applet and force a disconnect and then reconnect. Something is definitely up as this also occurs on two other Windows Server 2003 servers. For the record, when I connect to the iSCSI volume I check the box to "Automatically Restore This Connection When The System Boots". This is not a behavior that is expected in a server environment and need this iSCSI resource enabled each time the server boots.
0
trance2
Asked:
trance2
  • 2
1 Solution
 
trance2Author Commented:
Shortly after I posted I found this KB article: http://support.microsoft.com/kb/870964 

0
 
oztrodamusCommented:
Also, check your volume configuration on the Equallogic and make sure you've checked the box to allow access to the volume from multiple sources.
0
 
trance2Author Commented:
I finally figured out the problem... It was because the disks were converted to dynamic disks from the normal basic disk type. After changing back to basic disk type they auto-mounted 100% of the time.  
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Improve Your Query Performance Tuning

In this FREE six-day email course, you'll learn from Janis Griffin, Database Performance Evangelist. She'll teach 12 steps that you can use to optimize your queries as much as possible and see measurable results in your work. Get started today!

  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now