Xen Server - Client Redirect

I just installed Xen Server on a Windows Server 2008 box. I've configured metaframe XP before, but this Xen interface is new to me. My problem is that Xen, by default apparently, tells published apps to connect to the hosting server's local ip (10.0.0.XXX). I use the old metaframe trick of saving the published app's link in IE to the desktop, and editing in notepad to see where it's pointing. Of course, I need it to tell the published apps to connect to the WAN IP of the web server for external users. I have read through the documentation, and I have bee all through the management tool, and the "manage secure connections" menu. I just cant get it to work right. I also don't want to have to specify user networks - I'd like to have it translate the wan IP for any user by default. Can anyone help me out here?

Ant
asmith79Asked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

AcceleraSolutionsCommented:
I think you need to configure your Web Interface Site to utilize the alternate Address mode, and then also issue a ALTADDR command on your citrix server which specifies the WAN IP.  This will ensure that when the Web Interface responds with an address for your users, it responds with the correct WAN IP you have assigned it.  Check out this URL: http://support.citrix.com/article/CTX584485
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
asmith79Author Commented:
Ok, so I set an alternate address, then I went through the management console, selected the external connection. Under 'edit secure access settings' I selected alternate, then I removed all of the gateway values from the following forms. Does that sound correct? Shouold I be selecting gateway alternate and leaving all of the gateway values? I'm waiting for 5:30 CST to do a reboot so the altaddr will take affect.

Thanks for the response.

Ant
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Virtualization

From novice to tech pro — start learning today.