SharePoint Filter Web Part Problem

Hi

I am working on a form library and I need to filter it using a filter web part
the problem is that when I try to connect my filter web part (no matter what type it is) , an exception occurs :
Exception from HRESULT: 0x80020009 (DISP_E_EXCEPTION)
everything else is working fine , I even installed sharepoint in a virtual server , applied service pack 2 , tried with a normal list , but still have the same exception only when trying to connect a filter web part to any list

do you know why this is happening

thanks for reply
LVL 1
RawasiAsked:
Who is Participating?
 
RawasiAuthor Commented:
Well I am trying this from the browser , the filter should be configured first by using the tool panel before the Connection option is activated , and by the way , I think there is one type of filter that don't have the connect property in it , I need to use the Current User Filter specifically , but I noticed that the problem is for all the types of filters
0
 
Shailaja KumarCommented:
This error can be caused because of a buggy view. Can you create another view and connect using the filter webpart.
0
 
RawasiAuthor Commented:
Well I am editing the list view that is created when I create the list , so it is the base list , I also created another view , and I get the same problem , I even installed a new version of SharePoint with Office Server on a virtual pc and still get the same error , I feel it is really strange
0
Cloud Class® Course: Python 3 Fundamentals

This course will teach participants about installing and configuring Python, syntax, importing, statements, types, strings, booleans, files, lists, tuples, comprehensions, functions, and classes.

 
RawasiAuthor Commented:
Any Help Guys ????
0
 
irinucCommented:
Hi,

one question, if I may: are you trying to do this from browser or from Designer? I tried this from browser, and I do not see the option to connect a filter web part to the library web part.
0
 
irinucCommented:
Yep, you are right, I needed to first configure the filter web part. My bad.

However, I didn't get error (I tried with several filter webparts, and all seemed alright).
I created a new forms library, added the filter web part to the default view, (I used current user filter) and tried connecting them on "Modified by" field.

Could it be that you have some customization on the library? Or the field that you use to connect is the one that causes the issue?
I would also check the features activated on the site and the services running on the farm. (maybe the Office SP Server Enterprise Site feature??)
I do not know what may be the issue, but this is what comes to my mind as possible roads to track.

Hope this give you an idea...
0
 
RawasiAuthor Commented:
Thanks a lot for your help

Actually I thought of everything you said , I mean I tried another Library , a new one with new fields and several types of fields , I always get this error , I even tried another site , then another sharepoint server on another windows server , this is what makes me wonder what is the problem here ????

any way thanks for your help , I really appreciate it.

Hope to find the solution from other experts here.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.