Convert Cisco Aironet 1131AG Lightweight AP (LWAPP) to Autonomous AP

I mistakenly bought a Cisco Aironet 1131AG that comes with the lightweight version of the software (designed to use with a controller, part# AIR-LAP1131AG-A-K9), while what I really needed was the Standalone version (AIR-AP1131AG-A-K9)

Some say its not doable, others have done it.. Have you?

Reverting from Lightweight Mode to Autonomous Mode

After you use the upgrade tool to convert an autonomous access point to lightweight mode, you can convert the access point from a lightweight unit back to an autonomous unit by loading a Cisco IOS release that supports autonomous mode (Cisco IOS release 12.3(7)JA or earlier). If the access point is associated to a controller, you can use the controller to load the Cisco IOS release. If the access point is not associated to a controller, you can load the Cisco IOS release using TFTP. In either method, the access point must be able to access a TFTP server that contains the Cisco IOS release to be loaded.
Using a Controller to Return to a Previous Release

Follow these steps to revert from lightweight mode to autonomous mode using a wireless LAN controller:

Step 1 Log into the CLI on the controller to which the access point is associated.

Step 2 Enter this command:

config ap tftp-downgrade tftp-server-ip-address filename access-point-name

Step 3 Wait until the access point reboots and reconfigure the access point using the CLI or GUI.
Using the MODE Button and a TFTP Server to Return to a Previous Release

Follow these steps to revert from lightweight mode to autonomous mode by using the access point MODE (reset) button to load a Cisco IOS release from a TFTP server:

Step 1 The PC on which your TFTP server software runs must be configured with a static IP address in the range of 10.0.0.2 to 10.0.0.30.

Step 2 Make sure that the PC contains the access point image file (such as c1200-k9w7-tar.123-7.JA.tar for a 1200 series access point) in the TFTP server folder and that the TFTP server is activated.

Step 3 Rename the access point image file in the TFTP server folder to c1200-k9w7-tar.default for a 1200 series access point.

Step 4 Connect the PC to the access point using a Category 5 (CAT5) Ethernet cable.

Step 5 Disconnect power from the access point.

Step 6 Press and hold the MODE button while you reconnect power to the access point.

Note The MODE button on the access point must be enabled. Follow the steps in the "Disabling the Reset Button on Access Points Converted to Lightweight Mode" section to check the status of the access point MODE button.

Step 7 Hold the MODE button until the status LED turns red (approximately 20 to 30 seconds), and release the MODE button.

Step 8 Wait until the access point reboots as indicated by all LEDs turning green followed by the Status LED blinking green.

Step 9 After the access point reboots, reconfigure the access point using the GUI or the CLI.


At Step 8 it fails
ethernet link up, 100 mbps, full-duplex
Ethernet port 0 initialized: link is up
button pressed for 21 seconds
process_config_recovery: set IP address and config to default 10.0.0.1
process_config_recovery: image recovery
image_recovery: Download default IOS tar image tftp://255.255.255.255/c1130-k9w7-tar.default

examining image...
%Error opening (connection timed out)Loading "flash:/c1130-rcvk9w8-mx/c1130-rcvk9w8-mx"...##################################


I have these to IOS files, I'm not sure witch best
c1130_k9w7_tar.124_10b.JDA3.tar
c1130-k9w7-tar.124-3g.JA1.tar

I have renamed to c1130_k9w7_tar.default

Firewall is off, using IP adress 10.0.0.2, TFTPD Server and I have changed root folder.


I'we also tried this prosedure
Steps to convert the AP to standalone:
 
Step 1:  Enable LWAPP console CLI allow/disallow debugging
 
   #debug lwapp con cli
 
Step 2: Enable LWAPP ignore internal reload debugging
 
   #debug lwapp client no-reload
 
Step 3: Configure IP Address on the interface
 
   (config)#interface fa0
  (config-if)#ip addr 10.0.0.3 255.255.255.0  ---->>> example IP address for the AP
 
Step 4: Download the image file from the TFTP server to the AP
 
archive download-sw /force-reload /overwrite tftp://10.0.0.2/c1130_k9w7_tar.124_10b.JDA3.tar
   ** 10.0.0.1 is the example TFTP server's IP address.  
 
Step 5: When the access point has finished copying the IOS, it should reload and boot up in IOS


Fails at step 4

I see one interesting ting, I'm not able to ping from pc to ap and vice versa. I'm able to sett IP adress
  (config)#interface fa0
  (config-if)#ip addr 10.0.0.3 255.255.255.0

Link and protocol is UP, but no ping?

I am really happy if anyone is able to help :D
josnymAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

HodepineCommented:
Well, if you can't ping you can't TFTP, and if you can't TFTP you can't upgrade/downgrade.

The APs usually use the int bvi1 interface for IP, not the FA0.

AP#show ip int brief
Interface                  IP-Address      OK? Method Status                Protocol
BVI1                       192.168.1.254   YES NVRAM  up                    up
Dot11Radio0                unassigned      YES NVRAM  up                    up
Dot11Radio1                unassigned      YES NVRAM  reset                 down
FastEthernet0              unassigned      YES NVRAM  up                    up

Try removing the IP from the fa0, and add it to the BVI1 and see if you can ping it.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Enrique MalacareSystems EngineerCommented:
I am trying to convert a 1131 Lightweight AP and everytime I try to load the image I get an error

%Error opening flash:/update/info (No such file or directory)
ERROR: Image is not a valid IOS image archive.archive download: takes 47 second

I have tried different files and I keep getting the same error.  What am I doing wrong.  Thanks in advance.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Wireless Networking

From novice to tech pro — start learning today.