SCOM 2007 R2 event 21042, everything going stale

Our SCOM installation has stopped accepting updates from clients.  The event log on the OpsMgr box has a lot of similar events:

Event Type:      Information
Event Source:      OpsMgr Connector
Event Category:      None
Event ID:      21042
Date:            4/22/2010
Time:            10:06:35 AM
User:            N/A
Computer:      xxxx
Description:
Operations Manager has discarded 15 items in management group xxx, which came from xxx.xxx.LOCAL.  These items have been discarded because no valid route exists at this time.  This can happen when new devices are added to the topology but the complete topology has not been distributed yet.  The discarded items will be regenerated.

For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.

Everything seems normal until yesterday about 11:30.  From then on, no info is actually been accepted by the OpsMgr box, and all performance data shows only data until that time.  No alerts of any kind show up for a time after that.

It is a proof of concept setup, so while I loose a lot of work I could start from scratch or restore backups, but it would be nice to get behind the reason for this and prevent it in future.
LVL 6
pnautaAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

wwwallyCommented:
Here is an article which could help you get it back up and running.
http://anandpv.spaces.live.com/blog/cns!AFCCA5892B178862!2798.entry
Start by update the SCOM MP's with the latest ones from the catalog.
Regards,
Walter
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
pnautaAuthor Commented:
Hi wwwally,

Thanks, your comments as well as your URL (which I can not access from my place of work) have helped me solve the problem.  My installation is back up again.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft Server OS

From novice to tech pro — start learning today.