crontab stopped working

Hello.
Crontab jobs used to work fine, but stopped working at a certain (random) moment.
Any hints, please shoot.
Below I'll show what happens:


root@backup:/backup# cat /etc/issue
Ubuntu 8.04.1 \n \l

root@backup:/backup# uname -a
Linux backup 2.6.24-19-server #1 SMP Wed Aug 20 23:54:28 UTC 2008 i686 GNU/Linux
root@backup:/backup# ps -ax | grep cron
Warning: bad ps syntax, perhaps a bogus '-'? See http://procps.sf.net/faq.html
  629 ?        Ss     0:00 /usr/sbin/cron
  692 pts/1    S+     0:00 grep cron
root@backup:/backup# crontab -l
# m h  dom mon dow   command
* * * * *   root   /backup/backup
root@backup:/backup# date
Thu Apr 22 11:49:42 EDT 2010
root@backup:/backup# ls -lut /backup/backup
-rwxr-xr-x 1 root root 3302 2010-04-21 12:11 /backup/backup

As you can see, on an Ubuntu 8.04 server crontab is started (I restarted it a few times, even rebooted the machine), a job is called every minute (for testing purposes only, normally it should start once a day), however something's not working properly, as the file /backup/backup was not accessed since yesterday (you can see the dates). And yesterday I ran it manually.

Any ideas?
LVL 14
Adrian DobrotaNetworking EngineerAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

tty2Commented:
* * * * *   root   /backup/backup

The word 'root' is unnecessary here. It is needed in /etc/crontab only.
'crontab -l' shows the crontab for current user. 'crontab -l -u foo' shows the crontab for user 'foo'.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Adrian DobrotaNetworking EngineerAuthor Commented:
Thank you tty2, stupid mistake by my side, easy points for you :)

The problem is solved, only one question remains: why did this stop working at a certain point? I used to have this syntax (with user specified IE root ) for ages and it worked before. Maybe an update from cron? I guess that's the explanation.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Linux

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.